none
cannot connect to aspnetdb

    Question

  •  

    Hi there , i had VWD 2008 express which was instaled with sql express 2005, when i wanted to install silverlight tools kit, i was informed that i have to use VWD express with SP1, so i downloaded it and installed it with sql express 2008, since then my life is ***. i cannot login to my site although it was working fine with sql express 2005.

    tried so many things , looked in so many places, couldn't reach anything.

    so i formated my hard disk starting everything from scratch, windows vista, iis 7, vwd 2008 express SP1, and built a new website with login page expecting that everything will work as expected but i still find that stupis error that i cannot connect to aspnetdb because of NT AUTHORITY,

     i am new to web development but i thoghut that i passed this already and now i want to focus on learning new things like silverlight. can any one help me with that, or can i install vwd 2008 SP1 without sql exprees 2008 and keep using the 2005 that was working

    thx

    Monday, November 24, 2008 2:14 PM

All replies

  • "...or can i install vwd 2008 SP1 without sql exprees 2008 and keep using the 2005 that was working

    thx"

     

    Yes. When you do the VWD set up, there is a check box that will download and install SQL Express 2008 as an optional component. Just make sure you don't check it.

     

    Also, if you have other VS Express applications, such as VB Express, or C# Express you will need to upgrade those to 2008 SP-1 as well. I suggest doing this before you download and install VWD. You do not need to upgrade to SQLExpress 2008.

     

    I am using VWD 2008 SP-1 with SQL Express 2005 and they work jsur great.

     

    I hope this helps,

     

    -Preston

    Monday, November 24, 2008 9:59 PM
  •  

    See your other thread you placed in the forums, I replied to that one.

     

    Jens K. Suessmeyer

    Monday, November 24, 2008 10:59 PM
  • Hi Jens , thanks for your reply. I dont know why i cant reply to the other thread as the reply button is not there. Well u answered the other thred with that:

     

    "i see that you want to use integrated security. So bside using SQL Server authentication instead, you can reconfigure your application pool to use an identity (instead of NetWork Service) which is priviledged on SQL Server to access the database. If you want to impersonate the user, you will have to set the appropiate settings in the web.config file for enabling impersonation."

     

     

     i'd like you to simplify things for me as i am stepping my first steps into this field, first i had everything working when i was using SQLExpress 2005 with the same connection string, so is that a new feature of SQLEpress 2008. and if so how can i reconfigure my application pool to use an identity.

     

    i apperciate your time

    Tuesday, November 25, 2008 1:52 PM