none
Unable to connect named instance even SQL Browser service is running

    Question

  • Hi,

    I have a SQL Server with only named instance installed and it's using non-standard port number 1234. I can connect it from my client via SSM by entering server name as '<Servername>\INST1, 1234' or '<IPAddress>, 1234', but failed to connect it by '<Servername>\INST1' even the SQL Browser service is running on server and status is 'Active'. I checked everything and rebooted server, no luck. What else can I do?

    Thanks,

    Steven


    starlee

    Tuesday, April 23, 2013 2:18 AM

Answers

  • Check your firewall settings, the below link might help you

    http://social.msdn.microsoft.com/Forums/en-US/sqldatabaseengine/thread/4d5e7964-c6a6-4aa5-bed5-f4134a1e3e3c/


    Thanks & Regards RAJUKIRAN L Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers.


    • Edited by rksqldba Tuesday, April 23, 2013 4:13 AM
    • Marked as answer by starlee Thursday, April 25, 2013 7:26 AM
    Tuesday, April 23, 2013 4:13 AM

All replies

  • Check your firewall settings, the below link might help you

    http://social.msdn.microsoft.com/Forums/en-US/sqldatabaseengine/thread/4d5e7964-c6a6-4aa5-bed5-f4134a1e3e3c/


    Thanks & Regards RAJUKIRAN L Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers.


    • Edited by rksqldba Tuesday, April 23, 2013 4:13 AM
    • Marked as answer by starlee Thursday, April 25, 2013 7:26 AM
    Tuesday, April 23, 2013 4:13 AM
  • >>>but failed to connect it by '<Servername>\INST1'

    Do you mean you did not specify a port number???


    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Blog: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance

    Tuesday, April 23, 2013 5:18 AM
  • please verify you are entering the right server name and instance name, if needed you can put an port number as an additional.

    check errorlog as well.


    Thanks, Rama Udaya.K (http://rama38udaya.wordpress.com) ---------------------------------------- Please remember to mark the replies as answers if they help and UN-mark them if they provide no help,Vote if they gives you information.

    Tuesday, April 23, 2013 8:00 AM
  • Reply here with error messages you are getting?

    Regards http:\\sqldbatask.blogspot.com MCTS Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker

    Tuesday, April 23, 2013 8:36 AM
  •  

    Hello,

    Could you try using another port? Please see ports used by SQL Server on the following article:

    http://www.sqlcoffee.com/Tips0011.htm

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Tuesday, April 23, 2013 10:53 AM
  • Enable UDP 1434 on my server fixed the issue. Thanks for your link. 

    starlee

    Thursday, April 25, 2013 7:26 AM