none
SQL Server 2008 Intellisense not working

    Question

  •  

    I've seen a post about this here: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3371737&SiteID=17

     

    I've installed SQL Server 2008 and for a few weeks, intellisense was working fine.  The past week, it has stopped working entirely.  I'm running version 10.0.1442.  In Tools-->Options-->Text Editor-->Transact-SQL-->Intellisense, the option to "Enable Intellisense" is turned on.  I've also made sure that SQLCMD Mode is turned off.  I've disconnected a reconnected to my database several times with no luck.  I can try to uninstall and reinstall like the guy in the post I've referenced did, but if I can help to try to find out what's wrong here, I'm willing to wait for a while before doing so.

    Monday, July 28, 2008 7:09 PM

Answers

  • It sounds like you have a corrupt installation, althoguh I'm not sure why it would fail after it had been working. Obviously, something changed, and not on the server. I recomnend (relunctantly) re-installing the tools, in case something was installed after the fact to change the binaries.

     

    Sorry we couldn't fix this over the forums!

     

    Buck

    Monday, July 28, 2008 9:37 PM
    Moderator

All replies

  • I'm assuming that you're using the feature against a 2008 system, correct? It won't work against anything lower-level than that. Be sure and check the database version as well - it should be "10".

    -Buck Woody, SQL Server Program Manager

     

    Monday, July 28, 2008 8:39 PM
    Moderator
  • That is correct, it's against an SQL Server 2008 Enterprise server.  The database version is 10.0.1442 - I realize that intellisense is not backward compatible with SQL Server 2005 and lower.  I'm opening the SQL Server 2008 client on another machine going to the same server and intellisense is working fine.  It must be something on the Client Side, not the Server Side.

     

    Monday, July 28, 2008 9:09 PM
  • Perfect - good troubleshooting. It could be a corrupt registry entry, so re-registering the setup might fix the issue. Drop to a command prompt and type:

     

    SSMS.EXE /selfreg /setup

    Monday, July 28, 2008 9:17 PM
    Moderator
  • Thanks for the suggestion.  I tried that with no luck.

     

    Just to add, I also noticed that the outlining functionality that my working SQL client has is not available in the non-working machine either.  I don't know if that will help narrow a solution.

     

    Monday, July 28, 2008 9:33 PM
  • It sounds like you have a corrupt installation, althoguh I'm not sure why it would fail after it had been working. Obviously, something changed, and not on the server. I recomnend (relunctantly) re-installing the tools, in case something was installed after the fact to change the binaries.

     

    Sorry we couldn't fix this over the forums!

     

    Buck

    Monday, July 28, 2008 9:37 PM
    Moderator
  • That's not a problem.  Just figured I'd give it a try in case a bug was found.  Just so you're aware, I have installed the VS2008 Team Explorer and I believe it may have been after the SQL Client installation.  The Windows XP SP3 installation was definitely done afterward.  These are the only installs I can remember that I believe could have affected SQL Server.  It may be worth a test scenario on your end to try this.  Thanks for the help!

    Monday, July 28, 2008 10:33 PM
  • This was the case for me. . . Everything was working fine until it randomly became corrupt.  Launched the install wizard and clicked repair, 5 minutes later intellisense is working again.  Fairly painless. . .

    Thank you!

    • Proposed as answer by pergiamau Saturday, April 16, 2011 9:05 AM
    • Unproposed as answer by pergiamau Saturday, April 16, 2011 9:06 AM
    Thursday, February 10, 2011 6:19 PM
  • Actually Buck, I discovered something that could be the culprit here.

    I had the same problem with IntelliSense not functioning, although by all rights it should have been.  The culprit was I had an offline database.  When I brought the database online, IntelliSense functionality was magically restored!

    Thought this might help someone else.

    Mike

    • Proposed as answer by Alex_2007 Monday, August 22, 2011 9:58 AM
    Thursday, February 17, 2011 5:30 PM
  • Hello to everyone this is my first post and I hope I'm doing right.

    Anyway, I had the same issue with the IntelliSense. I think I messed up installing the Express Edition over SQLServer 2008 R2.
    I'm not an expert, but I think this corrupted my environment. 

    This was driving me crazy and even if it's not an essential tool, I was looking for another solution, I didn't want to install again everything.  

    So I started to look at the Option window and I played with its settings.

    For the ones who don't know...
    Tool > Options > Text Editor > Transact-SQL > IntelliSense.

    But 'Enable IntelliSense' was ticked, so I unticked and saved.

    I opened the view again and I ticked them again.

    Magically my IntelliSense started again to work fine.

    Hope to be helpful.

    Cheers.




    Saturday, April 16, 2011 9:49 AM
  • I had the same problem - think it occurred when installing patch for VS. Updated to UC7 to no avail. I then went in to customize the menu so I can put the SQLCMD Mode button - mode was off. Turned on, then back off - wala - fixed! Hope this helps someone out there.
    Wednesday, May 04, 2011 5:41 PM
  • Tried everything on this page. Nothing worked. Intellisense stopped working after VS 2010 SP1 upgrade. Any suggestions ??
    Tuesday, May 10, 2011 2:53 PM
  • After installing VS2010 SP1 I believe you need to install SQL2008R2 CU#7.
    Tom G.
    Tuesday, May 10, 2011 3:17 PM
  • Thanks, this helps :-)
    Alex
    Monday, August 22, 2011 9:59 AM
  • What is CU #7

     

    Gert

    Saturday, October 08, 2011 6:39 AM
  • Cumulative Update package 7 for SQL Server 2008 R2

    Cumulative update package 7 for sql server 2008 R2

    and you can find it at the following link:

     

    http://support.microsoft.com/kb/2531482

    Wednesday, November 30, 2011 1:31 PM
  • The following link discusses another update that will break intellisense.  GDR1617 - KB2494088.  Uninstalling this update allows intellisense to function once again. 

    http://darrenmyher.wordpress.com/2011/06/17/microsoft-sql-server-update-gdr-1617-leaves-sql-server-unusable/

    • Proposed as answer by vdan02 Friday, September 21, 2012 2:29 PM
    Thursday, September 20, 2012 2:25 PM
  • I'm sure you have resolved your issue. I ran into the exact same problem and all that was needed was the Service Pack 1 for SQL 2008.

    It worked immediately after installing SP1

    Wednesday, September 10, 2014 11:25 AM