none
Sql server Data Tool (Tabular Model)

    Question

  • Hi,


    I am working with Denali Tabular model. In Tabular model I have created one project and that project I had deployed to ssas. Project works fine in ssas but when I do any changes in relational database and then process the tabular model then it take updated data but when I try to deploy tabular model to ssas it does not show updated data.

    And in ssas, workspace database(Project name with user name and GUID) gets created automatically by tabular model. 
    And if I make any change in workspace database name using setting file it’s not saved Permanently.

    Is there any solution on this?


    Thanks,
    Sneha Butala
    Thursday, January 03, 2013 8:00 AM

Answers

  • Ok. Have you tried doing a "Process Full" on all the tables after deploying the updated instance? This should synchronize all the rows from your OLTP instance(s).

    Piyush T

    • Marked as answer by Sneha Butala Monday, January 07, 2013 7:17 AM
    Monday, January 07, 2013 7:03 AM

All replies

  • SSAS Tabular creates a temporary database which exists as long your cube project is opened. When you close the project, that database gets deleted.

    Make sure you also process the database when deploying the cube to Analysis Service instance.

    • Proposed as answer by Olaf HelperMVP Sunday, January 06, 2013 9:03 AM
    Friday, January 04, 2013 6:31 PM
  •  Hi Irusul,

     Thanks for the reply. 

     I used to process the database when deploying the cube to Analysis services but still it does  not updated the data (Rows) in Analysis services.

    Monday, January 07, 2013 5:07 AM
  • Can you check that you are deploying the correct tabular model and the connection string is correct? Tabular model will have an associated workspace in Visual Studio 2010 and will update the instances correctly?

    If not, can you delete the tabular instance and try re-deploying the tabular instance?


    Piyush T

    Monday, January 07, 2013 5:12 AM
  • Hi Piyush,

    I am deploying the correct Tabular model and connection string is also correct.

    And when i deleted tabular instance and re-deploy the tabular then it take updated rows in analysis services instance.

    But I think it's not the correct way because after this, again I have added some rows in relational database and then process the tabular and deploy the same, then it does not updated (rows) in Analysis services.

    Sneha Butala 

     

    Monday, January 07, 2013 5:47 AM
  • Ok. Have you tried doing a "Process Full" on all the tables after deploying the updated instance? This should synchronize all the rows from your OLTP instance(s).

    Piyush T

    • Marked as answer by Sneha Butala Monday, January 07, 2013 7:17 AM
    Monday, January 07, 2013 7:03 AM
  • Thanks for your reply.. 

    when I changed Processing option property to "Full" then I get the updated data in Analysis services instance. 

    Thank you so much..

    Monday, January 07, 2013 7:17 AM
  • Hi Piyush,

    I have one more Query. 

    If you know can u please tell me what is the Aim of Workspace database means why it gets created automatically when we opened the tabular model and it gets deleted after closing the tabular model.
    Actually this query is just for my knowledge.

    Thanks in Advance.

    Sneha Butala.

     

    Monday, January 07, 2013 7:37 AM
  • The vertipaq engine is available only on the server where tabular model is deployed. To enable distributed developer teams work with the same tabular instance, VS requires a local workspace to be created on the developer workstation. It is very similar to how VSTF source control system creates local workspaces for checkouts of source code.

    Piyush T

    Monday, January 07, 2013 4:45 PM
  • Ok Thanks.

    Sneha Butala

    Tuesday, January 08, 2013 5:11 AM