none
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

    Question

  •  

    I have reporting services 2005,  created a  report, if i run from server through IE, it is working,   i am getting this error msg

    when i try to run from my local m/c

     

    • An error has occurred during report processing.

      • Cannot create a connection to data source 'SQL1DEV'.

        • Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
    Thursday, December 04, 2008 3:53 PM

Answers

All replies

  • Symptom:
    “Login failed for user ‘NT Authority\ANONYMOUS LOGON'”


    Resolution:
    1. In SQL Server Management Studio go to Security. Expand Logins.
    2. Right click NT Authority\ANONYMOUS LOGON.
    3. Change the default database to the database that you are trying to access.

    4. In the left pane, click server roles. Check the sys admin server role.
    5. Click OK to save the changes.

    -------------------------------------------------------

     

    Thursday, December 04, 2008 4:17 PM
  •  

    thanks for reply,  i don't have NT Authority\ANONYMOUS LOGON  account on my database server, from where i am pulling data for report.
    Thursday, December 04, 2008 4:28 PM
  • Then you need to create it and then follow the steps above. Also add the user to report manager and assign it rights.

     

    Thursday, December 04, 2008 4:36 PM
  • if i connect database on the same server where reporting services installed, i am able to see report from my local m/c, problem is if i connect to  databse different server, i am getting this error.

     

    is there any security setting,  if  i want to connect to different server.

     

    Thursday, December 04, 2008 7:30 PM
  • Yes, you have to set up the security as I've described above.

     

    Thursday, December 04, 2008 7:45 PM
  •  

    Hi,

    Based on your descriptions, I would like to suggest that you should recheck your configuration steps, especially in database part, please refer to the following documents.


    How to: Configure Service Accounts (Reporting Services Configuration)

    http://msdn.microsoft.com/en-us/library/bb326419(SQL.90).aspx

    How to: Install and Configure Reporting Services on Windows Server 2008

    http://msdn.microsoft.com/en-us/library/bb839480.aspx

     

    Hope this helps.


    Garsy Liang - MSFT
    Wednesday, January 07, 2009 11:57 AM
  • hello....
    I am also facing the same problem as described above,
    as per your suggestion, i have create a role named "NT Authority\ANONYMOUS LOGON"
    but when i right clicked on that role , i can't see any option to
    Change the default database to the database that you are trying to access.

    Colud you please give some light on this...
    thanks in advance..............
    Monday, June 29, 2009 1:57 PM
  • Hi
    I have exactly the same issue

    this is not a role that is mentionned but a login.
    You have this default database option when creating a new login
    I tryed to create it but seems not possible due to not allowed characters

    if you found any solution please share it.
    thanks
    Wednesday, July 01, 2009 2:37 PM
  • This is usually a problem with SPN's not set up in the right way in your environment. This issue can be worked around by using stored crediential for Data source. The below article should help you with the same.

    http://msdn.microsoft.com/en-us/library/ms156278(SQL.90).aspx

    Feroz
    Mark as Answer if it helps. This posting is provided "AS IS" with no warranties and confers no rights.
    Wednesday, July 01, 2009 3:58 PM
  • Thanks for your link but this link is for SQL server 2005 and I have no issue with 2005 but with 2008

    On this link you will se that the Home folder has been removed from management studio:
    http://msdn.microsoft.com/en-us/library/ms143380.aspx
    In Management Studio, the Home folder is removed in this release. You cannot view, manage, distribute or secure report server content in Management Studio.

    shared data source can be managed in the Report Manager : http://<servername>/Reports and Credential can be store their, but my test didn't succeed
    for embedded connection you can also store credential but once again it not works

    It makes 3 days that I try many many thinks without any succes

    The only thinks that is working is that added user to the Administrators Group on the server where the report server is installed
    and this is not a solution for me.

    to summurize
    I have a SQL server 2005 (srv1) where all my database are stored
    I have installed SQL server 2008 on another server (srv2) with report service
    So I try to create and publish report on the srv2 using data from my srv1 using simple connection string :
    Data Source=srv1;Initial Catalog="databasename"

    If you have any other solution...
    Thursday, July 02, 2009 7:51 AM
  • I tried again today without any success.
    Embedded or not connection failed when trying to display the report
    I really don't knwo what to do to make this report working
    it seems very simple on database on one server and report server on another but this windows credential is a big trick.

    Any help is welcomed
    Thursday, July 02, 2009 7:25 PM
  • Can you please provide me the error that you receive when you use stored credientials and render the report?

    Thanks
    Feroz
    Mark as Answer if it helps. This posting is provided "AS IS" with no warranties and confers no rights.
    Monday, July 06, 2009 11:22 PM
  • Hi,
    below the Error that I get I try to run the report from report builder:
    This report cannot be run in Report Builder because it contains one or more embedded datasources with credential options that are not supported.
    Instead of Embedded data sources use Shared data sources or save and view the report on the Server

    Today I have created a report that use a database that is on the same server where Report Service 2008 is installed
    but I also get the Above errir
    Here are more details:

    the server is called VAL-T-SQL
    Both the database and report service are installed on it
    I'm Admin the computer and sysadmin SQL User

    I report Builder 2.0
    My Data source use the following Connection string:
    Data Source=VAL-T-SQL;Initial Catalog="<MydatabaseName>"
    I alos try the following without any success
    Data Source=VAL-T-SQL;Initial Catalog="<MydatabaseName>";Integraterd security = SSPI
    I checked the Use a connection embedded in my report

    the credential are:
    Use current Windows user. Kerberos delegation may be required

    I have save as my Report on the Server :
    http://val-t-sql/ReportServer

    I can see the report without any error but it's not normal that I get this error inside Report Builder
    And if other users should have access to this report I have to add them to Admin user Group
    Othert I get this error:
    The permissions granted to user 'Domain\UserName' are insufficient for performing this operation. (rsAccessDenied)
    The user have all the Server Role of the SQL Server included sysadmin
    and he has also permission on the view that is called in the dataset.

    Do you have any idea why it's not working ? 

    Wednesday, July 08, 2009 9:39 AM
  • Hi, this solutions works .. but is it good idea to give this login access in prodcution ? Is this accessing through windows AD group access???
    I need this to be added to the sQL Server .. . but bit worried that whether its safe
    thanks

    Bis


    Bis
    Friday, October 08, 2010 6:06 AM
  • From my experience, this looks exactly like a Kerberos authentication issue.

    http://blogs.technet.com/b/askds/archive/2008/06/13/understanding-kerberos-double-hop.aspx

    This link gives a good understanding of what is going on, but essentially when you get an error like the one above, it is most frequently caused by having Windows Authenticaiton turned on for the data source, and the server that houses the data is not on the report server.

    This causes the report server to send a request and pass credentials through to the ReportServer database on the remote server from the client.

    I would first enable the option Trusted for delegation in AD for the machine running Report Server.

    Let me know if this works for you!

     

    Petri

    • Proposed as answer by Quesi Jay Friday, March 04, 2011 11:22 PM
    Friday, January 21, 2011 5:24 AM
  • WTF your proposing to make any anonymous report running on the server a DBO.

    I know this is a really old thread, but google brought it to me as a top 2 result.  

    If any system that this links to, links from, contains any confidential data or is running as anything other than a local account ... don't do it.


    Symptom:
    “Login failed for user ‘NT Authority\ANONYMOUS LOGON'”


    Resolution:
    1. In SQL Server Management Studio go to Security. Expand Logins.
    2. Right click NT Authority\ANONYMOUS LOGON.
    3. Change the default database to the database that you are trying to access.

    4. In the left pane, click server roles. Check the sys admin server role.
    5. Click OK to save the changes.

    -------------------------------------------------------

     

    Tuesday, March 06, 2012 1:02 PM
  • Symptom:
    “Login failed for user ‘NT Authority\ANONYMOUS LOGON'”


    Resolution:
    1. In SQL Server Management Studio go to Security. Expand Logins.
    2. Right click NT Authority\ANONYMOUS LOGON.
    3. Change the default database to the database that you are trying to access.

    4. In the left pane, click server roles. Check the sys admin server role.
    5. Click OK to save the changes.

    -------------------------------------------------------


    I know this is an old thread but just wanted to comment on this since this terrible advice is out here and don't want others following suit. Do NOT give ANONYMOUS LOGON sysadmin rights, this opens your server wide up and will likely piss off your DBA/security teams. In fact, "just give it sysadmin rights" should never be your go to solution. Figure out what's REALLY wrong and work it from there.

    Jorge Segarra
    SQLChicken.com || Follow me on Twitter! || SQL University
    Please click the Mark as Answer button if a post solves your problem!

    Wednesday, December 19, 2012 7:43 PM