none
Unable to connect to remote server (IIS 7)

    Question

  • I have Windows Server 2008 64 bit with IIS 7 installed with SQL 2005 + reporting services etc. I type http://localhost/Reports and i receive the error "Unable to connect to remote server". This is from the server itself and from any other machine.

     

    I have all "green ticks" when opening up reporting configuration. I have TCP and named pipes enabled. Ive tried switching off the firewall but have the same issue. I just installed webDav after reading around but still no joy. Reporting services is enabled and started.

     

    Does anyone have any ideas? I can connect to the database from the server and have some applications connecting to the database and can retrieve data without any problems.

     

    Thanks for any help in advance.

    Monday, June 16, 2008 6:49 PM

Answers

  • I managed to overcome this nasty little problem.

     

    Go into IIS > expand all the way until you are at ReportServer >

    Open ReportServer (make sure your in Feature view) >

    Double click Handler Mappings. You will see CGI and ISAPI disabled >

    click Edit Feature Permissions and check all the checkboxes.

     

    This should then enable CGI and ISAPI. Now when you browse localhost/reports or localhost/reportserver it should load without any problems.

    Wednesday, June 18, 2008 11:41 AM

All replies

  • Try to type the full url from other machine: http://machineName.domain.com/Reports.

    On server machine, try http://localhost/ReportServer. If you can not access reportServer this way, Open RSWebApplicatin.config under ReportManager folder, modify the following lines:

    From :

    <ReportServerUrl></ReportServerUrl>

    <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>

    To:

    <ReportServerUrl>http://ip of server/ReportServer</ReportServerUrl>

    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    IP of server can be server name as long as your DNS can resolve the IP.

     

    Monday, June 16, 2008 7:32 PM
  • try Pcname\reports
    and do u able to connect to localhost??means only localhost and enter
    Monday, June 16, 2008 7:32 PM
  • If i type the FQDN (i.e. server.domain.local/reports) then i have the same problem.

    Changing the config file gives me the error:

    The request failed with HTTP status 400: Bad Request.

    I checked DNS and i notice Reverse lookup and the server name are pointing to the same IP/machine.

     

    Ive tried PCName\Reports and localhost\reports - all with the same error.

     

    HOWEVER i restarted the server and now notice the Initialization section has a red cross through it and Encryption keys has a blue exclamation mark. Clicking initialize doesnt seem to do anything - could this be the problem if so what would i need to do here?

     

    Thanks

    Tuesday, June 17, 2008 2:37 PM
  • Update:

     

    Ive been reading the article found at http://support.microsoft.com/kb/938245/ for WS2008. Below step Step 3: Start the SQL Server service and reset IIS at stage 1b (In IIS Manager, expand Sites, expand Default Web Site, right-click the Report Manager application, point to Manage Application, and then click Advanced Settings.) 

     

    When i open up the application pool i have a list consisting of ReportServer, DefaultAppPool, CLassic - i have this set to Report Server this also applies to stage 2 (ReportServer) - both are set to ReportServer.

     

    Stage 3 is set to NT Authority\NetworkService.

     

    Since the article states use a domain user account - im lost here as i dont "think" these are user accounts - if they are how could i verify - if theyre not domain user accounts how do i overcome this problem?

     

    Thanks

    Tuesday, June 17, 2008 7:13 PM
  • I managed to overcome this nasty little problem.

     

    Go into IIS > expand all the way until you are at ReportServer >

    Open ReportServer (make sure your in Feature view) >

    Double click Handler Mappings. You will see CGI and ISAPI disabled >

    click Edit Feature Permissions and check all the checkboxes.

     

    This should then enable CGI and ISAPI. Now when you browse localhost/reports or localhost/reportserver it should load without any problems.

    Wednesday, June 18, 2008 11:41 AM
  •  

    Not sure what you mean by (Feature View) Please elaborate...

     

    also I have ReportServer under ApplicationPools and Web sites, I guess you refer "ReportServer" under Web sites

     

    Thanks

    Wednesday, June 18, 2008 7:58 PM
  • Feature View - If you right click your server name in IIS the option at the bottom would be "Switch to Content View" or "Switch to Feature View" depending on what view your under. If Content View is selected then you wont see the Handler Mappings option. So in order to view it you would right click your server name and select the option "Switch to Feature View" - only if you had content view enabled.

     

    Yes im referring to Report Server under Web sites (i.e. expanding Sites then Default Web Sites).

     

    Hope this helps.

    Thursday, June 19, 2008 7:54 AM
  •  

    Thanks very much for your detailed message....but honestly, I am not able to see the "Feature view", I logged on to the IIS server using remote desktop and did not see the feature view/content view. I also installed IIS 6 Manager in my windows XP desktop and connected to the IIS Server and couldn't see the feature view/content view thing!

     

    Anyone from MS please help.

    Thursday, June 19, 2008 3:41 PM
  •  EssCee wrote:

    I managed to overcome this nasty little problem.

     

    Go into IIS > expand all the way until you are at ReportServer >

    Open ReportServer (make sure your in Feature view) >

    Double click Handler Mappings. You will see CGI and ISAPI disabled >

    click Edit Feature Permissions and check all the checkboxes.

     

    This should then enable CGI and ISAPI. Now when you browse localhost/reports or localhost/reportserver it should load without any problems.




    thanks dude... that worked for me
    Thursday, October 16, 2008 8:07 PM
  •  EssCee wrote:

    I managed to overcome this nasty little problem.

     

    Go into IIS > expand all the way until you are at ReportServer >

    Open ReportServer (make sure your in Feature view) >

    Double click Handler Mappings. You will see CGI and ISAPI disabled >

    click Edit Feature Permissions and check all the checkboxes.

     

    This should then enable CGI and ISAPI. Now when you browse localhost/reports or localhost/reportserver it should load without any problems.




    thanks dude... that worked for me

    With All Do Respect - I must be missing something elementary and critical all at the same time. OS: WS2008 64-Bit; SSRS 2008 64-bit (goes without saying); IIS7;
    SSRS is not managed through IIS.  Is there a way to enable this?
    Monday, August 24, 2009 10:30 PM
  • Hi , I have installed SSRS2008 on vista. I can connect to Sql server, I can develop a report, I can see the data in the report in Visual Studio 2008. But, I'm unable to access the http://localhost/reports page. When I go to IIS Manager-->websites-->Default website, i can't see the 'Report Server' nodes there. Do you have any idea to solve this problem?? Thank you.
    Tuesday, August 25, 2009 7:21 AM
  • Perfect!  That was my problem.

    Others need to check the basics first.
    Rob
    Friday, December 04, 2009 5:46 PM
  • This saved my ass after an in-place upgrade from Server 2003 R2 to Server 2008 R2.

    Thank You soo much for this!!!

    S/F,


    Aaron K. Clark

    Monday, December 10, 2012 2:58 PM