none
CacheDataForPreview in RSReportDesigner.Config not honored

    Question

  • I'm using SQL 2008 Developer and Visual Studio 2008. In my RSReportDesigner.Config file (under C:\Program Files/Microsoft Visual Studio 9.0/Common7/IDE/PrivateAssemblies) I see the following entry:

    <

     

    Add Key="CacheDataForPreview" Value="false" />

    Yet when I preview a report in Visual Studio, it still generates a <report name>.rdl.data file

    How do I STOP Visual Studio from caching data results from report previewing?

    Seems to be a BUG if it is NOT honoring the above tag in the config file!


    Todd C - MSCTS SQL Server 2005 - Please mark posts as answered where appropriate.
    Friday, June 18, 2010 1:26 PM

Answers

  • Hi Todd,

    This option indeed doesn't work, and there is no other way to prevent this cached data file from being created. It might be a bug. So, i would suggest you submit a feedback at http://connect.microsoft.com/SQLServer/Feedback  and hope this problem can be fixed in the next release of service pack.

    thanks,
    Jerry

    • Marked as answer by Todd C Monday, June 21, 2010 1:08 PM
    Monday, June 21, 2010 4:08 AM

All replies

  • Hi Todd,

    This option indeed doesn't work, and there is no other way to prevent this cached data file from being created. It might be a bug. So, i would suggest you submit a feedback at http://connect.microsoft.com/SQLServer/Feedback  and hope this problem can be fixed in the next release of service pack.

    thanks,
    Jerry

    • Marked as answer by Todd C Monday, June 21, 2010 1:08 PM
    Monday, June 21, 2010 4:08 AM
  • Putting a "refresh" button in a report designer that isn't actually able to refresh the data!  That is some fortuitous stroke of genius!

    Is there any update on this issue?  We need to disable this the creation of these pesky rdl.data files.  They can be misleading and very annoying to manage.

    We are trying to upgrade to SQL 2008 R2, which now seems to ignore the "CacheDataForPreview" parameter in the RSReportDesigner.config.


    David Beavon
    Thursday, January 06, 2011 6:46 PM
  • Get into SQL Server Connect and vote for/watch the item in quetion.
    Todd C - MSCTS SQL Server 2005 - Please mark posts as answered where appropriate.
    Thursday, January 06, 2011 8:25 PM
  • Thanks, I didn't realize you had created one. Here: https://connect.microsoft.com/SQLServer/feedback/details/468482

     

    We haven't upgraded from SSRS 2005 yet for a variety of issues like this one.  It seems like a pretty cut-and-dry regression bug, considering we have the ability to avoid using these pesky.rdl.data files in SSRS 2005.  When I get a chance I'll open the topic with premier support.

    Thanks, David


    David Beavon
    Thursday, January 06, 2011 11:26 PM