none
Problem adding new Database in Smart application

    Question

  • When I try to add new sql ce database to smart solution in vs2005 I have the following msgbox

    cannot obtain provider factory for data provider named 'microsoft.sqlserverce.client'

    what can be ??
    Thursday, November 03, 2005 4:36 PM

Answers

  • Which build of VS 2005 are you using?

    My guess is that your SQL Mobile entry in the machine.config file has been hosed. Try repairing your SQL Mobile install  - that might fix your problem
    Monday, November 07, 2005 12:28 PM
  • %SystemDrive%\WINDOWS\Microsoft.NET\Framework\v2.0.xxxxx\config\machine.config

    Open this file in NOTEPAD, and search for "SQL Server CE Data Provider".  If it is not there then, you may try adding the following line AS IT IS in Data Providers section.

    <add name="SQL Server CE Data Provider" invariant="Microsoft.SqlServerCe.Client" description=".NET Framework Data Provider for Microsoft SQL Server 2005 Mobile Edition" type="Microsoft.SqlServerCe.Client.SqlCeClientFactory, Microsoft.SqlServerCe.Client, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />

    You may need to restart the VS or even the PC to make VS detect this new setting.

    Let us know if this has worked for you!

    Thanks,
    Laxmi NRO, SQL Mobile

    Tuesday, November 08, 2005 11:37 AM

All replies

  • Which build of VS 2005 are you using?

    My guess is that your SQL Mobile entry in the machine.config file has been hosed. Try repairing your SQL Mobile install  - that might fix your problem
    Monday, November 07, 2005 12:28 PM
  • I solved my problem to reinstalling again Microsoft Mobile 2005 tools ENU

    Regards.
    Monday, November 07, 2005 12:30 PM
  • Sorry but I am again back !!!
    I solved my problem when I add a new sqlCE database, but now I have the same problem when I try to add a new column to a datatable in the dataset designer.
     
    You suggest to reinstall again mt SQL MObile, could you specify exactly what I have to reinstall ?
    Monday, November 07, 2005 12:36 PM
  • %SystemDrive%\WINDOWS\Microsoft.NET\Framework\v2.0.xxxxx\config\machine.config

    Open this file in NOTEPAD, and search for "SQL Server CE Data Provider".  If it is not there then, you may try adding the following line AS IT IS in Data Providers section.

    <add name="SQL Server CE Data Provider" invariant="Microsoft.SqlServerCe.Client" description=".NET Framework Data Provider for Microsoft SQL Server 2005 Mobile Edition" type="Microsoft.SqlServerCe.Client.SqlCeClientFactory, Microsoft.SqlServerCe.Client, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />

    You may need to restart the VS or even the PC to make VS detect this new setting.

    Let us know if this has worked for you!

    Thanks,
    Laxmi NRO, SQL Mobile

    Tuesday, November 08, 2005 11:37 AM