none
Date Time Attribute

    Question

  • HI All,

    I have a datetime attribute in a "regular type" dimension. When I connect to this cube using Excel, I can't use the datetime attribute to filter as it doesn't work. If I right-click on the attribute and put a filter like > 2010-12-31, it doesn't affect the pivot table.

    Any idea what's going on? An work-around? Thanks in advance.

    Saturday, February 05, 2011 5:18 PM

Answers

  • Hi,

    This is indeed plain stupid, but Excel (2010 in my case) offers "date" filtering only for dimensions that are of Time type. This means you could set your regular dimension type to be Time but then it kind of akes no sense for other attributes because excel will offer Date filters and Value filters (no label filters). The other option is to create a referenced time dimension for this attribute.

    I would love if someone would prove me wrong but I truly believe these are your only options.

    I suggest you research if this has already been submitted to connect and either submit it or vote for it (do provide the link here so I can too).

    Kind regards,

    Hrvoje Piasevoli

    Sunday, February 06, 2011 3:42 AM
  • Hi Sam,

    Please use Date Filter instead of Value Filter in your excel pivot table if you have time dimension. So, HrojePiasevoli is right.

    thanks,
    Jerry

    Wednesday, February 09, 2011 8:42 AM

All replies

  • check whether the dimension is linked to the measures in the dimension usage. Also make sure it is properly linked in the DSV. Also make sure it is linked with the right key.
    vinu
    Saturday, February 05, 2011 6:27 PM
  • I have 2 measure groups and the dimension is linked to one. I am only useing measures from the measure group to which the dimension is linked.

    Not sure why you think I have not linked the tables properly in DSV and not using the right key? Because if am not suing the right key, the data would be incorrect.

    Is possible to filter on an attribute which belings to a "regular type" dimensions? This should be doable, I think. Am I doing somehting wrong?

    Saturday, February 05, 2011 8:56 PM
  • Hi,

    This is indeed plain stupid, but Excel (2010 in my case) offers "date" filtering only for dimensions that are of Time type. This means you could set your regular dimension type to be Time but then it kind of akes no sense for other attributes because excel will offer Date filters and Value filters (no label filters). The other option is to create a referenced time dimension for this attribute.

    I would love if someone would prove me wrong but I truly believe these are your only options.

    I suggest you research if this has already been submitted to connect and either submit it or vote for it (do provide the link here so I can too).

    Kind regards,

    Hrvoje Piasevoli

    Sunday, February 06, 2011 3:42 AM
  • Hi Sam,

    Please use Date Filter instead of Value Filter in your excel pivot table if you have time dimension. So, HrojePiasevoli is right.

    thanks,
    Jerry

    Wednesday, February 09, 2011 8:42 AM