none
Failed to initialize the Common Language Runtime (CLR) v2.0.50727 due to memory pressure.-Please restart SQL server in Address Windowing Extensions (AWE) mode to use CLR integration features.

    Question

  • I have getting following error…    

     

    Failed to initialize the Common Language Runtime (CLR) v2.0.50727 due to memory pressure.

     Please restart SQL server in Address Windowing Extensions (AWE) mode to use CLR integration features.

     

     

    If I Restart the SQL server… it will work fine. Again after some time I getting same error.

     

     

    Can any one help me on this?

    Thursday, December 09, 2010 12:20 PM

Answers

  • So could you please try increasing the 'MemToLeave' or 'Non buffer pool memory'? Please see:

    Various memory errors are logged to SQL Server error log when using SQL CLR objects
    http://support.microsoft.com/kb/969962

    Alternatively, please migrate to 64-bit servers so that SQL CLR can access more virtual memory.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by KJian_ Monday, December 20, 2010 7:31 AM
    • Marked as answer by KJian_ Friday, December 24, 2010 6:44 AM
    Monday, December 13, 2010 5:41 AM

All replies

  • Hi,

    Could you please elaborate a bit? Which version of SQL Server are you using? Is it a 32-bit SQL Server instance?
    The error message indicates that it’s a SQL CLR memory issue, I would suggest you refer to the KB article below to fix it:

    Possible causes of "Failed to initialize the Common Language Runtime (CLR)" when using SQL CLR
    http://support.microsoft.com/kb/2003681

    Reference:

    Memory Usage in SQL CLR
    http://blogs.msdn.com/b/sqlclr/archive/2006/03/24/560154.aspx

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, December 10, 2010 2:27 AM
  •  

    Hi,

    Environment Details.  

     

    Os:  Windows Server 2003 Enterprise 32 bit Edition    (SP2)

     

    Sql server:  2005, 32 bit, SP3

     

    Available memory :  10239 MB

     

    AWE  is ENABLED

     

             Min:  240 MB

             Max: 12288 MB

     

    select  

    single_pages_kb + multi_pages_kb + virtual_memory_committed_kb from sys.dm_os_memory_clerks where type = 'MEMORYCLERK_SQLCLR'   ==>    556
    Friday, December 10, 2010 1:24 PM
  • So could you please try increasing the 'MemToLeave' or 'Non buffer pool memory'? Please see:

    Various memory errors are logged to SQL Server error log when using SQL CLR objects
    http://support.microsoft.com/kb/969962

    Alternatively, please migrate to 64-bit servers so that SQL CLR can access more virtual memory.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by KJian_ Monday, December 20, 2010 7:31 AM
    • Marked as answer by KJian_ Friday, December 24, 2010 6:44 AM
    Monday, December 13, 2010 5:41 AM
  • So could you please try increasing the 'MemToLeave' or 'Non buffer pool memory'? Please see:

    Various memory errors are logged to SQL Server error log when using SQL CLR objects
    http://support.microsoft.com/kb/969962

    Alternatively, please migrate to 64-bit servers so that SQL CLR can access more virtual memory.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.


    Hi...

    Will Check & Update this weekend....

     

    Regards,

    Sajid P k

     

     

    Wednesday, December 15, 2010 8:17 AM