none
SQL Server error 53 How do I find my server name to connect to server

    Question

  • I am new to SQL Server 2008 Developer edition for class online. I do not know my computer name/ server name to connect to server to start a database project. Please help me to find the info to open the database. Assignment due 4/5/2010. My computer is a Dell wireless laptop with Windows XP Home edition. I am getting error 53 and 40. Cannot connect to server and named pipes provider.

    The error message I got was: ...A sever was not found or accessable. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (Provider: Named Pipes provider error 40- could not open connection to SQL Server). (Microsoft SQL Server error 53).

    I know what I named my computer but I don't know if that is the name I use to connect to the Server and I don't know what the server name would be. Where would I find that and what do I enter into the dialog box to establish a connection? I have not set up any database or server in the Database Engine or other areas of this program. This is a brand new copy I purchased and installed recently.

    Friday, April 02, 2010 6:40 PM

Answers

  • >>How do I find my server name to connect to server

    One way to tell is on the command prompt enter hostname which will be the name of your computer


    right click on "My Computer", properties and select the "Computer Name" tab

    and if you have installed SQL as a deafult instance; SQL Server will have same name as of your computer.

    Alternatively, you can try on the command prompt SQLCMD /L

    SQLCMD /L will list all SQL server in your network.

     

     

    Friday, April 02, 2010 7:36 PM

All replies

  • >>How do I find my server name to connect to server

    One way to tell is on the command prompt enter hostname which will be the name of your computer


    right click on "My Computer", properties and select the "Computer Name" tab

    and if you have installed SQL as a deafult instance; SQL Server will have same name as of your computer.

    Alternatively, you can try on the command prompt SQLCMD /L

    SQLCMD /L will list all SQL server in your network.

     

     

    Friday, April 02, 2010 7:36 PM
  •  >>have not set up any database or server in the Database Engine or other areas of this program. This is a brand new copy I purchased and installed recently.

    Well,  first of all can you make sure SQL server is installed? Try to run SQLCMd on the command promt if it errors out you need to install SQL first. 

    Friday, April 02, 2010 7:42 PM
  • Hi

    We can navigate to All Programs -> Microsoft SQL Server 2008 -> Configuration Tools -> SQL Server Configuration Manager, expand SQL Server Services, see if the instance is running and check the SQL Server instance name, like "SQLEXPRESS" or “MSSQLSERVER”.

     acfff033-1253-4f45-b518-dc18c5585432

    If your SQL Server instance was installed as a default instance (“MSSQLSERVER”), we can use ".","localhost" or "(local)" to connect to it.

    If not, we need to specify “.\InstanceName” .


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, April 05, 2010 5:46 AM
  • sir,

    i am also facing the same issue with the SQL SERVER 2005 which i have installed few mins back. my SQL services are running .in the registry editor the installed instance name is MSSQLSERVER and it is giving me the error code 18456 and 53. i have tried with (local) , localhost MSSQLSERVER.

    • Proposed as answer by kamlendra Sunday, October 24, 2010 12:19 PM
    Sunday, October 24, 2010 11:56 AM
  • hey, 

     it got connected !! it was a silly mistake.... as i am working on windows7 i have to start the SQL server Management studio -- "Run as administrator" . :) and it worked.

    Sunday, October 24, 2010 12:22 PM
  • I went to command line and entered SQLCMD?L and got the following but no server name

    :uid:Login ID=?;PWD:Password=?Trusted_Connection:Use Integrated Security=?;*APP:AppName=?:*WSID=WorkStation ID=?;


    Jere Small

    Sunday, April 21, 2013 7:48 AM
  • Okay, I went to Tools then Connedct to server it asked for my computer name. then I went to tools again and used connect to database and selected Microsoft SQL Server Database File then searched for my .mdf databse that I already had and seled it and it loaded ok.  I got the it gave the data source as

    Data Source=(LocalDB)\v11.0;AttachDbFilename="C:\Users\Jere\Documents\

    Baseball2013\Bigger Leaguer Baseballer\Baseball2012.mdf";Integrated

    Security=True;Connect Timeout=30

    I assume the server name is (LocalDB)\V11.0 ?? anyone know the

    server name from this that I would enter in server explorer to ceate

    a new database

    Thanks JereBear



    Jere Small

    Sunday, April 21, 2013 8:40 AM
  • Okay I went to Tools, then connect to server, enter the computer name JERE. then I went to tools again and used connect to database and selected Microsoft SQL Server Database File then searched for my .mdf databse that I already had and selected it and it loaded ok. I gave the data source as Data Dource=(LocalDB)\v11.0;AttributeDbFilename=”C:\Databasename.mdf”;Integrated Security=True;Connect Timeout=30 So the question is what goes in the box below named Server name:

    Thanks for everyone for helping, I almost have my answer.



    Jere Small

    Sunday, April 21, 2013 11:12 AM
  • Okay!  (LocalDB)\v11.0 is the server name

    Thank erveryone answered


    Jere Small

    • Proposed as answer by JereTheBear Sunday, April 21, 2013 6:45 PM
    Sunday, April 21, 2013 6:45 PM
  • Okay, I went to Tools then Connedct to server it asked for my computer name. then I went to tools again and used connect to database and selected Microsoft SQL Server Database File then searched for my .mdf databse that I already had and seled it and it loaded ok.  It gave the data source as  (LocalDB)\v11.0. That's it, I was able to use the server explorer to create a new database using (LocalDB)\11.0, exactly like it is, weird but that's it.

    Data Source=(LocalDB)\v11.0;AttachDbFilename="C:\Users\Jere\Documents\

    Baseball2013\Bigger Leaguer Baseballer\Baseball2012.mdf";Integrated

    Security=True;Connect Timeout=30

    Thanks JereBear


    Jere Small

    • Proposed as answer by JereTheBear Tuesday, April 23, 2013 2:31 PM
    Tuesday, April 23, 2013 2:31 PM
  • I went to command line and entered SQLCMD?L and got the following but no server name

    :uid:Login ID=?;PWD:Password=?Trusted_Connection:Use Integrated Security=?;*APP:AppName=?:*WSID=WorkStation ID=?;


    Jere Small

    My SQLCMD -L is also reporting the same output. Does anyone know why/how to fix this?
    Tuesday, December 10, 2013 11:38 PM