none
Childwindow set isenabled property of my viewmodel to false of my usercontrol whenver been called.

    General discussion

  • Can anyone please help me with this problem thanks a lot in advance.

    I have my main page and there is one usercontrol whose is enabled property is binded with my viewmodel and there is one button which is binded with my command which show one childwindow.

    what happens is when i run my code locally and click in to the button first the isenabled property of viewmodel set to false although i havent written any code for the same and when i click into the cancel or ok or close button of childwindow it set to true again as it was first so my usercontrol is enabled .

    But when i deploy my silverlight application and do the same process as locally then at the last phase when i click into close cancel or ok the my isenabled property of my viewmodel doesnt get true which does when click locally. so my usercontrol gets disabled when anychildwindow is been showed from viewmodel.

    so the situtation is Locally : - 1) Usercontrol is enable and when i click into childwindow it set isenabled to false. 2) Now when i click ok,cancel or close button of childwindow it again set isenabled to true and my user control is enabled.

     

    Deployed:-1) Usercontrol is enable and when i click into childwindow it set isenabled to false. 2) Now when i click ok,cancel or close button of childwindow ienabled property doesnt set to true and so my usercontrol on mainpage get disabled.

    Its really very important for me to get that work thanks a lot in advance for help..!!

     

     

     

    Monday, June 04, 2012 9:26 AM