none
The service not exists - Exception Source :- System.Runtime.DurableInstancing

    Question

  • Hi All,

    The project is working fine when I ran on IDE but when we deploy on our test server its not working and giving the below error. Can somebody help me.

    We dont have RIA services install on server we just copied 2 dlls "System.ServiceModel.DomainServices.Hosting.dll" & "System.ServiceModel.DomainServices.Server.dll" in bin folder manually.

    Exception Type: System.Web.HttpException
    Error Detail: The service '/Project1/Services/P1ServicesLibrary-Web-DashboardDomainService.svc' does not exist.
    Exception Source: System.Runtime.DurableInstancing
    Stack Trace: [System.Web.HttpException: The service '/Project1/Services/P1ServicesLibrary-Web-DashboardDomainService.svc' does not exist.]
       at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.ExecuteSynchronous(HttpApplication context, String routeServiceVirtualPath, Boolean flowContext, Boolean ensureWFService)
       at System.ServiceModel.Activation.HttpHandler.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    [System.ServiceModel.EndpointNotFoundException: The service '/Project1/Services/P1ServicesLibrary-Web-DashboardDomainService.svc' does not exist.]
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.HandleRequest()
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.BeginRequest()
    Exception Target: End

     

    Sunday, February 06, 2011 9:40 AM

Answers

  • Sorry, Jeff and I were looking at an old thread with the answer and forgot to get back to you. It looks like it is a problem with the precompiledapp.config, the old thread we were looking at is http://forums.silverlight.net/forums/t/186739.aspx. See if that information helps you and let me know.

    Tuesday, February 15, 2011 8:44 PM
  • sorry for replying late....Not tried what you said but I got a work around.....

    When you build and deploy your RIA services website using web deployment project then you have to copy a dummy page with .svc extension file under "ClientBin" or create a folder "Services" and paste the file there.

    The file name and path should be same what actually calling from the website in my case it was "Services/P1ServicesLibrary-Web-DashboardDomainService.svc" you can get this path via fiddler or in error itself.

    I am not sure if any other solution is there but this worked for me.

    Sunday, March 06, 2011 10:03 AM

All replies

  • Is the web.config the same in both dev and on the server?

    Sunday, February 06, 2011 9:56 AM
  • Apart from some server related settings which we use internally in our application rest all is same..

    The only difference is its a virtual application with .net 4.0 in our web server and the Root website is in .net 2.0

    Sunday, February 06, 2011 10:48 AM
  • That is probably your problem. .NET 4.0 is backwards compatible so the entire application should be in 4.0.

    Sunday, February 06, 2011 11:28 AM
  • Everything is working fine excpet for silverlight thing so I dont thing its the version problem. what do u say ?

    let me share u web.config so u can give better idea....

    Sunday, February 06, 2011 11:39 AM
  • web.config from test web server. certain settings I removed which is just for internal purpose.

    <?

    xml version="1.0"

    ?>

    <!--

    Note: As an alternative to hand editing this file you can use the

    web admin tool to configure settings for your application. Use

    the Website->Asp.Net Configuration option in Visual Studio.

    A full list of settings and comments can be found in

    machine.config.comments usually located in

    \Windows\Microsoft.Net\Framework\v2.x\Config

    -->

    <

    configuration

    >

    <

    configSections

    >

    <

    section name="dataConfiguration" type="Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings, Microsoft.Practices.EnterpriseLibrary.Data, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="true"

    />

    </

    configSections

    >

    <

    dataConfiguration defaultDatabase="DBConnection"

    />

    <

    connectionStrings

    >

    <!--

    connection string part removed

    -->

    </

    connectionStrings

    >

     

    <

    appSettings

    >

    <!--

    internal website settings removed

    -->

    </

    appSettings

    >

    <

    system.web

    >

    <

    customErrors mode="Off"

    />

    <

    httpModules

    >

    <

    add name="DomainServiceModule" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    />

    </

    httpModules

    >

    <

    httpRuntime maxRequestLength="2097151" executionTimeout="600" requestValidationMode="2.0"

    />

    <!--

    Set compilation debug="true" to insert debugging

    symbols into the compiled page. Because this

    affects performance, set this value to true only

    during development.

    -->

    <

    compilation debug="false" batch="true" targetFramework="4.0"

    />

    <!--

    The <authentication> section enables configuration

    of the security authentication mode used by

    ASP.NET to identify an incoming user.

    -->

    <

    authentication mode="Forms"

    />

    <!--

    The <customErrors> section enables configuration

    of what to do if/when an unhandled error occurs

    during the execution of a request. Specifically,

    it enables developers to configure html error pages

    to be displayed in place of a error stack trace.

    <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">

    <error statusCode="403" redirect="NoAccess.htm" />

    <error statusCode="404" redirect="FileNotFound.htm" />

    </customErrors>

    -->

    <

    trace enabled="true" pageOutput="true" requestLimit="15" mostRecent="true"

    />

    <

    pages styleSheetTheme="Default" enableEventValidation="false" validateRequest="false" enableViewStateMac="false" controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"

    >

    </

    pages

    >

    <

    sessionState timeout="30"

    />

    </

    system.web

    >

    <!--

    The system.webServer section is required for running ASP.NET AJAX under Internet

    Information Services 7.0. It is not necessary for previous version of IIS.

    -->

    <

    system.webServer

    >

    <

    modules runAllManagedModulesForAllRequests="true"

    >

    <

    add name="DomainServiceModule" preCondition="managedHandler" type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    />

    </

    modules

    >

    <

    validation validateIntegratedModeConfiguration="false"

    />

    </

    system.webServer

    >

    <

    system.serviceModel

    >

    <

    serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true"></serviceHostingEnvironment

    >

    <

    behaviors

    >

    <

    serviceBehaviors

    >

    <

    behavior name="ServiceBehavior"

    >

    <

    serviceMetadata httpGetEnabled="true"

    />

    <

    serviceDebug includeExceptionDetailInFaults="true"

    />

    </

    behavior

    >

    </

    serviceBehaviors

    >

    </

    behaviors

    >

    <

    services

    >

    <

    service behaviorConfiguration="ServiceBehavior" name="SilverlightWCFService"

    >

    <

    endpoint address="" binding="basicHttpBinding" contract="ISilverlightWCFService"

    >

    <!--

    <identity>

    --><!--<dns value="202.46.215.139" />

    --><!--

    </identity>

    -->

    </

    endpoint

    >

    <

    endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"

    />

    </

    service

    >

    </

    services

    >

    <

    bindings

    >

    <

    wsHttpBinding

    >

    <

    binding name="WSHttpBinding_IService" closeTimeout="00:01:00" openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00" bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false"

    >

    <

    readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384"

    />

    <

    reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="false"

    />

    <

    security mode="Message"

    >

    <

    transport clientCredentialType="Windows" proxyCredentialType="None" realm=""

    />

    <

    message clientCredentialType="Windows" negotiateServiceCredential="true" algorithmSuite="Default" establishSecurityContext="true"

    />

    </

    security

    >

    </

    binding

    >

    </

    wsHttpBinding

    >

    </

    bindings

    >

    <

    client

    >

    <

    endpoint address="website url removed" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IService" contract="WS.iCAPS.IService" name="WSHttpBinding_IService"

    >

    <

    identity

    >

    <

    dns value="localhost"

    />

    </

    identity

    >

    </

    endpoint

    >

    </

    client

    >

    <

    diagnostics wmiProviderEnabled="true"

    >

    <

    messageLogging logEntireMessage="true" logMalformedMessages="true" logMessagesAtServiceLevel="true" logMessagesAtTransportLevel="true" maxMessagesToLog="3000"

    />

    </

    diagnostics

    >

    </

    system.serviceModel

    >

    </

    configuration

    >

    Sunday, February 06, 2011 11:47 AM
  • OK, I see from the web.config that you have 4.0 set so I misunderstood what you were saying about having the root set to 2.0. Are you using WCF RIA Services class libraries or is the DomainService in the main web project itself? This could also be happening if you are using a class library and the class library's dll is not in the bin folder.

    Sunday, February 06, 2011 12:48 PM
  • We are using Silverlight with RIA services in our project and We dont have RIA services install on web server we just copied 2 dlls "System.ServiceModel.DomainServices.Hosting.dll" & "System.ServiceModel.DomainServices.Server.dll" in bin folder manually.

    we are using web deployment proj to build the proj

    Sunday, February 06, 2011 7:01 PM
  • Yes, I got that. The question is, where is the DomainService? Is in the main web application or in a separate class library?

    Monday, February 07, 2011 12:36 AM
  • sepertate class library....

    Monday, February 07, 2011 7:28 AM
  • Is the separate class library's dll in the bin folder? Does the web project have a reference to the class library?

    Monday, February 07, 2011 8:48 AM
  • yes the web project have a reference to the class library.

    I hv set copy local to true for domain service related dll in the class library but it will not copy domain service related dlls to web application bin automatically.

    Monday, February 07, 2011 9:34 AM
  • Hi,

    Try to follow this document to deploy the RIA service to your server:

    http://msdn.microsoft.com/en-us/library/ff426912(VS.91).aspx

    Tuesday, February 08, 2011 9:33 PM
  • I find out that its not RIA services installation problem as it is working fine when I put code directly but when I do build with web deployment proj its giving me error.

    Appreciate if you guys guide me on this....

    Tuesday, February 15, 2011 3:22 PM
  • Oh, been a long time since i saw that problem. For some reason, the web deployment project breaks WCF RIA Services. I don't know exactly why it does, but it does.

    Tuesday, February 15, 2011 3:59 PM
  • using fiddler I found out few things...difference between request (request of .svc file) of  code and deployment build...

    Code:

    Content type ='application/msbin1'

    there is no download zip file for ria client dlls

    deploy build:

    Content type = 'text/html'

    It also download zip file for ria client dlls

     

    I am also not able to open .svc file through web path

    Tuesday, February 15, 2011 7:43 PM
  • Sorry, Jeff and I were looking at an old thread with the answer and forgot to get back to you. It looks like it is a problem with the precompiledapp.config, the old thread we were looking at is http://forums.silverlight.net/forums/t/186739.aspx. See if that information helps you and let me know.

    Tuesday, February 15, 2011 8:44 PM
  • sorry for replying late....Not tried what you said but I got a work around.....

    When you build and deploy your RIA services website using web deployment project then you have to copy a dummy page with .svc extension file under "ClientBin" or create a folder "Services" and paste the file there.

    The file name and path should be same what actually calling from the website in my case it was "Services/P1ServicesLibrary-Web-DashboardDomainService.svc" you can get this path via fiddler or in error itself.

    I am not sure if any other solution is there but this worked for me.

    Sunday, March 06, 2011 10:03 AM