none
WCF TCP Bindings that require window authentication

    Question

  • Dose any one know if there is a way to use a net:tcp binding that requires window authentication with in silverlight 4

    Here is my end point sample

          <endpoint address="net.tcp://Host.mydomain.com:9000/MyService/"
                  binding="customBinding" bindingConfiguration="tcpMyserviceBinding"
                  contract="ServiceName.IServiceContact" name="MyService" />

    Binding Sample

                <customBinding>
                  <binding name="tcpMyserviceBinding"   closeTimeout="00:05:00" openTimeout="00:05:00" receiveTimeout="00:05:00" sendTimeout ="00:05:00" >
                    <security authenticationMode="UserNameOverTransport"  includeTimestamp="true"/>
                    <tcpTransport maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" connectionBufferSize="2147483647" />
                  </binding>
                </customBinding>

    Friday, May 25, 2012 9:06 AM

Answers

  • Hi,

    You can refer to the link below:

    I have mentioned some useful information about your situation:

    http://msdn.microsoft.com/en-us/magazine/dd434653.aspx

    Figure 13 Settings for ASP.NET Authentication Service
    //web.config
    <Configuration>  
      <connectionStrings>
      <!-- removal and addition of LocalSqlServer setting will override the   
       default asp.net security database used by the ASP.NET Configuration tool
       located in the Visul Studio Project menu-->
      <remove name="LocalSqlServer"/>
        <add name="LocalSqlServer" connectionString="Data 
                 Source=localhost\SqlExpress;Initial Catalog=aspnetdb; ... />
    </connectionStrings>
    <system.web.extensions>
       <scripting>
         <webServices>
       <authenticationService enabled="true" requireSSL="false"/>
         </webServices>
       </scripting>
    </system.web.extensions>
    ... 
    <authentication mode="Forms"/>
    ... 
    <system.serviceModel>
       <services>
         <service name="System.Web.ApplicationServices.AuthenticationService" 
                  behaviorConfiguration="CommonServiceBehavior">
        <endpoint 
                  contract="System.Web.ApplicationServices.AuthenticationService" 
                  binding="basicHttpBinding" bindingConfiguration="useHttp" 
                  bindingNamespace="http://asp.net/ApplicationServices/v200"/>
         </service>
       </services>
       <bindings>
         <basicHttpBinding>
        <binding name="useHttp">
              <!--for production use mode="Transport" -->
          <security mode="None"/>
         </binding>
         </basicHttpBinding>
       </bindings>
       ... 
       <serviceHostingEnvironment aspNetCompatibilityEnabled="true"/>
    </system.serviceModel>
    </configuration>
    
     

     

    Monday, May 28, 2012 2:49 AM

All replies

  • Hi,

    You can refer to the link below:

    I have mentioned some useful information about your situation:

    http://msdn.microsoft.com/en-us/magazine/dd434653.aspx

    Figure 13 Settings for ASP.NET Authentication Service
    //web.config
    <Configuration>  
      <connectionStrings>
      <!-- removal and addition of LocalSqlServer setting will override the   
       default asp.net security database used by the ASP.NET Configuration tool
       located in the Visul Studio Project menu-->
      <remove name="LocalSqlServer"/>
        <add name="LocalSqlServer" connectionString="Data 
                 Source=localhost\SqlExpress;Initial Catalog=aspnetdb; ... />
    </connectionStrings>
    <system.web.extensions>
       <scripting>
         <webServices>
       <authenticationService enabled="true" requireSSL="false"/>
         </webServices>
       </scripting>
    </system.web.extensions>
    ... 
    <authentication mode="Forms"/>
    ... 
    <system.serviceModel>
       <services>
         <service name="System.Web.ApplicationServices.AuthenticationService" 
                  behaviorConfiguration="CommonServiceBehavior">
        <endpoint 
                  contract="System.Web.ApplicationServices.AuthenticationService" 
                  binding="basicHttpBinding" bindingConfiguration="useHttp" 
                  bindingNamespace="http://asp.net/ApplicationServices/v200"/>
         </service>
       </services>
       <bindings>
         <basicHttpBinding>
        <binding name="useHttp">
              <!--for production use mode="Transport" -->
          <security mode="None"/>
         </binding>
         </basicHttpBinding>
       </bindings>
       ... 
       <serviceHostingEnvironment aspNetCompatibilityEnabled="true"/>
    </system.serviceModel>
    </configuration>
    
     

     

    Monday, May 28, 2012 2:49 AM