none
I did not use the chainer... everyrthing went OK from the Getting Started page - can't open project files ?

    Question

  • a.) I installed VS2008 - SP1 successfully.

    b.) I already had Blend version 2 with the SP installed.  This was prior to installing Silverlight which should be OK.

    c.) Then I installed the Silverlight Tools For Visual Studio SP-1 which states that it will install

    This download will install the following:

    • Silverlight 2 developer runtime
    • Silverlight 2 software development kit
    • KB956453 for Visual Studio 2008 SP1
      and/or
      KB956485 for Visual Web Developer 2008 Express with SP1
    • Silverlight Tools for Visual Studio 2008 SP1
      and/or
      Silverlight Tools for Visual Web Developer 2008 Express with SP1

    Note: I checked my VS-2008 after the install and I have KB956453 installed whch would indicate the Silverlight install went OK :

    Update for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB956453)   KB956453
    This update is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this update will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/956453.

     The I installed the Silverlight Toolkit.  The only exception to the sequence on http://silverlight.net/GetStarted/  was that I had Blend 2 already installed.

    The problem I have is that when I go to open up any of the Silverlight sample VS projects I get this error:

    Microsoft Silverlight Tools is unable to open the project due to a missing patch ( WHICH ONE ???? ) for Visual Studio.  Please download the latest update from http://go.microsoft.com/fwlink/?LInkId=120032

     I'm stuck in a circular loop where I go to that link install and then I still can't open any of the sample Silverlight projects.  I am running Windows Server 2K8 and in general this is a working clean developer box.

    Any help would be appreciated.

    thanks

    mark


     

    Friday, December 12, 2008 5:21 PM

Answers

  • Hi tibby99,

    We truely understand your feelings.  Has your problem been resolved?    Anyway,  for the installation issues, the easiest way is to remove all the components away and then reinstall them. (Visual Studio is not required to uninstall, but before reinstall, please make sure you have installed all the available patches.)  Please take a look at my two replies on this thread.

    Best regards,

    Jonathan 

    Tuesday, December 16, 2008 9:38 PM

All replies

  • What is the version of (if 32-bit OS:) %programfiles%\Microsoft Visual Studio 9.0\Common7\packages\mswebprj.dll?  It's possible that the patch did not actually install properly (they always claim that they did though Sad).

    Friday, December 12, 2008 6:03 PM
  •  

    The version of mswebprj.dll -> 9.0.30729.1

     

    thanks for any help in advance

    Friday, December 12, 2008 6:11 PM
  •  

    Also the Silverlight Projects DO show up in the New Project dialog but I get the same error when trying to create a Silverlight Application. This of course makes sense but I thought I would mention it anyway.

    Friday, December 12, 2008 6:14 PM
  • This version indicates that the patch didn't actually install properly.  Your thread title says you didn't run the chainer; did you install each component manually? 

    Friday, December 12, 2008 6:19 PM
  • Yes I installed manually.  The Getting Started Page http://silverlight.net/GetStarted does not mention the 'chainer'.  It does have a sequence that for the most part I followed with the exception of Blend.

     

    Shall I uninstall Silverlight for VS-SP1 and then run the Chainer ?  Is it safe to run the Chainer with VS2008 SP1 installed ?  Also is there a way for me to verify that VS-SP1 ACTUALLY WAS installed correctly ?


    I'm not sure to be honest of my original install of VS2008 SP-1 went OK although I did look at the log file and it said that it completed successfully. There was nothing obviously wrong with the install - ad for the individual entries in the logfile I just gloss over them if the summary says the install was successful.

      It did take like 2 hours for the VS2008 - SP1 service pack to install. This is a very high end dev box , quad, 4-gigs, terrabytes disk, etc... so there is nothing wrong with the software or hardware envionrment that I am aware of.

    Friday, December 12, 2008 6:28 PM
  • The "chainer" is actually just the installer for Silverlight Tools for VS SP1; it installs a few different things (SDK, hotfix, and Tools add-on), and hence is called the "chainer."

    Unfortunately, we haven't found a good way to make sure that your SP1 install is indeed correct, uncorrupted, etc.  You could try to repair VS and then run the Silverlight Tools installer again, but I doubt that it will make a difference.  I hate to recommend uninstalling and re-installing VS, but it might be quicker (and still doesn't absolutely guarantee it will work).

    Out of curiosity, do you have any other add-ins or plugins for Visual Studio?  Or have you installed any other hotfixes that you've installed (once you install one, it will list any previous hotfixes for the same component so I'm only wondering about what you've installed)?

    Friday, December 12, 2008 6:45 PM
  • No I really don't have anything unusual : below is the information from my VSS 2008 install.  Perhaps something will standout as unusual.  The only other  major component I have is SQL Server 2005.  The only thing I have done that was out of line in any way was attempting to install the morst recent CAG bits which required VS - SP1  and then doing a cancel of the install when I realized ( most likely the installer complained but who knows ).  Then I uninstalled the CAG bits - but I'm thinking now that something weird was left - just a theory.

     I hate to do it for obvious reasons but it's not the end of the world ( as long as the reinstall works -  it that happens .... - then I'll start preaching about the end of - well - the end of getting home early tonight at least ... Party!!!)

     

    so here i go - reinstall...

    Zip it!

     

     

     

    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Microsoft Visual Studio 2008
    Version 9.0.30729.1 SP
    Microsoft .NET Framework
    Version 3.5 SP1

    Installed Edition: Enterprise

    Microsoft Silverlight Projects 2008   91899-270-2955635-60290
    Microsoft Silverlight Projects 2008
    Version 9.0.30729.146

    Microsoft Visual Basic 2008   91899-270-2955635-60290
    Microsoft Visual Basic 2008

    Microsoft Visual C# 2008   91899-270-2955635-60290
    Microsoft Visual C# 2008

    Microsoft Visual C++ 2008   91899-270-2955635-60290
    Microsoft Visual C++ 2008

    Microsoft Visual Studio 2008 Team Explorer   91899-270-2955635-60290
    Microsoft Visual Studio 2008 Team Explorer
    Version 9.0.30729.1

    Microsoft Visual Studio 2008 Tools for Office   91899-270-2955635-60290
    Microsoft Visual Studio 2008 Tools for Office

    Microsoft Visual Studio Team System 2008 Architecture Edition   91899-270-2955635-60290
    Microsoft Visual Studio Team System 2008 Architecture Edition

    Microsoft Visual Studio Team System 2008 Database Edition   91899-270-2955635-60290
    Microsoft Visual Studio Team System 2008 Database Edition

    Microsoft Visual Studio Team System 2008 Development Edition   91899-270-2955635-60290
    Microsoft Visual Studio Team System 2008 Development Edition

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V.  All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company.  Electronic version licensed from Lernout & Hauspie Speech Products N.V.  All rights reserved.


    Microsoft Visual Studio Team System 2008 Test Edition   91899-270-2955635-60290
    Microsoft Visual Studio Team System 2008 Test Edition

    Crystal Reports    AAJ60-G0MSA4K-68000CF
    Crystal Reports Basic for Visual Studio 2008


    Hotfix for Microsoft Visual Studio 2008 Team Explorer - ENU (KB946260)   KB946260
    This hotfix is for Microsoft Visual Studio 2008 Team Explorer - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946260.

    Hotfix for Microsoft Visual Studio 2008 Team Explorer - ENU (KB946458)   KB946458
    This hotfix is for Microsoft Visual Studio 2008 Team Explorer - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946458.

    Hotfix for Microsoft Visual Studio 2008 Team Explorer - ENU (KB948816)   KB948816
    This hotfix is for Microsoft Visual Studio 2008 Team Explorer - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/948816.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB944899)   KB944899
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/944899.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB945282)   KB945282
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/945282.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB946040)   KB946040
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946040.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB946308)   KB946308
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946308.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB946344)   KB946344
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946344.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB946581)   KB946581
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946581.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB946673)   KB946673
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946673.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB947171)   KB947171
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947171.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB947173)   KB947173
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947173.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB947180)   KB947180
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947180.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB947540)   KB947540
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947540.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB947789)   KB947789
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947789.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB948127)   KB948127
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/948127.

    Hotfix for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB953256)   KB953256
    This hotfix is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/953256.

    Microsoft Visual Studio Team System 2008 Team Suite - ENU Service Pack 1 (KB945140)   KB945140
    This service pack is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this service pack will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/945140.

    Microsoft Visual Studio Team System 2008 Team Suite - ENU Service Pack 1 (KB947888)   KB947888
    This service pack is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this service pack will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947888.

    Update for Microsoft Visual Studio Team System 2008 Team Suite - ENU (KB956453)   KB956453
    This update is for Microsoft Visual Studio Team System 2008 Team Suite - ENU.
    If you later install a more recent service pack, this update will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/956453.

    Friday, December 12, 2008 7:15 PM
  • Hi tibby99,

    We truely understand your feelings.  Has your problem been resolved?    Anyway,  for the installation issues, the easiest way is to remove all the components away and then reinstall them. (Visual Studio is not required to uninstall, but before reinstall, please make sure you have installed all the available patches.)  Please take a look at my two replies on this thread.

    Best regards,

    Jonathan 

    Tuesday, December 16, 2008 9:38 PM
  • Hi

    I've been struggling with the same problem for more than a day now Sad  I installed/re-installed VS 2008, VS 2008 SP1 and Silverlight RTW 3 times and still was not unable to solve the problem.  This was on top of a brand new Vista SP1 installation so no chance of legacy applications causing any havoc.  Eventually (and after some prayer - thank you Lord!), I tried the VS 2008 installation or a last time, but this time I kept all the C++ options selected.  Previously I deselected one of the options (can't seem to reminder which one though).  After the installation finished, I then applied VS 2008 SP1 and the Silverlight Developer Tools and everything worked fine.

    So I you are struggling with getting this to work, please consider following the route mentioned above and you might save yourself hours of installation frustration.  Perhaps someone at Microsoft can now have a look to see why the C++ options need to be installed for this to work in VS 2008.

    Cheers

    Carel

     

    Friday, February 06, 2009 6:37 AM
  •  I got this same problem today. Worth mentioning is that I am not talking about the Silverlight 2 Beta here. I got this message every time I tried to create a new Silverlight project. I tried reinstalling the Silverlight tools a couple of times but had no luck. What I eventually did was:

    * Uninstalled all versionens of Blend, this included the Blend 3 Preview.

    * Uninstalled everything related to Silverlight 2.

    * Uninstalled Visual Studio 2008.

    * Reinstalled Visual Studio, this time with the DEFAULT settings. This is an importent note I think. Maybe I had unchecked something in my custom install that caused this problem?

    * Reinstalled Visual Studio SP1.

     * Finally reinstalled the Silverlight tools again. My version at this time of install was 9.0.30729.146.

     

    Now it actually worked! Good luck to you that had this problem also.

    Monday, April 27, 2009 7:08 AM
  •  I can verify that the product (9.0.30729.146) does not install and run. Well, it will install... but visual studio won't open any silverlight projects due to 'missing patch'. It tries to direct me back to the download page. But I just installed that... It's definitely broken somewhere. Should we just wait for the next generation? BTW, I am not willing to uninstall/reinstall Visual Studio, etc. to get this to run.

     

     

     

     

    Saturday, May 09, 2009 10:32 PM
  • I looked at the SilverlightTools Installer log (when you get to Finish, there is a link for log), it showed me : 

    "[11/19/2009, 16:28:25] (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning IDOK. INSTALLMESSAGE_ERROR [Error 1303.The installer has insufficient privileges to access this directory: c:\Config.Msi. The installation cannot continue. Log on as an administrator or contact your system administrator.]" 

    Even though I had administrator rights. So I uninstalled Silverlight Tools and logged in as administrator and then installed again and there you go, it worked. However it is working only for Administrator account, for my user account it is still giving the same problem.

    My suggestion would be to look at the log and may be you will get something informative there.

    Refer details below:

    "[11/19/2009, 16:28:4] Action: Performing Action on MSI at c:\fba87b9bcf81cef24e0284fb\silverlight_sdk.msi...

    ...
    ...
    [11/19/2009, 16:28:25] (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning IDOK. INSTALLMESSAGE_ERROR [Error 1303.The installer has insufficient privileges to access this directory: c:\Config.Msi. The installation cannot continue. Log on as an administrator or contact your system administrator.]
    [11/19/2009, 16:28:26] (IronSpigot::MsiInstallerBase::PerformAction) MSI (c:\fba87b9bcf81cef24e0284fb\silverlight_sdk.msi) Installation failed. Msi Log: Silverlight 3.0 Tools_20091119_161835480-MSI_silverlight_sdk.msi.txt
    [11/19/2009, 16:28:26] (IronSpigot::MsiInstallerBase::PerformAction) PerformOperation returned 1603 (translates to HRESULT = 0x80070643)"
    Thursday, November 19, 2009 7:56 AM