none
Silverlight Installed, But Always Told To Install

    Question

  • On numerous different web sites whenever I click a link that requires Silverlight, it wants me to install Silverlight even though Silverlight is already installed. I have uninstalled/reinstalled it several times, but I still always get the "Install Silverlight" request/demand.

    I have followed the instructions in http://www.microsoft.com/silverlight/resources/help.aspx?errorID=1502, but there is no "stale" Silverlight registry key.

     It's become really aggravating because more and more web sites are using Silverlight. I can't use Netflix, I can't see my Bungie User Stats, I can't watch movie trailers, etc. etc. etc.

     

    Other people are having the same problem. There's a thread on this subject on "Get Satisfaction!".

     

    So can anyone tell me how to fix it so that Silverlight knows that it's already installed?

     

    Thanks,

         Mike

    Saturday, November 07, 2009 12:31 PM

All replies

  •  In the internet explorer's options press the manage addon button and make sure silverlight is enabled

    Saturday, November 07, 2009 2:52 PM
  • Thanks, sorry, I forgot to mention that I had also tried that.

     

    But just to be on the safe side, I reinstalled Silverlight just now, and verified that Silverlight is enabled.

     

    But the web site still thinks that Silverlight is not installed.

    Saturday, November 07, 2009 3:35 PM
  • Does this website prompt you to install silverlight?

    http://www.microsoft.com/silverlight/get-started/install/default.aspx

     

    Maybe the problem is with the website you are trying to visit

    Saturday, November 07, 2009 6:28 PM
  • Yes, a large black banner states, "Install Silverlight", and a medium-sized red banner says "Experience this in Silverlight install the free plug-in".

     

    The following web-sites also want me to reinstall Silverlight: Zune.net, Bungie.net, Xbox.com, and Netflix.

    Sunday, November 08, 2009 9:53 AM
  •  What operating system are you using on your computer?  What microprocessor do you have?

    Sunday, November 08, 2009 10:14 AM
  • XP Home, SP3.

    Pentium 4 2.53GHz

    IE8.

    Sunday, November 08, 2009 10:30 AM
  • I suspect maybe one of the security settings in IE is preventing the activex control silverlight is running in from starting,  I would try and reset all the security levels to there default settings.  If that is not possible add the websites with silverlight to your trusted sites list.

    Sunday, November 08, 2009 6:46 PM
  • yea, but the average web surfer is just going to say "F*** it, dammed Microsoft S**T" and move on. Been there. Done that. Still annoyed when It comes up all the time. We are about to make a big investment in this stuff. There are too many BS dependencies that depend on a professional MS installation, not a home stick it on your screen configuration. (what does that mean ?) Running an activeX control to see if Silverlight is installed, only to have it disabled by most security software is not a good idea. Even worse, is when you hit the button to install it, the installation fails BECAUSE Silverlight is installed. This is almost a parody fit for the famous Mac vs PC commercials. Wake up and smell the competition (STINKEY ??) A better solution should be out there, even if it breaks the Silverlight security sandbox... wait, do I smell "Goedels Paradox lurking here..." If it smells like Silverlight, but Silverlight can't break its security to test it, is it Silvleright ? Perhaps if it walks like a Duck, Talks like a duck, perhaps there is a way to define it as Ducky. Seriously: It is axiomatic of a logically consistent system to always be incomplete. So, an exception should be made, and ActiveX is not the way to do it (its already to suspect and possibly broken). Perhaps just a working button that says "congrats, you have Vs 3.99s0x0v s Silverlight installed" I'm putting something like that in to my apps, to try to get users to stay current if they go out of browser, disconnected from the net, standalone shivering in their sandbox... too much red bull; back to work... or too much bull. stop me before I make another not so subtle reference again.... dr. K hey hey !
    Sunday, November 08, 2009 9:47 PM
  • I set all my IE Security settings to "default", and that didn't change anything.

     

    When I tried to add a site to "Trusted Sites", it said I could only add links starting with "https", which none of these sites are.

    Monday, November 09, 2009 4:27 PM
  • I've been following this thread. I am also having the same problem with Silverlight on the MSN Money Portfolion site. IE8 with all current updates. Silverlight is certainly a stain on the Microsoft family. There seem to be a lot of sites dependent on Silverlight that cannot be used because of this integration and installation problem. What is MS doing about this?

    Tuesday, November 10, 2009 12:25 AM
  • Hey Ken, I'm still interested in figuring this thing out. I haven't made any disparaging remarks,  Big Smile   and I'm willing to keep trying anything you suggest.

     

    Would it help if I were to use Windows Installer? If I recall correctly, that's supposed to be more thorough than add/remove programs at cleaning up after an uninstall.

     

    Also, I'm a software engineer, a few years ago I wrote about 15KLOCs of VC++. I think I still have the compiler lying around here somewhere that I could install, if there were some debugging you could recommend. If nothing else it would be fun to try.

     

    And if all else fails, it'll give me a good excuse to build myself a hot new Core i7 PC from scratch as a present.

     

    Thanks for all the help so far...

    Wednesday, November 11, 2009 11:34 PM
  • Hi,

       Everytime the silverlight is installed successfully?

       If it is,   you may try disable all your third part ie plugin, sometime this will cause some subtle issue.

    Best Regards

    Thursday, November 12, 2009 12:14 AM
  • Hey Ken, I'm still interested in figuring this thing out. I haven't made any disparaging remarks,  Big Smile   and I'm willing to keep trying anything you suggest.

     

    I know. 

    In the internet explorers options --> programs tab --> press the manage add-ons button and make sure silverlight is enabled. 

    Thursday, November 12, 2009 6:36 AM
  • I have the same problem. I just sent a similar post without looking first if this problem is already discussed (sorry).

    I'm using Windows 7 & IE8. Silverlight add-on is enabled. I have many other ActiveXs that run. This happens in every site that has Silverlight in it. I have many Microsoft SDKs installed on this machine. I suspect that this is the cause for this problem. But I don't want to spend the time of uninstalling them.

     

    Thursday, November 12, 2009 7:07 AM
  • If you had tried with all the options including checking for Add-Ons, then I will suggest just uninstall the Silverlight runtime including any silverlight updates first. Reboot your machine. Then goto registry (regedit) & search for the key "Silverlight". If it is available, just remove it. Now reboot the PC & install Silverlight again.

    NB: Registry editing is dangerous. Only play with registry if you know it well.

    Thursday, November 12, 2009 7:26 AM
  • i will tell this to my users and give them printed instructions.
    Thursday, November 12, 2009 10:32 AM
  • I did everything that you wrote but it didn't help.

    Friday, November 13, 2009 1:23 AM
  • Take a look here. This is a similar thread and I got my problem resolved thanks to a reply sent there.

    Tuesday, November 17, 2009 6:29 AM
  • Go to THIS SITE and tell me if the Silverlight video plays to the right of the text please.  If it does, I may have some limited insight.

     Kurt

    Saturday, January 16, 2010 1:49 AM
  • Go to THIS SITE and tell me if the Silverlight video plays to the right of the text please.  If it does, I may have some limited insight.

     Kurt

    Saturday, January 16, 2010 1:51 AM
  • I think I finally found out what the problem here is. 

    I'm on Win7 x64 Pro, IE8

    It is absolutely a conflict with agcore.dll which you'll likely find at C:\Program Files (x86)\AGI\core\3.1\agcore.dll

    It is the same name as agcore.dll for Silverlight which is at C:\Program Files (x86)\Microsoft Silverlight\3.0.50106.0\agcore.dll

    The AG Core Services service was running, and the agcore.dll that is registered in Windows is the AGI one instead of the silverlight version.  Silverlight calls agcore.dll and gets the AGI one and thus the website doesn't think you have silverlight installed.  Basically, silverlight is trying to run the wrong agcore.dll file.  So you could delete the agcore.agutils folder, delete the AGI folder in Program Files, stop the AG Core Service and disable it permanently and reinstall Silverlight and you'll probably be fine.  If you want to know how it got there, you'll have to find out what application installed the AG Core.  In my case, I went to http://www.interactive.ag.com/ and clicked on "brands" and found that AG Interactive is the publisher of both Webshots (wallpaper and screensaver tool) and Kiwee (MSN Messenger add on).  Both of which I use or have used in the past.  That's likely how the service and dll ended up on my PC.

    To solve my problem, I had to stop the AG Core Service.  I had to disable the service and reboot for it to completely stop.  Then I renamed the AGI folder, deleted the agUtils registry key at HKEY_CLASSES_ROOT\agcore.AGUtils and then reinstalled Silverlight.  Now the agcore.dll registers correctly to silverlight and it works on all sites.

    HTH!

    FunRuss

    Tuesday, January 19, 2010 6:06 PM
  • Hi,  I'm on Windows XP, but had the same problem.  We have both Webshots and Kiwee on our computer, went in Manage Add-ons (in IE) and disabled the AG Core service.  Netflix movies now run OK, and so does Webshots screensaver.  Never use MSN Messenger anyway, so who cares? I didn't need to edit registry key, but if I encounter a problem with Webshots, that would be the next move.  Thanks for the info!

    Friday, January 29, 2010 5:53 PM