none
NETFLIX WONT STAY IN FULLSCREEN!

    Question

  • Hi! this is my first time posting to a forum but i am having an extremely difficult time fixing this problem.

    Since netflix has switched to the silverlight platform, when I watch a video in full screen, it will automatically switch out of fullscreen mode, to default size, or sometimes even minimize my whole internet explorer, so that my wallpaper is showing. there is also this shiny, silveryl light on my wallpaper. I will have to keep clicking 'put in full screen mode' every 3 minutes. This is very annoying. I have tried everything to fix this. Netflix has never heard of this issue, windows wont help me, and i cant contact anyone from silverlight.
    I have windows 7 operating system, and i am currently using google chrome, but the problem still occurs in firefox, and internet explorer. Any help would be much appreciated, thank you. 

    Sunday, February 26, 2012 11:03 AM

Answers

  • Right-Click over Silverlight and select "Silverlight" from the ContectMenu.

    Select the Permissions Tab.

    Make sure Netflix has Permission to stay in Full-Screen when Unfocused.

     

    If that is not it, you need to contact Netflix.  I just wrote an app that uses this feature and it works.

    Tuesday, February 28, 2012 7:01 PM

All replies

  • Hi GuitarGirl,

    Thank you for your post.

    I am trying to involve someone familiar with this topic to further look at this issue.

    Best Regards,

    Tuesday, February 28, 2012 2:04 AM
    Moderator
  • Right-Click over Silverlight and select "Silverlight" from the ContectMenu.

    Select the Permissions Tab.

    Make sure Netflix has Permission to stay in Full-Screen when Unfocused.

     

    If that is not it, you need to contact Netflix.  I just wrote an app that uses this feature and it works.

    Tuesday, February 28, 2012 7:01 PM
  • Right-Click over Silverlight and select "Silverlight" from the ContectMenu.

    Select the Permissions Tab.

    Make sure Netflix has Permission to stay in Full-Screen when Unfocused.

     

    If that is not it, you need to contact Netflix.  I just wrote an app that uses this feature and it works.

    I have Firefox 11 and Silverlight 5 64-bit.  I tried this and netflix will not display in the permission for Full-Screen when Unfocused.  I manually added it in the registry and still it does not work.  I tried another website that uses silverlight and I even got the popup asking for permission and it worked on that site, however it refuses to work on Netflix.  I even uninstalled and reinstalled Silverlight 64-bit as well as tried an older instance (SL 4.1) to no avail.  I of course also tested it in IE.  So currently I cannot maintain a full-screen video of silverlight on my secondary screen while I do other things.

    Now Netflix is claiming that I have to contact Microsoft for a solution, when it's likely a website coding issue on their end.  Microsoft also says that they'll charge me for help because I have an OEM version of Windows (I'm the manufacturer of my PC).

    Friday, April 20, 2012 12:28 AM
  • Another time MS sacrifices users for the corporate dollars. This apparantly is taken out because it causes some "security" issue in silvelight. So, instead of fixing that, MS simply took it out. If only they put the users first like linux they wouldn't be losing market share

    Friday, May 11, 2012 11:22 PM
  • Today I was having the same problem while using Firefox, and I discovered a solution. If you remove the Stay Fullscreen While Unfocused permission (if it's there that is), end the "plugin-container.exe" process in Task Manager - this is the program that runs all plug-ins for Firefox - it should kill your playing video with the "Silverlight has crashed." message. Simply reload the page, push the Enter Fullscreen button, and it should ask again if you want to keep the video fullscreen while unfocused. That fixed my problem, hopefully it fixes yours.

    With other browsers though, I'm going to say maybe closing the browser itself and reloading it might work, but I'm not sure.

    Wednesday, May 16, 2012 8:53 AM
  • It seems the Silverlight permissions are display specific, or at least if you give access while the browser was in main display, it will not suffice to run it fullscreen on your secondary monitor/TV (it will go into fullscreen but if you click in primary display, or another program, the fullscreen will close).

    Quick fix is to remove Netflix rights and give them again, ie. right-click Silverlight, click Permissions tab, remove Netflixes, close Silverlight settings window, make sure your browser is in the the display you planning on using it, click fullscreen button in Netflix stream, give permissions again, and you should be ok.

    Not sure what "corrupts" the permissions, even though you can see them given inside Silverlight. Maybe the display identity changes, when you change between clone and extended display modes, or some sort of bug in Silverlight.

    Tuesday, December 10, 2013 6:44 PM
  • this doesn't work. if you remove netflix permission. Close everything and restart, go back to netflix it doesn't ask for for permissions again and there's no way to trigger adding them back in. Secondly uninstalling silverlight entirely and reinstalling still doesn't allow me add netflix permissions.  
    Monday, December 16, 2013 5:27 AM
  • So for those who can't seem to do the Right-Click Silverlight and select silverlight...

    Here's an alternate solution:

    Just watch whatever movie/show you want and then press f11 (if nothing happens click the searchbar and press f11 again). Then, make the movie fullscreen as you have normally done. Finally after the movie is in fullscreen, move your arrow to the top right corner of your screen and let it stay there. Ta-da! Enjoy your movie/show without the annoying constant fullscreen escaping...

    Also press f11 after you press escape if you want everything back to normal.

    note: f11 for most laptops has to be pressed simultaneously with "fn" usually found near "alt" and "ctrl."

    Cheers!

    Tuesday, March 25, 2014 6:20 AM
  • So for those who can't seem to do the Right-Click Silverlight and select silverlight...

    Here's an alternate solution:

    Just watch whatever movie/show you want and then press f11 (if nothing happens click the searchbar and press f11 again). Then, make the movie fullscreen as you have normally done. Finally after the movie is in fullscreen, move your arrow to the top right corner of your screen and let it stay there. Ta-da! Enjoy your movie/show without the annoying constant fullscreen escaping...

    Also press f11 after you press escape if you want everything back to normal.

    note: f11 for most laptops has to be pressed simultaneously with "fn" usually found near "alt" and "ctrl."

    Cheers!


    Ha!! So simple it was right in my face. Doesn't use the Silverlight full screen, but the IE full screen function. Still, it works. Who cares! Works on all my displays.
    Wednesday, April 02, 2014 11:52 PM