none
Error installing Silverlight Tools on Windows 7 (x64)

    Question

  • Executable gets past the "Downloading..." phase, but crashes on the "Installing..." with the following error: Exe (c:\f6077371619fc17129afe1136deb5d\PurgeSLTCache.exe) succeeded. Exe (C:\Users\dcuccia\AppData\Local\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe) failed with 0x80070643 - Fatal error during installation. . Exe (c:\f6077371619fc17129afe1136deb5d\PurgeSLTCache.exe) succeeded. Final Result: Installation failed with error code: (0x80070643), Fatal error during installation. Anyone successfully installed SL Tools on Windows 7?
    Saturday, January 17, 2009 6:45 PM

Answers

  • Literally as I was typing up a reply including posting my log file, action center popped up with the solution. I did what it said and Silverlight_Tools.exe has indeed gone past where it failed before. So I'll post that instead of the log file.

     

    An issue with the Customer Experience Improvement Program (CEIP) client in Windows 7 beta is causing Explorer and some MSI-based installers to stop working properly.

    To solve this problem, follow these steps:

    1. Click the Start button , click All Programs, and then click Accessories.

    2. Right-click Command Prompt, and then click Run as administrator. In the User Account Control window, verify that Program name is Windows Command Processor, and then click Yes.

    3. In the Administrator: Command Prompt window, type or paste the following text at the prompt:

      reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions /va /f

    4. Press Enter to install the solution.

    5. If The operation completed successfully displays, close the Administrator: Command Prompt window to complete this procedure. If "ERROR: Access is denied" displays, repeat this procedure from the top, making sure you clicked Run as administrator in step two.

     

    Tuesday, January 20, 2009 8:49 AM

All replies

  • me too,so i have to return to xp

    Sunday, January 18, 2009 3:00 AM
  • I've installed Silverlight tools on Windows 7 (x64) and all works fine.

    This is my "install log":

    • Visual Studio 2008;
    • Expression Blend 2;
    • VS 2008 SP1;
    • Silverlight tools;
    • Expression Blend 2 SP1.
    Sunday, January 18, 2009 12:08 PM
  •  Same problem here with the 32-bit version of Windows 7. My log looks the same as yours too.

     

    Monday, January 19, 2009 8:31 AM
  •  Hi,

    It's weird. We have installed Silverlight on our PC(Windows 7(x64)), and installed it successfully.

    Can you post your installation log here, which will be  able to help further.

    Tuesday, January 20, 2009 3:23 AM
  • Literally as I was typing up a reply including posting my log file, action center popped up with the solution. I did what it said and Silverlight_Tools.exe has indeed gone past where it failed before. So I'll post that instead of the log file.

     

    An issue with the Customer Experience Improvement Program (CEIP) client in Windows 7 beta is causing Explorer and some MSI-based installers to stop working properly.

    To solve this problem, follow these steps:

    1. Click the Start button , click All Programs, and then click Accessories.

    2. Right-click Command Prompt, and then click Run as administrator. In the User Account Control window, verify that Program name is Windows Command Processor, and then click Yes.

    3. In the Administrator: Command Prompt window, type or paste the following text at the prompt:

      reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions /va /f

    4. Press Enter to install the solution.

    5. If The operation completed successfully displays, close the Administrator: Command Prompt window to complete this procedure. If "ERROR: Access is denied" displays, repeat this procedure from the top, making sure you clicked Run as administrator in step two.

     

    Tuesday, January 20, 2009 8:49 AM
  • Worked!! Thanks!!! P.S. What did I just do?
    Tuesday, January 20, 2009 4:15 PM
  • i install on vista ultimate 64 bit and it install great,no problems

    Tuesday, January 20, 2009 6:45 PM
  • Hi Wanda,

    I got following error while trying to install Silverlight_Tools.exe. I have VS 2008 SP1, Blend 2 and those were installed before attempting to install silverlight tools.

    Launching CreateProcess with command line = Silverlight.2.0_Developer.exe /q /ignorewarnings
    [4/12/2009, 0:33:56] (IronSpigot::ExeInstallerBase::EnsureExitCodeIsAnMSIErrorCode) Original exit code: C:\DOCUME~1\Mustafa\LOCALS~1\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe returned non-MSI error code: 0x5e2 - (null)
    [4/12/2009, 0:33:56] (IronSpigot::ExeInstallerBase::PerformAction) C:\DOCUME~1\Mustafa\LOCALS~1\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe - Exe installer does not provide a log file name
    [4/12/2009, 0:33:56] (IronSpigot::ExeInstallerBase::PerformAction) Exe (C:\DOCUME~1\Mustafa\LOCALS~1\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe) failed with 0x80070643 - Yükleme sırasında önemli hata. .
    [4/12/2009, 0:33:56] (IronSpigot::ExeInstallerBase::PerformAction) PerformOperation on exe returned exit code 1603 (translates to HRESULT = 0x80070643)

    Rgrds,

    Mustafa

    Saturday, April 11, 2009 5:42 PM
  • Hi all,

    I solved my problem with following steps:

    • Uninstalled all versions of silverlight
    • Registered MergeMod.dll
    • Restarted Windows
    • Installed silverlight tools again and installation succeded.

    Rgrds,

    Mustafa

    Saturday, April 11, 2009 6:29 PM
  • Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 2:14:58: RegisterProgIdInfo. Registering program identifiers]
    [5/2/2009, 2:14:58] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 2:14:58: RegisterTypeLibraries. Registering type libraries]
    [5/2/2009, 2:14:58] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 2:14:58: WriteRegistryValues. Writing system registry values]
    [5/2/2009, 2:15:1] (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning IDOK. INSTALLMESSAGE_ERROR [Error 1406.Could not write value to key \Software\Classes\Interface\{A9F86308-5EA7-485D-BAB8-E8989C3CFBDC}\NumMethods. Verify that you have sufficient access to that key, or contact your support personnel.]
    [5/2/2009, 2:15:2] (IronSpigot::MsiExternalUiHandler::UiHandler) Returning IDOK. INSTALLMESSAGE_ACTIONSTART [Action 2:15:02: Rollback. Rolling back action:]
    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::PerformMsiOperation) Patch (c:\3894c139ebe32c3487\VS90SP1-KB967143-ENU.msp) install failed on product (Microsoft Visual Studio 2008 Professional Edition - ENU). Msi Log: Silverlight 3.0 Tools Beta 1_20090502_021255528-Microsoft Visual Studio 2008 Professional Edition - ENU-MSP0.txt
    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::PerformMsiOperation) MsiApplyMultiplePatches returned 0x643

    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::Rollback) exiting function/method
    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::Rollback)
    [5/2/2009, 2:15:50] Action complete. Log File: C:\Users\Admin\AppData\Local\Temp\Silverlight 3.0 Tools Beta 1_20090502_021255528-Microsoft Visual Studio 2008 Professional Edition - ENU-MSP0.txt

    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::PerformMsiOperation) exiting function/method

    [5/2/2009, 2:15:50] (IronSpigot::MspInstallerT<class ATL::CPathT<class ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class ATL::ChTraitsCRT<unsigned short> > > > >::PerformMsiOperation) failed and rolled back

    [5/2/2009, 2:15:50] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x643
    [5/2/2009, 2:15:50] (IronSpigot::BaseMspInstaller::PerformAction) exiting function/method

    [5/2/2009, 2:15:50] (IronSpigot::BaseMspInstaller::PerformAction) PerformMsiOperation returned 0x643
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiUnInstaller,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeUnInstaller,class IronSpigot::CartmanExeUnInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = PurgeSLTCache.exe /skip
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::PerformAction) c:\3894c139ebe32c3487\PurgeSLTCache.exe - Exe installer does not provide a log file name
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::PerformAction) Exe (c:\3894c139ebe32c3487\PurgeSLTCache.exe) succeeded.
    [5/2/2009, 2:15:50] Action complete
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiUnInstaller,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeUnInstaller,class IronSpigot::CartmanExeUnInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = Silverlight.3.0_Developer.exe /qu
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::Launch) Error launching CreateProcess with command line = Silverlight.3.0_Developer.exe /quThe system cannot find the file specified.
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::Launch) CreateProcess returned error = The system cannot find the file specified.
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::EnsureExitCodeIsAnMSIErrorCode) Original exit code: C:\Users\Admin\AppData\Local\Temp\Silverlight 3.0 Tools Beta 1\Silverlight.3.0_Developer.exe returned non-MSI error code: 0x2 - The system cannot find the file specified.
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Admin\AppData\Local\Temp\Silverlight 3.0 Tools Beta 1\Silverlight.3.0_Developer.exe - Exe installer does not provide a log file name
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::PerformAction) Exe (C:\Users\Admin\AppData\Local\Temp\Silverlight 3.0 Tools Beta 1\Silverlight.3.0_Developer.exe) failed with 0x80070643 - Fatal error during installation. .
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::PerformAction) PerformOperation on exe returned exit code 1603 (translates to HRESULT = 0x80070643)
    [5/2/2009, 2:15:50] Action complete
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiUnInstaller,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::MspUninstallerT<class IronSpigot::CMsiInstallContext>,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeUnInstaller,class IronSpigot::CartmanExeUnInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [5/2/2009, 2:15:50] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = PurgeSLTCache.exe /q
    [5/2/2009, 2:15:51] (IronSpigot::ExeInstallerBase::PerformAction) c:\3894c139ebe32c3487\PurgeSLTCache.exe - Exe installer does not provide a log file name
    [5/2/2009, 2:15:51] (IronSpigot::ExeInstallerBase::PerformAction) Exe (c:\3894c139ebe32c3487\PurgeSLTCache.exe) succeeded.
    [5/2/2009, 2:15:51] Action complete
    [5/2/2009, 2:15:51] Action complete

    [5/2/2009, 2:15:51] (IronSpigot::LogUtils::LogFinalResult) Final Result: Installation failed with error code: (0x80070643), Fatal error during installation.

    [5/2/2009, 2:15:51] Action complete
    Tuesday, May 05, 2009 8:20 PM
  • under your user /appdata/local/temp/2 there is a silverlight0.txt file

    I had the following message under that file

      [15:42:19] Silverlight installer logging started.
    [15:42:19] Silent mode enabled
    [15:42:19] ignorewarnings
    [15:42:19] Installer is newer than installed product, beginning installation.
    [15:42:19] Contents of pending file operations registry key:
    [15:42:19] \??\C:\Program Files (x86)\Microsoft Silverlight\2.0.40115.0\agcore.debug.dll
    [15:42:19] Pending operation with path include Microsoft Silverlight found
    [15:42:19] Returned from install call
    [15:42:19] Finished the install.
    [15:42:19] Silent installer done
    [15:42:19] Silverlight installer logging ended.

    I searched for that c:\programfile in my registry and cleanedup that section. Then tried to install silverlight 2 and things went on well after that.

    Friday, July 03, 2009 5:58 PM
  • Hy Amanda,

           Hy i got the same problem what Omnius got it. Please help me. Help me @ sgobikannan@hotmail.com..

     

    Regards

    Gobi

    Saturday, July 11, 2009 12:59 PM
  • Hi Windows 7 users!

    I just wondering how many users are confronted with different problems? I installed yesterday Win7 Ultimate. I installed my favorite progs used on Vista. So far, everything works great Silverlight tools including.

    Andris

    Latvia


    Wednesday, February 03, 2010 9:22 AM
  • I have and old version of Silverlight installed but I cannot up upgrade it, nor can I uninstall it.  I get the same error:  It wants an MSI on my drive G which I do not have !!

    Wednesday, February 03, 2010 6:24 PM
  •  I got Windows XP SP3 and did not work, still trying.

    Wednesday, February 03, 2010 7:49 PM
  • Just install the VS 2010 Sliverlight tools package from this url:

    http://bit.ly/cgCHs6


    Then run the Web platform installer to install the April 2010 CTP or WCF RIA Services if required.


    Hope this helps.


    Regards,

    Mostafa Elzoghbi

    http://moustafa-arafa.blogspot.com


    Wednesday, July 21, 2010 5:23 PM