none
session cookies must be allowed

    Question

  • I get the error

    "The form cannot be displayed in the browser because the use of session cookies has been disabled in the current browser settings. In order to load the form, session cookies must be allowed"

    when trying to connect to some Sharepoint 2007 infopath pages which are in the Local Intranet Zone. 

    Path: WrkTaskIP.aspx?ID=2&List=87365a5d-e84f-42fb-9244-28abe8dfbee9&_InfoPath_Sentinel=1

    According to Microsoft all cookies are automatically accepted from Web sites in the Local Intranet zone.  So why am I getting this error.  However I changed my IE privacy setting to "always allow session cookies" but still get the same error which isn't suprising as the privacy settings affect the Internet zone.

    Does anyone know why I get this session cookie error when trying to access InfoPath Sharepoint 2007 pages?

     

    Thursday, January 18, 2007 10:56 PM

Answers

All replies

  • I get the same issue, any suggestions?
    Monday, February 19, 2007 11:19 PM
  • I am also having this problem on my public-facing Internet site. Only, it's sporadic. Sometimes the form comes up fine. Most times however, I get the error message.

    Why is InfoPath trying to use cookies anyway. I want browsers to see my form without having to allow cookies.

    Tuesday, February 20, 2007 4:57 PM
  • I get the same error when i try to use workfolow .

    i changed IE privacy setting to "always allow session cookies" but i still get the same error

    Saturday, February 24, 2007 9:05 AM
  • I have found such a suggestion here:

     

    http://www.venkat.org/index.php/2007/03/11/session-cookies-and-_-underscores-in-sharepoint/

     

    It says:

    "...browsers (only IE works great in Firefox) does not accept cookies if a host name contains the underscore character “_” ..."

     

    It is working ok when you the name for your application from e.g.  infopath_123.firm.com to infopath123.firm.com

     

    It worked for me!

     

    Good luck!

    Thursday, April 05, 2007 9:51 AM
  • I read it before , Realy My server Host name contain "_" ...

    In the next week i will try to setup sharepoint server in a server its name not contain "_"

    I hope this will solve My problem

    Thursday, April 05, 2007 10:00 AM
  •  

    hi guys,,i can't wirte will be very well,but i'll tall u how u can fix this problem,,

     

    go to controll panel than click internet options and click privacy and bring down setting zoneto ACCEPT ALL COOKIES,, and than click apply,,now everythink is fine,,ok
    Thursday, September 20, 2007 2:46 AM
  • hi katrina,,it will be help u,,
    but 


    ,i can't wirte will be very well,but i'll tall u how u can fix this problem,,

     

    go to controll panel than click internet options and click privacy and bring down setting zoneto ACCEPT ALL COOKIES,, and than click apply,,now everythink is fine,,ok


    Thursday, September 20, 2007 2:50 AM