none
Error during SP2010 configure - Failed to create sample data

    Question

  • Hello team,

    I'm trying to configure SP 2010 and getting below error: Any clue?

    Microsoft.Office.Server.UserProfiles.UserProfileException: Unrecognized attribute 'allowInsecureTransport'. Note that attribute names are case-sensitive. (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebClients\Profile\client.config line 56) ---> System.Configuration.ConfigurationErrorsException: Unrecognized attribute 'allowInsecureTransport'. Note that attribute names are case-sensitive. (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebClients\Profile\client.config line 56)
       at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult)
       at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.ConfigurationSectionCollection.Get(String name)
       at System.ServiceModel.Configuration.ServiceModelSectionGroup.get_Client()
       at Microsoft.Office.Server.UserProfiles.MossClientBase`1.GetServiceBinding(String endpointConfigurationName)
       at Microsoft.Office.Server.UserProfiles.MossClientBase`1.GetChannelFactory(String endpointConfigurationName)
       at Microsoft.Office.Server.UserProfiles.MossClientBase`1.get_Channel()
       at Microsoft.Office.Server.UserProfiles.MossClientBase`1.ExecuteOnChannel(String operationName, CodeBlock codeBlock)
       at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)
       --- End of inner exception stack trace ---
       at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.ExecuteOnChannel(String operationName, CodeBlock codeBlock)
       at Microsoft.Office.Server.UserProfiles.ProfilePropertyServiceClient.GetProfileProperties()
       at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID)
       at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValueNow(K key)
       at Microsoft.Office.Server.Utilities.SPAsyncCache`2.GetValue(K key, Boolean asynchronous)
       at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache()
       at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.Provision()
       at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.ProvisionServiceApplicationsAndProxies()
       at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.Run()


    TIA,
    Manish
    • Moved by Mike Walsh FIN Tuesday, November 17, 2009 5:09 AM sp 2010 (From:SharePoint - Setup, Upgrade, Administration and Operation)
    Monday, November 16, 2009 11:37 PM

Answers

  • An exception of type Microsoft.Office.Server.UserProfiles.UserProfileException was thrown. Additional exception information: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: ....
    This text indicates to me that you do not have WCF HTTP Activation and WCF non-HTTP Activation enabled on your server. I can see this because a WCF call expects a soap response and if it received text/html then that means no WCF code was activated on the server.

    To correct this use the following command which I've taken from the Windows 7 install guide here.

    start /w pkgmgr /iu:WCF-HTTP-Activation;WCF-NonHTTP-Activation;

    Regards,
    Paul

    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    • Marked as answer by Darrin Bishop Tuesday, November 24, 2009 2:09 PM
    Tuesday, November 24, 2009 1:43 AM

All replies

  • Looks a lot like the WCF error (KB971831).  Are you on Server 2008 R2?  Win 7?

    See item #4 for more info:  http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx
    Tuesday, November 17, 2009 1:44 AM
  • Hello,

    According to a tweet earlier today, you can remove the allowInsecureTransport to configure properly: http://twitter.com/mphacker/statuses/5779828509

    As has been mentioned, this is likely due to the WCF bug.

    .b
    Learn SharePoint with Understanding SharePoint Journal http://www.understandingsharepoint.com/journal
    Tuesday, November 17, 2009 1:49 AM
  • Post ALL SP 2010 items to a SP 2010 forum. (At the moment there is only one but I expect more).


    Moving this post.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Tuesday, November 17, 2009 5:09 AM
  • Here's the link to the hotfix now available: http://go.microsoft.com/fwlink/?LinkID=166231


    Regards,
    Paul
    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    Monday, November 23, 2009 1:29 AM
  • I hit the same issue while installing SharePoint Server 2010 (standalone installation) on Windows 2008 Server R2 , and I do have KB  http://go.microsoft.com/fwlink/?LinkID=166231 installed.At this momment , I have created a new site collection inside application at port 80 and it seems to be working fine. May I know how should I proceed now?
    Monday, November 23, 2009 3:58 AM
  • I also have the same issue as Razi! The confiuration fails in step 8 when installing sample data and I have the hotfix installed properly. I get an error as follows in the event log

    Failed to create sample data.

    An exception of type Microsoft.Office.Server.UserProfiles.UserProfileException was thrown. Additional exception information: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: ....

    some where along I get

    Server Error in '/919daa111aab47c6836804de4ec'. ---> System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly.

    Wierd thing is that I am also getting a lot of System.ServiceModel 3.0.0.0 and don't know exactly if that's assiocated with this issue. Entry is as follows;

    WebHost failed to process a request.

    Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/21212130

    Exception: System.ArgumentException: An item with the same key has already been added.

    at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)

    at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)

    Process Name: w3wp

    Process ID: 2028

    Everything ssems to be working besides the occasional "beta" error but I really want to get rid of these messages and be able to run the wizard as should...

    Cheers


    ********** UPDATE *******

    Please also notica that the configuration wizard error  mentions "IsContentTypeSupported " and not "allowInsecureTransport" as mentioned in most posts before applying the WCF hotfix....
    Monday, November 23, 2009 1:39 PM
  • An exception of type Microsoft.Office.Server.UserProfiles.UserProfileException was thrown. Additional exception information: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: ....
    This text indicates to me that you do not have WCF HTTP Activation and WCF non-HTTP Activation enabled on your server. I can see this because a WCF call expects a soap response and if it received text/html then that means no WCF code was activated on the server.

    To correct this use the following command which I've taken from the Windows 7 install guide here.

    start /w pkgmgr /iu:WCF-HTTP-Activation;WCF-NonHTTP-Activation;

    Regards,
    Paul

    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    • Marked as answer by Darrin Bishop Tuesday, November 24, 2009 2:09 PM
    Tuesday, November 24, 2009 1:43 AM
  • Hi Paul,

    I managed to figure it out thanks to your tip! Thanks a lot! The WCF-NonHttp-Activation feature wasn't enabled on my machine. When following the setup guide on MSDN I didn't use the script but cross checked my features with the screenshots in the article. In the screenshots the WCF-NonHttp-Activation feature isn't checked so that's the reason why it wasn't working on my machine. The script sample though does include the WCF-NonHttp-Activation feature so perhaps that something to get straighten out in the setup guide.

    After enabling the WCF-NonHttp-Activation feature I took a look in the event log and saw some errors there referring to the fact the Windows Process Activation service wasn't running. I checked it out and was running but set to manual. Changed it to automatic to make sure it's always running.

    Reran the configuartion wizard succesfully! So that solved the configuration wizard but still a lot of SharePoint errors and warnings in my event log. Really dislike a coloured event log so still working on that.  I am on that in a seperate thread here;

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/c894d98c-24ab-416c-aca9-ae57644deb5e/


    Thanks a lot for the hint!

    Regards,
    Xavier
    Tuesday, November 24, 2009 1:51 PM
  • When following the setup guide on MSDN I didn't use the script but cross checked my features with the screenshots in the article. In the screenshots the WCF-NonHttp-Activation feature isn't checked so that's the reason why it wasn't working on my machine. The script sample though does include the WCF-NonHttp-Activation feature so perhaps that something to get straighten out in the setup guide.
    Yes, the screenshot is wrong in that article. Sorry about that, we know about the issue, but there are delays in getting those things updated.

    Regards,
    Paul

    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, November 24, 2009 4:53 PM
  • It worked for me after enabling WCF HTTP activation through command: start /w pkgmgr /iu:WCF-HTTP-Activation;WCF-NonHTTP-Activation; and by installing the hot fix from: http://go.microsoft.com/fwlink/?LinkID=166231

    Cheers
    Imran Shafqat


    Imran Shafqat
    Tuesday, January 26, 2010 10:13 PM
  • I hit the same issue while installing SharePoint Server 2010 (standalone installation) on Windows 2008 Server R2 , and I do have KB  http://go.microsoft.com/fwlink/?LinkID=166231 installed.At this momment , I have created a new site collection inside application at port 80 and it seems to be working fine. May I know how should I proceed now?

    I had the exact same issue as Razi, but I wasn't aware of the 'hotfix'.  Once I downloaded and installed it, SharePoint is working like a dream.  Now I just have to start downloading/purchasing documentation on the use of SharePoint & Project Server (which is what I'm currently testing - Project Server 2010).  If anyone has any links to helpful documentation, I would be extremely grateful.
    Thursday, April 22, 2010 7:40 PM
  • Hi All,

    I have tried to install the SP 2010 on windows 7 Professional. I got the error below on configuration wizard step 8 i.e. creating sample data.

    An exception of type System.ServiceProcess.TimeoutException was thrown.  Additional exception information: Time out has expired and the operation has not been completed.
    System.ServiceProcess.TimeoutException: Time out has expired and the operation has not been completed.
       at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)
       at Microsoft.SharePoint.Win32.SPAdvApi32.StopService(String strServiceName)
       at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.Stop()
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Provision()
       at Microsoft.Office.Server.Search.Administration.SearchAdminUtils.DeployLocalServiceInstance[T](T localSearchServiceInstance)
       at Microsoft.Office.Server.Search.Administration.SearchQueryAndSiteSettingsService.CreateApplication(String name, Type serviceApplicationType, SPServiceProvisioningContext provisioningContext)
       at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.ProvisionServiceApplicationsAndProxies()
       at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    Please help to out of this.

    Thanks in advance

    Nikunj Chudasama

    Wednesday, October 27, 2010 9:21 AM