none
After deleting a required field on my form, now after saving the form and filling it out, I cannot submit the form as it is looking for that field even though it does not exist

    Question

  • I deleted one of my fields (which was a required field) and now I cannot submit the form as it is still looking for that field even though it does not exist anymore on the form.  I have published the form and republished it again.

    Second question - I have a drop-down list box control on my form and I keyed in the values for the field manually, however when the form is filled out and submitted to my sharepoint doc library, no value shows up in SharePoint even though I filled out that field.   What could I be possibly doing wrong???

    <shaking head with frustration>
    Thursday, June 25, 2009 8:14 PM

Answers

  • Hameed, you didn't delete the field.  You just deleted the control bound to that field.  The field itself in your main data source is still required whether your control is on the canvas or not.  Go into your main data source, find that data element, right-click and delete it for REAL.  I answered this in your other thread and explained what's going on.

    In dropdown boxes, there are both values and display names.  The value is what determines the true data of the field and is what will go to SharePoint.  Did you input any values?  If so, then those values will definitely show up in SharePoint as long as you have promoted that property during the publishing process.
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Thursday, June 25, 2009 10:55 PM
  • The main data source is the built-in one where you add all your data fields and name them.  There is no form without a main data source.  that main data source can be an external data source or just the form itself with whatever fields you add - I assume you started with a blank form and went from there, so the main data source is just the myFields top group with data fields under it.  You get to it by just looking at the Design Tasks pane on the right and clicking on Data Source.  You could not have built your form without spending almost all of your time here, so if you're not familiar with this part, then my assumption would be that someone else built the form initially? Anyway, go there and find the field that was required...it is still in the template and is still required whether you have a control on the canvas or not.  Just delete it or make it not required.

    Did you key in VALUES or just DISPLAY NAMES.  Every option in a dropdown list has both and they don't have to be the same.  If you have both values and display names, then the values _will_ show up in the SharePoint list if you publish it properly.  Promoting properties is when you choose which fields from your form should be published into the form library.  You said you added it, but if you did, then it would show up automatically, so I don't think you did. 

    If you want help with this directly, you can go to my blog's contact page to send the template to me via email.


    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 1:09 AM
  • So, the required field error is no longer an issue, right?  I'll figure out the promoted property.
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 2:25 PM
  • I've already worked on it and confirmed that it works perfectly.  The Description pulldown shows all the display names, and all the display names are also the values.  When I publish it to my library, the Description shows up in my library just as it should.  I tried 3 different selections and all of them worked.  I'll send you a screenshot back via email in case what you see on my screen is different.  You had it all set up just right, so it should be working, which would indicate an issue with your library maybe.

    By the way, it looks like you are already putting my article to great use for your submit button: Auto-Generating Filenames for InfoPath Forms.  That's really great to see my article doing some good!
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 2:42 PM
  • Wow, I've never seen this, but it appeared that even though it worked well on my system, Hameed was having a conflict with his field that was named "Description."  I don't know exactly what the conflict was, but that was my only guess after much troubleshooting.  After he changed the name to something else and re-published the property, it started working.  There must have been a conflict with the OOTB Description site column or something...
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 8:19 PM

All replies

  • Hameed, you didn't delete the field.  You just deleted the control bound to that field.  The field itself in your main data source is still required whether your control is on the canvas or not.  Go into your main data source, find that data element, right-click and delete it for REAL.  I answered this in your other thread and explained what's going on.

    In dropdown boxes, there are both values and display names.  The value is what determines the true data of the field and is what will go to SharePoint.  Did you input any values?  If so, then those values will definitely show up in SharePoint as long as you have promoted that property during the publishing process.
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Thursday, June 25, 2009 10:55 PM
  • Hi Clayton,

    Thanks again for the prompt response.

    I will fix the first issue when I go back to the office tomorrow.   How do I get to the "main data source"?   The form is not connected to any backend system or anything of that sort.

    Regarding the second issue - I did key in manually values for the drop down list.  I basically populated the first field and it automatically populated the display field.   What do you mean when you say "promoted that property"?  I published the form and added that field in one of the boxes of publishing wizard.  Is that what you mean as promoting it? Please clarify.  Thanks!
    Thursday, June 25, 2009 11:19 PM
  • The main data source is the built-in one where you add all your data fields and name them.  There is no form without a main data source.  that main data source can be an external data source or just the form itself with whatever fields you add - I assume you started with a blank form and went from there, so the main data source is just the myFields top group with data fields under it.  You get to it by just looking at the Design Tasks pane on the right and clicking on Data Source.  You could not have built your form without spending almost all of your time here, so if you're not familiar with this part, then my assumption would be that someone else built the form initially? Anyway, go there and find the field that was required...it is still in the template and is still required whether you have a control on the canvas or not.  Just delete it or make it not required.

    Did you key in VALUES or just DISPLAY NAMES.  Every option in a dropdown list has both and they don't have to be the same.  If you have both values and display names, then the values _will_ show up in the SharePoint list if you publish it properly.  Promoting properties is when you choose which fields from your form should be published into the form library.  You said you added it, but if you did, then it would show up automatically, so I don't think you did. 

    If you want help with this directly, you can go to my blog's contact page to send the template to me via email.


    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 1:09 AM
  • Hi Clayton,

    I cleaned up my form, got rid of the fields that were no longer on the canvas, recreated my drop down list, publised the form and yet the drop down list values still don't show up in the library.

    I only keyed in values, and then the display names defaults to the values field, yet when the form is published and I am promoting that field, after filling out the form, the data still does not get saved to the sharepoint list.  This is very weird.

    I'll send you the template if you don't looking at it please.

    Thanks!
    Hameed
    Friday, June 26, 2009 2:00 PM
  • So, the required field error is no longer an issue, right?  I'll figure out the promoted property.
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 2:25 PM
  • Right. The required field is no longer an issue! :)

    I am but one step away from finishing this form and moving on! :)

    Did you get the template I sent via email? Thanks!
    Friday, June 26, 2009 2:34 PM
  • I've already worked on it and confirmed that it works perfectly.  The Description pulldown shows all the display names, and all the display names are also the values.  When I publish it to my library, the Description shows up in my library just as it should.  I tried 3 different selections and all of them worked.  I'll send you a screenshot back via email in case what you see on my screen is different.  You had it all set up just right, so it should be working, which would indicate an issue with your library maybe.

    By the way, it looks like you are already putting my article to great use for your submit button: Auto-Generating Filenames for InfoPath Forms.  That's really great to see my article doing some good!
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 2:42 PM
  • Wow, I've never seen this, but it appeared that even though it worked well on my system, Hameed was having a conflict with his field that was named "Description."  I don't know exactly what the conflict was, but that was my only guess after much troubleshooting.  After he changed the name to something else and re-published the property, it started working.  There must have been a conflict with the OOTB Description site column or something...
    SharePoint Architect || My Blog
    • Marked as answer by Hameed3 Monday, June 29, 2009 6:54 PM
    Friday, June 26, 2009 8:19 PM
  • Sorry to be bugging, but I have another question for you.
     
    Regarding the form you helped me with.
     
    What is the best way to add another field that will only be populated by an admin to indicate that a change request has been either approved or not?
     
    In other words, when someone is filling out the form for the first time, they won't see the field, however after the admin (someone else) sees the form, acts on it and then either approves the request or not, clicks a radio button and saves the form and now in the view in SharePoint it shows the request as having been completed or not.
     
    What is the best way to accomplish the above?
     
    Thanks!
    Monday, June 29, 2009 5:28 PM
  • Hameed, it's probably a good idea to split each issue into a separate thread.  The reason being is that this could be the 3rd separate issue resolved, but people won't necessarily know that each thing is answered in one thread based on the title.  Consider that so that others can learn from the answers if they are helpful.

    For this, you need to use hidden fields and User Roles.  On rich client forms, user Roles are built-in and very easy to use.  Go to Tools > User Roles and define them accordingly for your admins and/or others.  Then, use conditional formatting on the required controls (fields or sections) to only show to the right people.  For browser-enabled forms, User Roles are not available, so you'll need to use some variation of my idea on my blog: User Roles in Browser-Enabled InfoPath Forms.

    As a favor to me, if you don't mind marking each post as an answer wherever I solved each problem?  I think there were 2 separate ones above that were resolved, and this could be a 3rd.  Thanks!!
    SharePoint Architect || My Blog
    Monday, June 29, 2009 5:46 PM