none
The document could not be opened for editing. A Microsoft SharePoint Foundation compatible application could not be found to edit the document.

    Question

  • When opening a document(both Excel and Word) from a sharepoint library on a particular site, I am receiving the following error.

     "The document could not be opened for editing. A Microsoft SharePoint Foundation compatible application could not be found to edit the document"

    I am opening the document by choosing "Edit document in Excel/Word".

    Thanks in advance for your help.

    Tuesday, September 27, 2011 12:40 PM

Answers

All replies

  • Did you add the SharePoint site to the Trusted Sites zone of the browser?  When a SharePoint server opens an Office document there is code that runs on the server to tell the client to open the document (it's not done just using MIME types like a normal web site).  In later versions of the browser and the OS this requires that the site be listed as Local Intranet or Trusted Sites or it fails.  That's usually what the error you are getting means.
    Tuesday, September 27, 2011 12:57 PM
  • Ben,

    Can you provide a little more information about the library - is it a Trusted File Location for Excel?  Does it use versioning?  Any additional configuration information would be very helpful.

    Thanks!

    Tom

     


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Tuesday, September 27, 2011 1:14 PM
  • Please see this : http://support.microsoft.com/kb/833714

    Error message when you try to edit an Office document in a document library: "'Edit Document' requires a Windows SharePoint Services-compatible application" 

     



    Aryan Nava | Twitter: @cloudtxt | Blog: http://virtualizesharepoint.com
    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Disclaimer: This posting is provided "AS IS" with no warranties.


    Tuesday, September 27, 2011 1:23 PM
  • Hi,

    Are you trying to open it with Firefox

    Documents are associated with a particular application via the DOCICON.XML file.  More information on this file and how it works in http://msdn.microsoft.com/en-us/library/ms463701.aspx. In Internet Explorer the browser has the ActiveX control integrated that allows it to marshal the call to the associated application.

    Firefox does not include this ActiveX control and reports, although not a very good error message, that there is no compatible applications.

     And Another note to be taken

    Their might me multiple reasons for the error you said

    Their is one link which will discuss more about your error and their are other workaround discussed in this thread

    http://support.microsoft.com/kb/979634


    "The Only Way To Get Smarter Is By Playing A Smarter Opponent"
    Tuesday, September 27, 2011 1:29 PM
  • Hello Ravi,

    I know Ben (the person who posted the question) is using a version of IE.

    Ben,

    Can you check which version of IE you are using and check the trusted iste settings?

    Also, has this always been a problem or did the problem just beging occurring?

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Tuesday, September 27, 2011 1:50 PM
  • Hey Ben,

    Can you go to the document library's settings, advanced settings and check the settings for Opening Documents in the Browser?  Try the three differant settings there and then retest after each change.

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Tuesday, September 27, 2011 2:27 PM
  • Hi Tom,

    I have posted another link also which is showing some other reasons also associated with your problem .

    Can you go thru that also

    IE problem is just a thought and other reasons may also be important

    Go thru it :)


    "The Only Way To Get Smarter Is By Playing A Smarter Opponent"
    Wednesday, September 28, 2011 5:19 AM
  • Hey Ravi,

    Those are both good links but I don't believe they address this issue.

    Hey Ben,

    Are there other errors that occur when you try to use additional ECB Menu functionality like check in / check out, edit properties, delete, etc?

    Thanks!

    Tom

     


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    • Edited by Tom Molskow Wednesday, September 28, 2011 2:23 PM
    Wednesday, September 28, 2011 2:22 PM
  • Hi Tom,

    I tested each of the settings for opening documents in the browser and received the same message for each of them.

    Thanks,

    Ben

    Wednesday, September 28, 2011 3:27 PM
  • Hey Ben,

    Has this been an issue before / just after or long after migration?

    Tom

     


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Wednesday, September 28, 2011 4:41 PM
  • Tom,

    This was not an issue prior to the migration to 2010. This is a library that is used very infrequently so it was not noticed untill a few months after we completed our migration. My guess is that it is a result of the migration to 2010.

    Thanks,

    Ben

    Friday, September 30, 2011 1:20 PM
  • Ben,

    Please try this - create a new library of the same type with the same metadata, upload a file, and see if the new library functions properly?  If so then the shortest route may be to make the new library the defacto library, upload the reports to the new library, and then finally delete the old library.

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Microsoft Community Contributor 2011 Award - Linked-In - SharePoint Gypsy
    Friday, September 30, 2011 3:39 PM
  • Here are a few things to check:

    - Make sure you are using IE 32 bit. IE 64 bit is not fully compatible with SharePoint

    - If using IE 32 bit, check if "SharePoint OpenDocuments Class" is enabled under Tools -> Manage add-ons

    - Make sure "Open Documents in Client Applications by Default" feature is activated for the site collection

    - Also, try changing "Browser File Handling" of the web application to "Permissive" (unsecure)

    Friday, September 30, 2011 4:08 PM
  • I solved that issue by disable compatibility view in the IE
    Thursday, February 20, 2014 5:07 PM