none
Powershell command for retracting a farm solution

    Question

  • Hello all,

    I'm trying to retract a farm solution through powershell.  I'm using the command:

    uninstall-spsolution -identity casemanagementdeployment.wsp  -webapplication http://myServer 

    I get the error "This solution contains no resources scoped for a web application and cannot be retracted from a particular web application."  The features contained in this solution are "site" scoped.  I've googled looking for the right parameter but haven't found much.  I saw something from CodePlex, but for this solution I can't use this for our project.  Anybody have any suggestions?  Thanks, Shaun

    Friday, June 22, 2012 5:36 PM

Answers

  • Can you try

    UnInstall-SPSolution -Identity casemanagementdeployment.wsp

    skip the -webapplication url param


    Thanks
    Akhilesh Nirapure

    Friday, June 22, 2012 6:16 PM
  • Your solution probably does not have any resources that can be installed only for a specific web application such as safe control entries etc. Try to remove the -webapplication parameter and run the command. It will uninstall the solution globally.

    NLV - MCTS - Blog - Twitter - In

    • Marked as answer by Shaun Cline Friday, June 22, 2012 6:49 PM
    Friday, June 22, 2012 6:17 PM

All replies

  • Can you try

    UnInstall-SPSolution -Identity casemanagementdeployment.wsp

    skip the -webapplication url param


    Thanks
    Akhilesh Nirapure

    Friday, June 22, 2012 6:16 PM
  • Your solution probably does not have any resources that can be installed only for a specific web application such as safe control entries etc. Try to remove the -webapplication parameter and run the command. It will uninstall the solution globally.

    NLV - MCTS - Blog - Twitter - In

    • Marked as answer by Shaun Cline Friday, June 22, 2012 6:49 PM
    Friday, June 22, 2012 6:17 PM
  • Thanks for your reploy Akhilesh.  That worked.  That's the one thing I didn't try.  Take care, Shaun.
    Friday, June 22, 2012 6:49 PM
  • Thank you for your response NLV, that was the solution.  Take care, Shaun
    Friday, June 22, 2012 6:49 PM