none
Error exporting the list named "Announcements" at the URL: Lists/Announcements

    Question

  • Hi all,

    I am unable to save a site as a template, and getting the following error:

    Error
    Error exporting the list named "Answer Comments" at the URL: Lists/Answer Comments
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 37811ee1-c53e-44ed-87dd-fb450d41452e
    Date and Time: 5/30/2011 3:05:01 A

    I don't think it's particular to the list, it's just the first alphabetical list it comes to, as the erro rwas being seen for the Announcements list.

    The site was created from a previous template based on the STS definition.

    At the moment I do not have access to the ULS logs to research further but wondered if anybody had seen this before?

    Regards,

    Ben


    Ben Weeks
    SharePoint Consultant @ Webtechy Ltd
    T: +441223922070 F: +448701315220
    Web: http://www.webtechy.co.uk Blog: http://blog.webtechy.co.uk
    Monday, May 30, 2011 1:10 AM

All replies

  • OK, SP logs give:

    05/30/2011 03:04:51.02     w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             g220    Unexpected    No windows identity for domain\weeks.    37811ee1-c53e-44ed-87dd-fb450d41452e
    05/30/2011 03:04:51.25     w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             bz7l    Medium      SPSecurityContext.WindowsIdentity: Could not retrieve a valid windows identity for NTName='domain\weeks', UPN='weeks@domain.net'. UPN is required when Kerberos constrained delegation is used. Exception: System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/s4u/022694f3-9fbd-422b-b4b2-312e25dae2a2 that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.IO.PipeException: The pipe endpoint 'net.pipe://localhost/s4u/022694f3-9fbd-422b-b4b2-312e25dae2a2' could not be found on your local machine.      --- End of inner exception stack trace ---    Server stack trace:      at System.ServiceModel.Channels.PipeConnectionInitiator.GetPipeName(Uri uri)     ...    37811ee1-c53e-44ed-87dd-fb450d41452e
    05/30/2011 03:04:51.25*    w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             bz7l    Medium      ...at System.ServiceModel.Channels.NamedPipeConnectionPoolRegistry.NamedPipeConnectionPool.GetPoolKey(EndpointAddress address, Uri via)     at System.ServiceModel.Channels.CommunicationPool`2.TakeConnection(EndpointAddress address, Uri via, TimeSpan timeout, TKey& key)     at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)     at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)     at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager...    37811ee1-c53e-44ed-87dd-fb450d41452e
    05/30/2011 03:04:51.25*    w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             bz7l    Medium      ... cascade)     at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)     at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)    Exception rethrown at [0]:      at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)     at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)     at Microsoft.IdentityModel.WindowsTokenService.S4UClient.IS4UService_dup.UpnLogon(String up...    37811ee1-c53e-44ed-87dd-fb450d41452e
    05/30/2011 03:04:51.25*    w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             bz7l    Medium      ...n, Int32 pid)     at Microsoft.IdentityModel.WindowsTokenService.S4UClient.<>c__DisplayClass1.<UpnLogon>b__0(IS4UService_dup channel)     at Microsoft.IdentityModel.WindowsTokenService.S4UClient.CallService(Func`2 contractOperation)     at Microsoft.SharePoint.SPSecurityContext.GetWindowsIdentity().    37811ee1-c53e-44ed-87dd-fb450d41452e
    05/30/2011 03:04:51.25     w3wp.exe (0x12F4)                           0x0220    SharePoint Foundation             Claims Authentication             g220    Unexpected    No windows identity for domain\weeks.    37811ee1-c53e-44ed-87dd-fb450d41452e

    However, domain\weeks does exist (but you have to login using the username in the format as weeks@domain.net). We are using claims based authentication.

    Regards,

    Ben


    Ben Weeks
    SharePoint Consultant @ Webtechy Ltd
    T: +441223922070 F: +448701315220
    Web: http://www.webtechy.co.uk Blog: http://blog.webtechy.co.uk
    Monday, May 30, 2011 11:31 AM
  • Also see:

    http://social.technet.microsoft.com/Forums/en-IE/sharepoint2010setup/thread/9e822618-06af-4bb3-9f4f-9f1df4762b4b


    Ben Weeks
    SharePoint Consultant @ Webtechy Ltd
    T: +441223922070 F: +448701315220
    Web: http://www.webtechy.co.uk Blog: http://blog.webtechy.co.uk
    Monday, May 30, 2011 11:34 AM
  • Hi Webtechy,

    Workaround 1: Run a few cmdlets to delete the list once and for all.

    $site = get-spsite http://mysiteurl
    $web = $site.rootweb
    $list = $web.lists["Answer Comments"]
    $list.delete()
    $web.dispose()
    $site.dispose()

    Refer Links:

    http://jrjlee.blogspot.com/2011_03_01_archive.html

    http://visualstudiofeeds.com/index.php?option=com_content&view=article&id=3141:Can't%20save%20SharePoint%202010%20site%20as%20template%20with%20a%20library%20called%20Forms&catid=197:johnliunet-blog&Itemid=54&layout=default&month=3&year=2011


    Workaround 2:

    "Error exporting the list named "Announcements" at the URL: Lists/Announcements

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 005bc8f0-4a64-415f-b3b0-e38cda39342e

    Date and Time: 11/02/2011 17:52:08


     Goto "Sharepoint 2010 Management Shell" console and run the following command to get the detail error :
     Get-SPLogEvent -StartTime "2/11/2011 17:52" -EndTime "2/11/2011 17:53" |Where-Object {$_.correlation -like "*4a64-415f*"} | format-list
     
    Notes:
         1) replace "*4a64-415f*" with your real error correlation string
         2) replace starttime and endtime with yours.

    Refer Link:

    http://social.technet.microsoft.com/Forums/en-IN/sharepoint2010setup/thread/6abe36f9-562d-43c1-b4df-d4527ea93373

     

    Hope it helps.


    Tuesday, May 31, 2011 6:25 AM
  • Hi Prakash,

    If I delete the list it complains about it just fails at the next (runs through alphabetically it looks like).

    The issue is (or starts from):

    SPSecurityContext.WindowsIdentity: Could not retrieve a valid windows identity for NTName='domain\weeks'

    This identity does exist and I use it to login to the site. The issue is presumably that there are remnants of identities in the site that are using classic based authentication (perhaps as the template originally came from dev which is classic windows auth), rather than claims based authentication. The resolution (as noted on TechNet and other forums) is to run the MigrateUsers method on this web application to ensure all users and permissions are set to the claims based authentication. The method is outlined here:

    http://technet.microsoft.com/en-us/library/gg144572.aspx


    Specifically, we did the following (using the farm account and added this account as a site collection admin):

    # Verify that you meet the following minimum requirements: See Add-SPShellAdmin.
    # On the Start menu, click All Programs.
    # Click Microsoft SharePoint 2010 Products.
    # Click SharePoint 2010 Management Shell.
    # From the Windows PowerShell command prompt, type the following:

    $w = Get-SPWebApplication "https://www.somedomain.com/"
    $w.MigrateUsers($True)

    For more information on the MigrateUsers method, please see:

    http://msdn.microsoft.com/en-us/library/ee554321.aspx

    However, this did not resolve the issue, so we then ran:

    $w = Get-SPWebApplication "https://www.somedomain.com/"
    $w.UseClaimsAuthentication = 1
    $w.Update()
    $w.ProvisionGlobally()

    Unfortunately this did not resolve this either.

    I have found out that the Claims to Windows Token Service is not currently running which may be the issue - looking into this at the moment. This may be required for the script above.

    The replicate the error, I do:

    1. Navigate to the solution gallery, and ensure only one solution is activated with the text "Custom Site" contained in the Name. Make a note of this name.
    2. Go to the root home page (https://www.somedomain.com/sites/here) as a site owner or site collection administrator.
    3. Using the custom "Create Custom Site" web part, create a new custom site (Year: 2011, Party: Afghanistan, Review Name: Delete Me). This creates a new site using the first template it finds with the Name containing "Custom Site" (i.e. the template noted in step 1).**
    4. There may be a time out issue, wait 30 seconds, then go to https://www.somedomain.com/sites/here (i.e. click return in browser rather than refreshing page).
    5. Your newly created custom site should appear in the custom "My Sites" web part. Click on "2010 AFG Delete Me" to go to it.
    6. Within the "2010 AFG Delete Me" site, go to Site Actions > Site Settings > "save site as template".
    7. Enter a file name of "Custom Site Delete Me" and a template name of "Custom Site Delete Me". Tick "Include Content" and press OK. The template should now appear in the solution gallery.
    8. Navigate to the solution gallery, and deactivate the name we noted in step 1 and deactivate and delete the template we created in the previous step.
    Navigate back to "2010 AFG Delete Me" site and go to Site Actions > Site Settings > "save site as template".
    9. Enter a file name of "Custom Site Delete Me 2" and a template name of "Custom Site Delete Me". Tick "Include Content" and press OK. The template should now appear in the solution gallery.
    10. You should now get "Error exporting the list named "Announcements" at the URL: Lists/Announcements". NB Reactivating this original site template that was used does not fix the issue, it leaves the site in an orphaned state!

    ** I shall run through the steps above using a regular method to create a SP site to ensure to rule out that it is not something specific to the Create custom site web part but do not think this is the issue, as it's basically doing:

    // Create the custom site if it doesn't already exist.
    customWeb = partyWeb.Webs.Add(webURL, webTitle, webDescription, 1033, webTemplate, false, false);

    NB The "Custom Site" is taken from our development environment where claims based authentication is not used (just classic windows authentication).

    Any help much appreciated.

    Regards,

    Ben


    Ben Weeks
    SharePoint Consultant @ Webtechy Ltd
    T: +441223922070 F: +448701315220
    Web: http://www.webtechy.co.uk Blog: http://blog.webtechy.co.uk
    Tuesday, May 31, 2011 1:42 PM
  • NB there is a particular list within this site, which when I try and save as a template I get (when including content):

    Error
    Read error on file "_catalogs/lt/Findings v2_1.stp".
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 3209d272-86ca-4de4-8bfd-08563f496e4a
    Date and Time: 5/31/2011 6:02:29 PM

    All other lists seem to save as a template OK.


    Ben Weeks
    SharePoint Consultant @ Webtechy Ltd
    T: +441223922070 F: +448701315220
    Web: http://www.webtechy.co.uk Blog: http://blog.webtechy.co.uk
    Tuesday, May 31, 2011 4:03 PM