none
How to disable Target Audience

    Question

  • We have Publishing feature enabled at site collection level.

    On Pages library I need to diable target audience but the option to uncheck it is greyed out.

    Library settings-> audience tragetting setting-> enable audience targetting.


    Prachi

    Monday, July 08, 2013 10:32 PM

Answers

  • Are all elements involved in the scenario saved, checked in and published? Hiding a column should not result in a "File not found". This has a different reason. Check page layouts, CSS files, scripts, etc and make sure everything is checked in and at a major version.

    cheers, teylyn
    www.teylyn.com

    • Marked as answer by Prachi taunk Tuesday, July 09, 2013 4:50 PM
    Tuesday, July 09, 2013 3:25 AM

All replies

  • Do you have administrative right like Site Collection Administrator or Farm Administrator?

    Amar Deep Singh

    Monday, July 08, 2013 11:37 PM
  • Yes. I have farm admin and site collection admin rights.


    Prachi

    Monday, July 08, 2013 11:38 PM
  • Hello,

    when you enable Audience targeting by checking that box, the column "Target Audiences" will be added to the Library. The box is then grayed out and cannot be unchecked. 

    To disable audience targeting, edit the column "Target Audiences" and set it to "Hidden" so it does not appear on the form anymore. This column is a so-called "persistent" column, which cannot be deleted from the content type through the GUI.

    See http://blog.metrostarsystems.com/2011/05/11/persistent-sharepoint-2010-site-columns/

    You can delete the column with a Powershell script, like

    $web = Get-SPWeb (Your site URL)
    $list = $web.Lists[(Your List Name)]
    $field = $list.Fields[(Your Column Name)]
    $field.AllowDeletion = “true”
    $field.Sealed = “false”
    $field.Delete()
    $list.Update()
    $web.Dispose()

    Source: http://sharepointinsimple.blogspot.co.nz/2012/05/i-cannot-delete-this-column-from-my.html


    cheers, teylyn
    www.teylyn.com




    Monday, July 08, 2013 11:41 PM
  • I followed the steps.

    I set target audience column to hidden for three content types set for Pages library:

    Pages, Artilcle pages,  welcome pages.

    Still we get error File not found when a user tries to access the page.


    Prachi

    Monday, July 08, 2013 11:56 PM
  • Are all elements involved in the scenario saved, checked in and published? Hiding a column should not result in a "File not found". This has a different reason. Check page layouts, CSS files, scripts, etc and make sure everything is checked in and at a major version.

    cheers, teylyn
    www.teylyn.com

    • Marked as answer by Prachi taunk Tuesday, July 09, 2013 4:50 PM
    Tuesday, July 09, 2013 3:25 AM
  • Thanks.

    I checked all the resources. Everything seems to be checked in and at major version.

    Is there a script to check it in case I m ight have missed something.

    Also I noticed that one user who is able to see the page has some limited access given directly and also the target audience is still enabled on page library.


    Prachi

    Tuesday, July 09, 2013 3:33 PM
  • Thanks for the pointer.

    I was looking at wrong error.

    we found that one of the master page was checked out to a user and so was inaccessible by others.


    Prachi

    Tuesday, July 09, 2013 4:50 PM