none
Directory Listing Denied

    Question

  • Hi,

     

    After uninstalling and re-installing NET 2.0 (sp1) and 1.1 both Sharepoint 3.0 Central Administration and a sharepoint site show directory listing denied errors.

     

    Surfing to http://site/ result in Directory Listing Denied (403) error. However, if I type the whole path http://site/default.aspx both central administration and the site is shown correctly.

     

    After scanning google, I've seen several suggestions. Checking application pools (both central administration and the site have their own application pool owned by Network Service). Checking so execute permissions is script only and not executable (I've tried them all and on all subdirectories). Documents settings in IIS is default.aspx (don't think sharepoint listen to that though). They all fail. The problem is persistant.

     

    I would really like to hear some suggestions how to fix this problem.
    Friday, April 25, 2008 1:38 PM

All replies

  • This is a weird error. So you're saying the site functions normally, with the sole exception of the URL routing? That's difficult to believe.

    First I need to ask: did you create a new IIS Web Site/SharePoint web application when you installed SharePoint? Or did you instead upgrade an existing IIS web site? If in doubt, create new.

    Also, is your Central Admin app pool different from your content app pool? If not, make a new App Pool (not yourself; have SharePoint do it for you) and see if that works. If not, we can tackle this problem from different angles.
    Monday, April 28, 2008 4:16 PM
  • Thanks for the reply Smile

     

     pseale wrote:
    This is a weird error. So you're saying the site functions normally, with the sole exception of the URL routing? That's difficult to believe.

     

    Unfortunately it is true. Besides URL routing it is perfectly possible to browse through the sharepoint site, however we have discovered that any document that has been uploaded before and after to the content database is "lost". Whenever we try to browse to such a document (.doc, .gif, .txt...any kind of file uploaded to the sharepoint site, we are faced with a 404 Page Not Found).

     

    We can edit apperance, texts and do everything else. Just not access files uploaded to the site.

     


    First I need to ask: did you create a new IIS Web Site/SharePoint web application when you installed SharePoint? Or did you instead upgrade an existing IIS web site? If in doubt, create new.

     

    I believe it was the former not the latter. The application pool was created in the sharepoint interface.  Just to clarify again, the site worked perfectly until we uninstalled and installed .NET 1.1/2.0. Something broke when we did that. Just need to figure out what broke and how to fix it.

     


    Also, is your Central Admin app pool different from your content app pool? If not, make a new App Pool (not yourself; have SharePoint do it for you) and see if that works. If not, we can tackle this problem from different angles.

     

    Yes, Central administration has it's own application pool and content database (default settings).

     

    Again, I appreciate your answer and hope we can get more response Smile

     

    Tuesday, April 29, 2008 8:40 AM
  • could it be that sharepoint fails to recognize the new .NET 2.0 installation (we don't see any errors that specifically point to such a problem but it's gotta be related to the framework somehow since the error appeared after we reinstalled it).

     

    Maybe a "stsadm -o upgrade -inplace -url www.site.com" can fix the error 403/404 problems? Or will we just mess it up even more?

    Tuesday, April 29, 2008 12:03 PM
  • I didn't notice the ".NET 2.0 reinstallation" step. Have you already run aspnet_regiis -i under the v2 Framework directory?

     

    Other than running that command, I'm pretty much stumped. You may have to 1) save your content databases (for the sites you want to keep, not all of them) , 2) completely uninstall SharePoint, 3) reinstall SharePoint, 4) attach your existing content databases via the web interface or via stsadm -o addcontentdb.

     

    ...but yes, stumped. -Peter

    Tuesday, April 29, 2008 2:03 PM
  • Yes, Did it again just to be sure.

     

    Code Snippet

    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -u
    Start uninstalling ASP.NET (2.0.50727).
    ................................
    Finished uninstalling ASP.NET (2.0.50727).

     

    %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
    Start installing ASP.NET (2.0.50727).
    ...................................................
    Finished installing ASP.NET (2.0.50727).

     

    iisreset
    Attempting stop...
    Internet services successfully stopped
    Attempting start...
    Internet services successfully restarted

     

     

    http://www.mysite.com/it/Shared%20document/Forms/AllItems.aspx <- Works just fine
    http://www.mysite.com/it/Shared%20document/Infrastrukture.ppt <- Shows error 404 Page Not Found

    I was hoping I would have to resort to such a drastic measure of reinstalling the sharepoint just because .NET was reinstalled. Any other ideas?
    Tuesday, April 29, 2008 2:21 PM
  •  

    I now know how to replicate this problem.

     

    Uninstalling .NET 1.1 will cause this error.

     

    If you only uninstall .NET 2.0 and 3.0 you can just reinstall the frameworks and make sure to set each site in the IIS back to .NET 2.0 settings and it all works again. However, if you also removed .NET 1.1 you can not do this and will recieve Error 403 on each frontpage and Error 404 on all objects saved in the database.

     

    Question is: How do I repair the sharepoint if that happened?

    Friday, May 02, 2008 8:53 AM
  • Hello,

    Did you mange get this fixed? I'm having same problem.

    Br,
    Jouni
    Wednesday, April 08, 2009 1:10 PM
  • I encountered the exact same problem and solved it through a walk-around. 

    Open Sharepoint Central Administration --> Application Management --> Create or Extend Web Application. Choose to extend an existing web application (Sharepoint - 80), here you can create a new website that is an exact copy of the original (except that it works). Put it on port 8008 (just temporary).  Then it is just to change the port back to 80 in IIS manager!

    I guess you already have solved the problem, but hopefullt someone else will have use of it.


    Jonas
    Tuesday, April 14, 2009 1:51 PM
  • Tuesday, June 23, 2009 9:03 PM
  • thanks this helped me!
    Tuesday, September 14, 2010 7:10 PM
  • Hello All,  I hope this helps.

    I found a work-around to this problem.

    1. Create an empty site on another port using sharepoint admin.

    2. stsadm -o backup -url oldside

    3. stsadm -o restore -url newsite

    4. test that the new site is now old site.

    5. Stop old site in IIS

    6. Change new site to operate on same hostname/port as old site.

    That should be it.  GL.

     

    GM

    Sunday, November 14, 2010 5:47 PM
  • I'm actually having this same issue, but this link no longer works

    https://www.hensongroup.com/blogs/archive/2009/05/11/moss-2007-403-forbidden-error-after-net-framework-updates-fail-to-install.aspx

    I gather from this other post

    https://www.hensongroup.com/blogs/archive/2009/05/11/moss-2007-403-forbidden-error-after-net-framework-updates-fail-to-install.aspx

    That this has something to do with KB973917 , but I'm not sure of any other details.

    By any chance does anyone recall what the actual solution to this problem was?

    Thank you.

    Tuesday, September 04, 2012 11:39 PM