none
Edit a Microsoft InfoPath Form in SharePoint Datasheet view

    Question

  • Hello- I created a form in Microsoft InfoPath 2003 then published the form in Microsoft SharePoint 2007. I then populated the form with test data and submitted it. I would like to know if the "Edit in Datasheet" under Actions will allow me to edit a submitted Microsoft InfoPath form in SharePoint.  I have administrative rights to the SharePoint site however when I review my sample submission in datasheet view, it indicates in the right corner, "Read Only. Am I doing something wrong or is there no capability to "Edit in Datasheet" for 2003 InfoPath forms?  I have used both SharePoint and InfoPath for a few years but am no expert by any means.  Is there a simple solution to this question?  Will progamming be involved?  If so, is there a link available to walk me through the process.  The key is that individuals must be able to edit their submitted form using a datasheet view.  If the end user makes any changes within the datasheet view, those changes should also update the original form that was populated.
    Tuesday, January 05, 2010 10:50 PM

Answers

  • Are you sure it's not in the InfoPath publishing wizard at the point when you promote your fields?  You have to check the box individually for each field.  So, if you've already promoted all your fields, you'll need to go publish it again, but when you get to the property promotion menu, double-click all promoted fields and check the box at the bottom.  It's an InfoPath setting that will affect how they work in SharePoint.
    SharePoint Architect || My Blog
    Wednesday, January 06, 2010 7:07 AM

All replies

  • You can't edit the form, but you can edit the data promoted to the form library _IF_ you check the box during publishing for each field that says "allow for editing in SharePoint."  Once you do this, then the fields are editable in SharePoint, which allows you to do it in datasheet view.  To do this also requires that Content Approval is not enabled.  After editing the field in SharePoint, it will also update the field's value in the form XML.
    SharePoint Architect || My Blog
    Tuesday, January 05, 2010 11:29 PM
  • It actually is SharePoint 3.0 (not SharePoint 2007 as I mistakenly indicated initially-  Sorry about that).  I do not see the option of selecting "allow for editing in SharePoint" during the publishing wizard process.  Is this not an option on this SharePoint version.  If not, what other options are out there for this type of situation.  Thanks
    Wednesday, January 06, 2010 6:39 AM
  • Are you sure it's not in the InfoPath publishing wizard at the point when you promote your fields?  You have to check the box individually for each field.  So, if you've already promoted all your fields, you'll need to go publish it again, but when you get to the property promotion menu, double-click all promoted fields and check the box at the bottom.  It's an InfoPath setting that will affect how they work in SharePoint.
    SharePoint Architect || My Blog
    Wednesday, January 06, 2010 7:07 AM
  • Thanks for you response.  Unfortunately I am not seeing any area in SharePoint version that allows me to check a box on the Propery Promotion menu.  Here is what I am seeing and doing:

    1. Open InfoPath form and go into design view
    2. Select "File" from top menu and and click "Publish". 
    3. The InfoPath Form Wizard opens.  Select Next to start Wizard
    4. Select the radio button indicating that the form should be published "To a SharePoint Form Library" and hit then Next
    5. Select the radio button to "Create a new form library (recommended)" and then hit Next
    6. Paste the location of the SharePoint site that I want the form to be published to and hit Next
    7. Type a name and description for this form library and hit Next
    8. On the last step prior to publishing the form it indicates, "You can make form data listed below available as column names on a SharePoint site."  I can then "Add", "Remove" or "Modify" fields so that they appear in the standard/datasheet view of SharePoint.  If I select "Add" a new pop up appears asking that I choose a field to promote as a form library column on a SharePoint site."  The "Modify" button is very similar.  Unfortunately, on this last step or anywhere prior, I do not see an area that specifically asks me to "Promote your fields", nor do I see a check box at the bottom.  I am assuming that either I am doing something wrong or this function became available on later SharePoint versions.

    Any thoughts.  If this functionality appears only in later SharePoint versions, is there a workaround for my version.

    Thanks

    Wednesday, January 06, 2010 6:14 PM
  • Hmm, it may not be possible with InfoPath 2003.  I don't use 2003, so I'm not sure.  Are you only able to use Office 2003?  With SharePoint 2007, it's much better to use Office 2007 as a whole, including InfoPath.
    SharePoint Architect || My Blog
    Wednesday, January 06, 2010 6:54 PM
  • Unfortunately I am at work and we currently are only licensed/set up for 2003.  Sounds like I am out of luck with any ability to edit these fields in a datasheet view.  If you happen to run across anything please let me know.

    Thanks for responding!
    Friday, January 08, 2010 9:07 PM
  • Yeah, it's not the best idea to pay all the money for SharePoint 2007 while remaining on Office 2003, so that must be why you're having to use WSS 3.0 - it's free.
    SharePoint Architect || My Blog
    Saturday, January 09, 2010 1:19 AM
  • Will we be able to do this for "Date" Type properties ?

    This checkbox was enabled for text type properties , but disabled for Date type. Is there any work around?

    Thanks

    Wednesday, November 17, 2010 10:17 PM
  • Will we be able to do this for "Date" Type properties ?

    This checkbox was enabled for text type properties , but disabled for Date type. Is there any work around?

    Thanks


    For that, you may need to create the Date column in SharePoint first, add it to your form library, then promote the date field while associating it with this existing date field (This Document Library in the dropdown).  See if that enables the check box.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, November 17, 2010 11:05 PM
  • You mean to say create as site column ?

    ok i followed these steps but the check box didnt get enabled.

    1> Created a Date Column in Sharepoint (As site column).

    2> Added that to the form library

    3> while publishing tried to associate this site column(Date) to the one of the exisiting date field in the form.

    Couldnt see the check box enabled.

    Thursday, November 18, 2010 10:12 PM
  • Don't know what to say...
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, November 19, 2010 4:32 AM
  • Hi I am have the same Issue, except in the InfoPath publishing wizard at the point when you promote your fields the check box individually for each field are greyed out I also dont have Content Approval enabled.

    I have Share point 2007 and infopath 2010.

    any ideas what this could be?

    Monday, December 06, 2010 2:21 PM
  • Hi Clayton - Your suggestions are always helpful. However this time,I have a similiar problem as the ones mentioned above. I've created fields in an infopath 2007 form and published it to a form library in SharePoint 2007. I also created a content type in SharePoint. In infopath I have checked the box to allow users to edit fields in datasheet view. Here are my issues: 1.) When opening the form library in datasheet view I noticed some of the fields are not editable. Mind you some. Some are editable however some aren't allowed this capability although the box was checked in infopath. 2.) When in infopath and publishing the data fields to sharepoint the fields box was disabled to allow the users to edit in datasheet view. Any suggestions although I've followed the same steps for all fields?
    Saturday, December 11, 2010 2:44 AM
  • You need to:

    • change the DataType of the date field in Infopath to "Date and Time" and the date column that you want to publish to in Sharepoint to Date/Time, as well. 
    • Then, when you get to the publishing the field, go to the "Site column group:" and toggle to any other drop down and then go back and select "(This document library)" to get your sharepoint site's columns to populate. 
    • Now find the date column you created in Sharepoint
    • and check "Allow users to edit data in this field by using a datasheet or properties page"
    Monday, April 18, 2011 9:58 PM
  • In the InfoPath form library- in the datasheet view we are not able to blank out data from an editable field/cell. After deleting the value also previous value gets populated again. So for a work around, for the field which need to be empty we are putting a string like 'N/A' or open the infopath form and delete the value and resubmit. Is there any solution to blank out the editable field/cell in the datasheet view only? Any help would be highly appreciated. Thanks in advance!! :)
    Friday, March 23, 2012 11:34 AM