none
Problems with item detail popup with ie7 and ie8

    Question

  • I have a new installation of Sharepoint 2010 beta.  This is straight, out of the box, fresh install, no custom code at all. 

    On several browsers I cannot view several items within sharepoint.  But can view them with other browsers
    When I open the main root site with one of the offending browser I get an error triangle at the bottom left of the browser (details below).  on these browser I am unable to do basic functionality within the sharepoint site:

    • The Page ribbon does not load
    • Cannot view Detail popup for anything in the site.

    These browsers fail:
    XP Desktop - ie7.0.5730.13
    XP Laptop - ie8.0.6001.18702

    These browsers seem to work:
    Windows 7 laptop - ie8.0.7600.16385
    Sharepoint Server - ie8.0.6001.18882

    I've tried to update the XP Laptop.  I've run Windows update several time trying to get all the .net and browser updates I can.  But it's still not working.

    Am to conclude that:
    • I MUST be on windows 7 to use Sharepoint 2010?
    • I must be on a very specific version of ie8?
    is this even a client issue?  or is it more of a server component issue?

    Incidentally, Firefox 3.5 seems to work pretty well.

    Here is the error details I get :

    on the ie7 desktop I get an error message that reads : Char: 70125, Object expected

    Webpage error details on the ie8 laptop.

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 3.0.04506.30; MS-RTC LM 8; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.3)
    Timestamp: Mon, 15 Mar 2010 15:52:33 UTC


    Message: Invalid character
    Line: 1
    Char: 1
    Code: 0
    URI: http://tstsps01/ScriptResource.axd?d=3gtDevuF5hwGxI3DULiHKe4PLpjPC2NBqO_Aln8mJuME3vdMXP1RflDREQe-ARzl4053j1XJPuK_tKVreY7-JEJHhiZGtQfbk53NzX2FfOU1&t=57268015


    Message: Invalid character
    Line: 1
    Char: 1
    Code: 0
    URI: http://tstsps01/ScriptResource.axd?d=3gtDevuF5hwGxI3DULiHKe4PLpjPC2NBqO_Aln8mJuME3vdMXP1RflDREQe-ARzlKTEXQo2eogcWU5q9nETxLMVv7VkxkeZKcJBd3mhGGIQ1&t=57268015


    Message: 'Sys' is undefined
    Line: 213
    Char: 1
    Code: 0
    URI: http://tstsps01/Lists/Tasks/AllItems.aspx


    Message: 'Sys' is undefined
    Line: 1260
    Char: 1
    Code: 0
    URI: http://tstsps01/Lists/Tasks/AllItems.aspx


    Message: 'Type' is undefined
    Line: 3
    Char: 1
    Code: 0
    URI: http://tstsps01/_layouts/navresizer.js?rev=ulprP4hnQ3FxULueDoY8Vw%3D%3D


    Message: 'Type' is undefined
    Line: 2
    Char: 1
    Code: 0
    URI: http://tstsps01/_layouts/sp.core.js?rev=hp5jN4e%2BPTRw7LrRxloaGg%3D%3D


    Message: 'Type' is undefined
    Line: 1
    Char: 1
    Code: 0
    URI: http://tstsps01/_layouts/ScriptResx.ashx?culture=en%2Dus&name=SP%2ERes&rev=CKSAv76LENnzrJqc86tP2g%3D%3D


    Message: Object doesn't support this property or method
    Line: 2
    Char: 132
    Code: 0

    Tuesday, March 16, 2010 2:47 PM

Answers

  • we also experienced the exact same issue and the answer, in our case, was quite simple.  A group policy we use for IE control had not set the following IE settings:

    • HTTP 1.1
    • Use HTTP 1.1. through proxy connections

      We enabled these settings and presto....the problem went away.

      These settings can be configured in the advanced tab of the Internet options if your desktop is not locked down.

      Hope this helps.

    • Proposed as answer by FancyIT Thursday, September 02, 2010 2:28 PM
    • Marked as answer by Randy Drisgill MVPMVP Friday, October 08, 2010 4:35 AM
    Thursday, September 02, 2010 2:27 PM
  • What solved the issue for us was turning off compression for the script resource handler.

     

    Edit the web.config file associated with the SharePoint site:

    Modify the following item in the config file, or add it if it is missing:

    <scriptResourceHandler enableCompression="false" enableCaching="true" />

    Inside this section:
    <system.web.extensions>
          <scripting>
    • Proposed as answer by Jazzy Friday, September 17, 2010 6:52 PM
    • Marked as answer by Randy Drisgill MVPMVP Friday, October 08, 2010 4:35 AM
    Tuesday, August 31, 2010 10:45 PM

All replies

  • Hi there,

    I actually encountered exactly the same problem, same ie versions and all.

    As additional information, I might add that on a Windows2003 with ie8.0.6001.18702 ( same as on XP ) Sharepoint works.
    On the XP station withe the same ie version Sharepoint doesnt work properly.

    Rgds


    Error details:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727)
    Timestamp: Wed, 17 Mar 2010 14:29:20 UTC


    Message: Invalid character
    Line: 1
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/ScriptResource.axd?d=DTOwGhC3pzi3ORyDAMHAdRu7aTRle4DXsGDcH-9wgVMbdK3oh9Y-bT65g4ynCx7AvnmHsBELoXQtmrdBkY2lfkexQ8mwudZTZlj2mfwi_sE1&t=ffffffffec2d9970


    Message: Invalid character
    Line: 1
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/ScriptResource.axd?d=DTOwGhC3pzi3ORyDAMHAdRu7aTRle4DXsGDcH-9wgVMbdK3oh9Y-bT65g4ynCx7AUKnm49y4adf2pVvAttscF9Ienmk80ih9CNxrl7fpAtI1&t=ffffffffec2d9970


    Message: 'Sys' is undefined
    Line: 155
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/_layouts/viewlsts.aspx


    Message: 'Sys' is undefined
    Line: 812
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/_layouts/viewlsts.aspx


    Message: 'Type' is undefined
    Line: 2
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/_layouts/sp.core.js?rev=hp5jN4e%2BPTRw7LrRxloaGg%3D%3D


    Message: 'Type' is undefined
    Line: 1
    Char: 1
    Code: 0
    URI: hxxp://sharepointserver/_layouts/ScriptResx.ashx?culture=en%2Dus&name=SP%2ERes&rev=CKSAv76LENnzrJqc86tP2g%3D%3D


    Message: Object doesn't support this property or method
    Line: 2
    Char: 132
    Code: 0
    URI: hxxp://sharepointserver/_layouts/cui.js?rev=PJr9zZQkRQvKfIvBDGmhRg%3D%3D

     

    Wednesday, March 17, 2010 2:12 PM
  • I am experiencing the same problem on XP SP3 machines running IE 8.0.6001.18702.

    The problem seems to have its source in an IE bug explained at http://stackoverflow.com/questions/835130/ie-8-dropping-memory-pages/ and discussed here as the "IE Missing 4k bug" : http://blogs.msdn.com/ieinternals/archive/2009/07/27/Bugs-in-the-IE8-Lookahead-Downloader.aspx (following the answers on that thread, it's not clear if this bug has a fix or not for IE8 on XP).

    The bug makes it that the references to .axd files (as those contained in the html output of files like \_layout\create.aspx) contain invalid values (ex. WebResource.axd?d=FOh8OJuiMABJnvQTYnAaJQ2-t=633802704069218315), thus preventing IE from loading required ressources, among which .xap files like AddGallery.xap. This explains the "Invalid character" and "Object is undefined" Javascript errors. More detailed explainations are available at  http://stackoverflow.com/questions/461605/invalid-webresource-axd-parameters-being-generated

    We tried to update IE on our XP machines, but we can't get an upper version number than ie8.0.6001.18702.
    We also noticed that the same IE version works on a Windows Server 2003, so I suspect that the IE bug finds its source in some core/.net library used by IE, not IE code itself, since the bug seems to dependent on the OS version on which IE is installed.  

    If anyone knows a fix or workaround for this one, I would be glad to hear about it, since this bug is preventing us from using SharePoint 2010 on our XP machines.  

    Wednesday, March 17, 2010 2:48 PM
  • I guess that this problem has to do with your OS version, XP just isn't supported, also the 64 bit edition is not supported.... For a complete list of hardware and software requirements please take a look here
    Tuesday, March 30, 2010 12:06 PM
  • The IE "missing 4K" bug has been corrected, as announced on Eric Lawrence's "IE Internals" blog :

    http://blogs.msdn.com/ieinternals/archive/2010/04/01/IE8-Lookahead-Downloader-Fixed.aspx

    PS. I wrongly proposed the above post from SP1ffy as an answer. All my appologies for the confusion.

    • Proposed as answer by Paul Gaunard Thursday, April 01, 2010 6:32 PM
    Thursday, April 01, 2010 6:32 PM
  • I am getting this issue as well on IE 8, Win 7 64 bit with SP 2010.  Everything is fully patched so it has nothing to do with XP.

     

    It is a shame when it works better in Firefox than MS IE8.

    Tuesday, May 18, 2010 11:33 PM
  • I'm experiencing the same issue with Windows 7 64 bit and IE 8.  Is there a fix for this issue?

    Monday, August 09, 2010 7:20 PM
  • What solved the issue for us was turning off compression for the script resource handler.

     

    Edit the web.config file associated with the SharePoint site:

    Modify the following item in the config file, or add it if it is missing:

    <scriptResourceHandler enableCompression="false" enableCaching="true" />

    Inside this section:
    <system.web.extensions>
          <scripting>
    • Proposed as answer by Jazzy Friday, September 17, 2010 6:52 PM
    • Marked as answer by Randy Drisgill MVPMVP Friday, October 08, 2010 4:35 AM
    Tuesday, August 31, 2010 10:45 PM
  • we also experienced the exact same issue and the answer, in our case, was quite simple.  A group policy we use for IE control had not set the following IE settings:

    • HTTP 1.1
    • Use HTTP 1.1. through proxy connections

      We enabled these settings and presto....the problem went away.

      These settings can be configured in the advanced tab of the Internet options if your desktop is not locked down.

      Hope this helps.

    • Proposed as answer by FancyIT Thursday, September 02, 2010 2:28 PM
    • Marked as answer by Randy Drisgill MVPMVP Friday, October 08, 2010 4:35 AM
    Thursday, September 02, 2010 2:27 PM
  • Michaelhe's solution is good. Well done.

    Enabling Http1.1 does not solve the problem if using host headers, and I like to disable Http1.1, so I can see the received text content in Fiddler or similar tool.

    Friday, September 24, 2010 1:22 AM
  • This solves the problem for sharepoint 2010 allright, but not for sharepoint foundation. I experience the same problem using only the sharepoint foundation 2010.

     

    Any clues on this?

    Monday, January 10, 2011 11:22 AM
  • I am just learning SharePoint 2010.  I am using WindowsXP SP3 operating system.  I cannot open the ribbon to make edits when the site in opened in IE8.  I updated IE8 & downloaded Silverlight and I am still experiencing the same issue.  The ribbon tries to open but instead, there is a spinning semi-circular arrow.

    When I access the SharePoint development site in Firefox 4, everything works just fine.

    My supervisor is using Windows7 and IE9.  Everything opens fine for him.

    Monday, June 27, 2011 6:10 PM
  • michaelhe, thanks a million for that gem.  Five hours of browsing later and this little chunk in my web.config and all my IE8 ScriptResource.axd "invalid character" problems have disappeared...

     <system.web.extensions>
     <scripting>
      <scriptResourceHandler enableCompression="false" enableCaching="true"/>
     </scripting>
    </system.web.extensions> 

    Friday, August 19, 2011 1:30 PM
  • We just recently upgraded our SP 2007 intranet to SP 2010.  We experienced many javascript errors on several IE7 clients and tried several things.  We thought it was user profile specific because changing some of the advanced settings in IE (active scripting, allow active content from My Computer) seemed to resolve the problem temporarily, but wasn't a final solution.

    Our Windows 7 IE8 machines seemed to work ok, but the issues seemed to be inconsistent on Windows XP machines.  We were getting weird javascript messages like 'Type is undefined',  Object doesn't support this property or method, 'Sys' is undefined.  Finally, we were able to replicate the problems on many machines that were Windows XP SP3 with IE7.  The above web.config change to disable compression fixed all of our issues.

    THANK YOU, THANK YOU!

    Monday, December 19, 2011 7:23 PM
  • I'm having this problem with Sharepoint 2007 and can't find
    <system.web.extensions>
    <scripting>
    in the web.config, anybody fix this problem for SP 2007?
    Wednesday, January 18, 2012 2:35 PM
  • Found my solution, my _layouts folder was set to the wrong version of asp.net!
    Thursday, January 26, 2012 12:25 PM