none
Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\fc80c46c-0fcf-44d7-ad9a-bf75d2f3305b\cache.ini' is denied.

    Question

  • Hi,

    I am creating and deleting an timer job definition at site collection feature. Its throws this error :

    Access to the path 'C:\ProgramData\Microsoft\SharePoint\Config\fc80c46c-0fcf-44d7-ad9a-bf75d2f3305b\cache.ini' is denied.

    I have tried running this code with RunWithElevelatedPrivalges. Still same error.

     

    Thanks in advance

    Monday, August 02, 2010 1:29 PM

All replies

  • Hi

    try giving full control to the WSS_WPG user on the folder where the cache.ini file is searched.

    Regards

    Sujasree

    Tuesday, August 03, 2010 12:07 AM
  • Hi Sujasree,

    I don't want to give the permission to that folder because its a hidden folder. Can't instruct same to the client.

    Tuesday, August 03, 2010 4:42 AM
  • so, did anyone find de answer?

    having the same problem here...

    Tuesday, August 17, 2010 1:54 PM
  • instead of running with elevated priveleges, why not impersonate as the farm administator, surely that user has access to write to the cache

    although why is it erring on the cache settings anyways

    this looks like a problem with the farm configuration

    what does the timer job do, what is the schedule frequency, and how are you delting it?
    What server is giving you the error? WFE, AppServer, Indexer?
    Is it possible the timer job wasn't deployed successfully on all these servers?

     


    Brian Bedard, MCTS - pioneeringsharepoint.blogspot.com - Twitter:@tigertoy

    Tuesday, August 17, 2010 2:26 PM