locked
Why is a favicon not showing up in Internet Explorer but is in Firefox/Google Chrome?

    Question

  • Hi,

    I am trying to add a custom favicon.ico to my SharePoint 2007 sites, and it is working in Firefox and Google Chrome but not IE 7,8 or 9. I have cleared the cache, deleted browing history, restarted, removed and re-added to my favourites and it is still the default icon. I can see on teh Ferrari website that it has worked for them (there website is built on SharePoint). But it is not working with my methods, I have added the .ico file to SharePoint images directory itself, added it to the web server and referenced in the .masterpage and this works for all other browsers except IE.

    What is it that I need to do in IE, in order for this to show? It is not working on any client machine which makes me think that some kind of force refresh is needed.

    Many thanks,

    Laura


    Laura Blackmore
    • Edited by Mike Walsh FIN Wednesday, June 15, 2011 6:50 AM Title made impersonal
    Tuesday, June 14, 2011 2:52 PM

Answers

  • I use the following code in the <head> section of the my custom master page, directly below the meta content information:

     <link rel="SHORTCUT ICON" href="/PublishingImages/layout/favicon.ico" type="image/x-icon" /> 

    It seems to work okay in IE. I think having the type="image/x-icon" is the key?

    You may need to clear your cache initially, but I haven't had this problem - I close the tab, open a new tabl and go to the site & it works great. I intially tried type="image/ico" and that didn't work for IE, only FireFox.

    Hope that helps!

    • Marked as answer by Peng Lei Tuesday, June 21, 2011 7:40 AM
    Thursday, June 16, 2011 10:35 PM

All replies

  • its working for me

    <head><link rel='SHORTCUT ICON' href='favicon.ico'/>

    Wednesday, June 15, 2011 7:44 AM
  • Hi,

    I have tried it again but it still isn't working. Where did you save the file?

    Thanks,


    Laura Blackmore
    • Edited by Mike Walsh FIN Wednesday, June 15, 2011 12:27 PM no longer needed (refered to deleted post) section removed
    Wednesday, June 15, 2011 12:25 PM
  • Hi Laura,

    This should be the code for favicon,

    <HEAD>

    <LINK REL="SHORTCUT ICON" HREF="http://URL/icon.ico">

    </HEAD>

    Make sure .ico file is accessible with URL.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, June 16, 2011 1:19 AM
  • Try this <link rel="shortcut icon" href="/favicon.ico?"> add the ? after the .ico
    Heather Waterman SharePoint Desginer www.heatherwaterman.com
    Thursday, June 16, 2011 12:12 PM
  • Hi,

    Thank you for your replies. I have tried both of these methods to no avail. Before this, I managed to get it to work on one web app but not another which to me suggests that there is a setting I have missed in the new web apps.

    Apart from creating the .ico file with an icon editor, adding the image to the root directory, ensuring that it has the correct permissions and adding this link rel to the master page, and then clearing browser history/ cache. Is there anything else that I should be doing as the favicon is showing in Firefox and Google still?

    All settings for both web apps seem to be exactly the same, so I am not sure where I am going wrong!

    Many thanks,

    Laura


    Laura Blackmore
    Thursday, June 16, 2011 12:25 PM
  • Does it work well on IE6? :) 

    On IE7/8/9, did you try clicking the Compatibility View button next to URL?


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 16, 2011 12:53 PM
  • Could you check Java Script error? In Internet Explorer's default setting, a small warning icon appears in the status bar.

    May be the error stops rendering.

     

    Moderator Note: Your other post (7 mins before this one) was deleted as off-topic as it was about SP 2010.


    Senior Software Developer - Virtosoftware - Premium Web Parts for Microsoft SharePoint 2007 & 2010
    • Edited by Mike Walsh FIN Thursday, June 16, 2011 1:29 PM Moderator Note added about why the poster's previous post was deleted.
    Thursday, June 16, 2011 1:24 PM
  • Hi,

    No Javascript errors, and I have tried in IE8 and 9 - Still doesn't work in compatibility view. It is strange that it works on one site and not another.

    Please note it is SharePoint 2007 with SSL authentication.

    Thanks,

    Laura


    Laura Blackmore
    Thursday, June 16, 2011 1:45 PM
  • "Be careful because IE sometimes caches the heck out of the favicon state. Make sure you make a new bookmark and clear the cache and close and open IE. Firefox sometimes is easier."

    As told by Randy Drisgill on this post:

    http://blog.drisgill.com/2009/11/sp2010-branding-tip-4-easily-show.html

     

     


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 16, 2011 4:12 PM
  • Yes - My browser history and cache is deleted everytime I close IE. The icon does not show in Firefox, but does in Google. I have deleted history and closed and re-opened IE a number of times over the past few days but it is still not showing.

    Thanks,

    Laura


    Laura Blackmore
    Thursday, June 16, 2011 4:35 PM
  • I use the following code in the <head> section of the my custom master page, directly below the meta content information:

     <link rel="SHORTCUT ICON" href="/PublishingImages/layout/favicon.ico" type="image/x-icon" /> 

    It seems to work okay in IE. I think having the type="image/x-icon" is the key?

    You may need to clear your cache initially, but I haven't had this problem - I close the tab, open a new tabl and go to the site & it works great. I intially tried type="image/ico" and that didn't work for IE, only FireFox.

    Hope that helps!

    • Marked as answer by Peng Lei Tuesday, June 21, 2011 7:40 AM
    Thursday, June 16, 2011 10:35 PM
  • Given that IE will not display the favicons for innumerable sites - some of them major global businesses - but Firefox, Opera, Chrome and Safari all display them without any problems at all - it's pretty clear where the problem is!  Just Google this problem - you'll find that IE8 (and some earlier versions) are notoriously unreliable in this respect.  It's  a Microsoft "feature", of course!!  Don't waste your time trying to get it to work consistently in IE - just accept that it doesn't.
    Thursday, July 28, 2011 8:35 AM