none
inaccessible site settings in sharepoint

    Question

  • I encountered an UNKNOWN ERROR when accessing the Site Settings page  <click Site Actions and select Site Settings> after I customized the application.master <found in Program Files/Common Files/Microsoft Shared/web server extensions/12/LAY-OUTS/TEMPLATES>. I decided to revert the application.master back to its original state (I deleted the modifications I've made) since I thought that caused the unknown error. Yet, after reverting the application.master to its original state, I still encountered an UNKNOWN ERROR.

    I'd like help on the following:
    1) how to make the site settings page accessible again;
    2) what caused the unknown error? Does modifying the application.master cause the unknown error? I also suspect that since I think I and my other colleague are simultaneously updating or making any modification in the site using the Sharepoint Designer, this may have also caused the Unknown Error, is this assumption correct?

    Thanks.

    Gene
    Monday, August 10, 2009 6:53 AM

Answers

  • Thanks, Lionel and Naveen. I was able to resolve the issue by copying an "application.master" file from another instance of sharepoint site and pasting it in the appropriate location; thus the site settings and View All Site Contents pages were accessible again. I've learned my lesson (back up the file first before modifying it) well from that experience.

    @Lionel, will read those "links" to further learn about application pages in layouts folders.

    Again, thanks for your help.
    Tuesday, August 11, 2009 8:14 AM

All replies

  • Hi,

    Its always recommended that to keep a backup of files especially when you are changing the files in 12 hive, you can check the event log for information regarding this error. Can you please post that error msg, so that it would be helpful for us to work on that issue.


    Thanks,
    Naveen
    Monday, August 10, 2009 7:12 AM
  • Hello,

     

    Regarding the customization of the application.master page, as Naveen said, please backup the files before any action. The following KB article is the best practice in doing such customizations:

     

    (KB944105) How to customize application pages in the Layouts folder in SharePoint Server 2007 and in Windows SharePoint Services 3.0

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;944105

     

    To narrow down the problem’s scope, please include the ULS logs here.

     

    Besides, please refer to the following thread in another forum:

     

    Modifying application.master causes error

    http://www.mombu.com/microsoft/sharepoint-design-and-customization/t-modifying-applicationmaster-causes-error-1481855.html

     

    The user found the cause that the slash before the “_layout” has been removed during the customizations. Please check if this is also your case.

     

    Thanks.

     

    Best Regards,

    Lionel Chen

    Tuesday, August 11, 2009 6:50 AM
  • Thanks, Lionel and Naveen. I was able to resolve the issue by copying an "application.master" file from another instance of sharepoint site and pasting it in the appropriate location; thus the site settings and View All Site Contents pages were accessible again. I've learned my lesson (back up the file first before modifying it) well from that experience.

    @Lionel, will read those "links" to further learn about application pages in layouts folders.

    Again, thanks for your help.
    Tuesday, August 11, 2009 8:14 AM
  • Hiii,


    Rather to view message like 'Unknown Error', you can view error on same page. Just do some changes as given in following URL...

    http://nitinb4u.blogspot.com/2009/06/sharepoint-show-errors-on-web-pages.html


    hope this helps in future!!! :)

    Regards,

    N i T i N
    • Edited by Nitinb4u Tuesday, August 11, 2009 8:25 AM Change URL format
    Tuesday, August 11, 2009 8:25 AM