none
file Not Found: Content Query Webpart

    Question

  • Hi everyone,

    i am wokring with a content query webpart to display the documents in a sub site from a document library of another sub site.(My Environment is Sharepoint 2010)

    I have a document library with some folders in it and folders having the documents in it in a"subsite2".

    I want to display the documents of "subsite2" in another subsite called "Subsite1".

    I am using content query webpart to dislay the documents from document library of "subsite2" to "subsite1" based on some content type.

    I am able to see all the document in "subsite1",but the issue is when i click on the link of the document displayed in the content query webpart,then it shows the error as "File Not Found".

     

    Please help me to resolve this issue.

     

    Thanks in advance

    Chandu

    Thursday, November 18, 2010 6:38 AM

Answers

  • Hello,

     

    Seems that you are using Office Web App to view documents from CQWP. While I was testing, this error reproduces on Word and PowerPoint file when it was trying to open the file in browser, Excel file works though.

     

    The reason for this error is that Content Query Web Part passes incorrect URL to wordviewer.aspx and powerpoint.aspx. I am afraid that this problem has been identified as a problem with SharePoint Server 2010 and a known issue has been filed but our product group don’t have an estimate for how long it will take for a fix.

     

    A workaround here is to enable “Open documents in client applications by default” feature at site collection level so that files will be opened in Office application.

     

     

    Sorry for the inconvenience and many thanks for your understanding.  

     

    Thanks & Regards.


    Lily Wu
    • Marked as answer by Lily Wu Friday, November 26, 2010 6:53 AM
    Wednesday, November 24, 2010 2:40 AM

All replies