locked
deactivate publishing feature

    Question

  • Hi all

    I've created a Blank site -I then turned on the Publishing feature. As expected all sorts of new lists and document libraries were created along with it.

    I've since deactivated the Publishing feature on the site, as it didn't turn out to be suitable for what we wanted - but the "system" libraries and lists that were created when I turned Publishing on, are still there - and I can't delete them manually.

    They didn't automatically disappear when I deactivated the Publishing feature - so how do I get rid of them?

    Thanks in advance

    Duncan

    Friday, March 04, 2011 3:25 PM

Answers

  •  

    Make sure there are no contents in any of those list of libraries, then try couple of options to delete them.

    1) go to List -> Settings and then select delete this list

    2) Or go to Site Actions ->Manage content and structure and then delete it from there.

     


    SharePoint Developer
    • Marked as answer by David HM Friday, March 11, 2011 9:39 AM
    Tuesday, March 08, 2011 7:30 PM

All replies

  • That is obvious behavior. Once you activate the publishing feature necessary List/Libraries get created and that never deleted automatically even you deactivate the feature. You have to delete that manually.
    w: http://www.worldofsharepoint.com | t: @sharesandip
    Friday, March 04, 2011 4:14 PM
  • You have to delete it manully.Use sharePoint designer to delete
    Destin -MCPD: SharePoint Developer 2010, MCTS:SharePoint 2007 Application Development
    Friday, March 04, 2011 6:11 PM
  • Thanks for your replies guys, but the point of my posting was that I CANNOT delete those pages or folders - whenever I attempt to do so from Sharepoint Designer I get an error messages stating that the folders contain "one or more lists, document libraries or galleries that your Web site requires in order to function correctly.."  - but it clearly doesn't because the Publishing feature has been turned off?

    Why wont it let me delete them?

    Thanks

    Duncan

    Monday, March 07, 2011 10:23 AM
  •  

    Make sure there are no contents in any of those list of libraries, then try couple of options to delete them.

    1) go to List -> Settings and then select delete this list

    2) Or go to Site Actions ->Manage content and structure and then delete it from there.

     


    SharePoint Developer
    • Marked as answer by David HM Friday, March 11, 2011 9:39 AM
    Tuesday, March 08, 2011 7:30 PM
  • Followed OttawaTechGuy and it works like a charm. Check if you have the right to delete it (security).

    Worked like a charm for me.


    Technical Architect | BrainScale Consulting
    Monday, August 08, 2011 9:20 AM