none
SharePoint 2010 - Windows Explorer View Error - Your client does not support opening this list with Windows Explorer

    Question

  • We're running SharePoint 2010 (MOSS) using a Windows 7 Ultimate client.  When I go into the Windows Explorer view I get the error, "Your client does not support opening this list with Windows Explorer".  Oddly enough there are times (usually the first time into the site) which this works briefly, but after returning to Browse mode, it won't work with the above mentioned error.  I've seen a number of suggestions, none seem to work.  The Web Client Service is running on the client.  Desktop Experience is running on the server.  The automatically detect (proxy) settings is unchecked in the Browser (IE8 by the way).  My version of MSDAIPP.DLL is 12.0.6415.1000 dated 11/20/2008 at 10:58PM and is actually in the C:\Program Files\Common Files\System\Ole DB folder (other posts have this in a different folder).

    Your help would be greatly appreciated!

    Wednesday, May 19, 2010 1:04 PM

Answers

All replies

  • Only does that to me when on Server 2008 without the Desktop Experience activated.  It's never happened to me with Windows 7 on multiple machines and multiple builds, but I don't put SP2010 on Win7 - only on W2K8R2.
    SharePoint Architect || Microsoft MVP || My Blog
    Thursday, May 20, 2010 4:18 AM
  • I know this is an old post but this article my help - http://support.microsoft.com/?id=943280

     

    Friday, December 17, 2010 3:41 PM
  • Hello,

    I have the same problem that I am using W2K8R2 and sharepoint server2010. I want to see my list libraries in Windows Explorer view. It is showing a message box that

    "Your client does not support opening this list with Windows Explorer"

    Can any one tell the solution for this?

    Thank you


    • Proposed as answer by anitKOKO Thursday, March 03, 2011 12:21 AM
    • Unproposed as answer by anitKOKO Thursday, March 03, 2011 12:22 AM
    Wednesday, March 02, 2011 7:03 AM
  • Thursday, March 03, 2011 12:22 AM
  • We are having the exact same issue here on all our Win7 + IE8 clients. Also the odd 'works in beginning but doesn't work after retuning to Browse mode' issue.
    Web Client Service is running. (Maybe it crashes in the background when browsing to other websites ?)

    Version of MSDAIPP.DLL is 12.0.6415.1000 dated 11/20/2008 at 11:58PM and is in C:\Windows\Installer\$PatchCache$\Managed\00002109010090400000000000F01FEC\12.0.4518 and

    C:\Program Files (x86)\Common Files\System\Ole DB

    Any help on this would be greatly appreciated !!
    I also went trough the ' Whitepaper - Understanding and Troubleshooting the SharePoint Explorer View ' from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c523ac7a-5724-48be-b973-641e805588f4 which doesn't seem to explain this unexpected behaviour.

    Any help on this would be GREATLY appreciated !!

     

    Wednesday, March 30, 2011 7:35 AM
  • I'd love to have something positive to say here, but all I can add, is the context in wich I get this error message (Your client does not support opening this list with Windows Explorer):

    Our environment is a SBS2008 network. 90% of computers run Windows 7 PRO.

    We have the SBS server wich hosts the companyweb (SS3) and another server with Windows Server 2008 STD with Sharepoint Foundation installed.

    If I use Windows XP Pro, I can use the Explorer view on both Sharepoint sites. No problem.

    If use a Windows 7 to the "companyweb" (sharepoint services 3.0) there is no issue opening in explorer view, but I get the error "Your client does not support opening this list with Windows Explorer" when I try this view on the "Foundation" site.

    "to be continued..."

    Thomas

    Thursday, June 02, 2011 5:34 PM
  • I was having this issue with a Win7 IE8 machine.  The WebClient service has always been running, but restarting the service got explorer view working.  Apparently the service becomes unstable at some point on my machine.  Not a solution, but more information perhaps.
    Tuesday, August 02, 2011 4:50 PM
  • Let me just preface with, I'm not an IT person, just an end user so I can't try most of the suggestions above. I do know that Explorer View was working perfectly last week on Windows 7, 32 bit running IE 8. My system then ran some automatic updates and it suddenly stopped working. My IT help desk had me load IE 9, the problem resolved itself and worked....up until automatic uploads installed yesterday. I tried uninstalling the Security update for Microsoft Sharepoint Workspace 2010 and when the system rebooted I was able to access Explorer view once and only once and the next time I tried it the error came back and I can no longer access it via Explorer View. There has got to be something in one of the security updates that is causing the problem. If anyone finds a solution please let me know!

    Michele

    Thursday, September 15, 2011 7:07 PM
  • I had this issue at a previous employer. We were running Windows 7 as well. An install of Windows 7 SP 1 resolved the issue for us.

    Thursday, September 15, 2011 7:36 PM
  • Try this:

    1. Go to your SharePoint server's applicationhost.config file (under C:\Windows\System32\inetsrv\config\)

    2. Go to the <requestFiltering> section of the file:

    3.Locate <verbs allowUnlisted

    4. Change it to <verbs allowUnlisted="true" applyToWebDAV="true">

    5. Do an IISRESET

    This should fix the issue.

    Monday, September 19, 2011 7:42 PM
  • FYI

    i am assuming that you alreadyhave Office 2007 or Office 2010 unstalled. WebDav only works on port 80 so if you are running other ports you will e using FPRPC it doesnt look the same as WebDAVE. Desktop experience does NOT need to be running on the Server for any reason unles you are using the Server as your desktop and you want it to look more like Windows 7.

    The issue: You are prompted to enter your credentials when you access an FQDN site from a computer that is running Windows Vista or Windows 7 and has no proxy configured, when you attempt to use Explorer View. Pior to creatiing a GPO testng the registry settings below. THis alos manifests itself when running different ersion of Office on the same client like using Porject 2007 and have Office 2010 installed.

    The issue occurs:

    · On a computer that is running Windows Vista or Windows 7, you do not configure a proxy in Windows Internet Explorer.

    · You use Web Distributed Authoring and Versioning (WebDav) to access a fully qualified domain names (FQDN) site.

    To resolve the issue for a single user

    1. ClickStart, type regedit in the Start Search box, and then pressENTER.

    2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    3. On theEdit menu, point to New, and then click Multi-String Value.

    4. TypeAuthForwardServerList, and then press ENTER.

    5. On theEdit menu, click Modify.

    6. In theValue data box, type the URL of the server that hosts the Web share, and then clickOK.

    However, in larger organizations it would be difficult to visit every desk and create theAuthForwardServerList Parameter. Instead you have two choices 1) Export the AuthForwardServerList MutiValued String with the FQDNs added to the value and add the resulting .reg file to your login scripts or 2) Create a GPO to push the changes down to the desktops, option 2 is a more elegant solution and can be more easily maintained

    To enable all users within an organization to Open Document Libraries in Explorer without being prompted to Authenticate.

    1. On the machine where you have Added theAuthForwardServerListMultistring Values to the registry.

    2. Open GPO Manager > Right Click on the Domain, Site, or OU and choose Create GPO in this Domain or if you have an IE GPO then edit the existing GPO

    3. Go to Computer Configuration > Preferences > Windows Settings > Right Click on Registry

    4. Choose New > Registry Wizard > Local Computer, Next > Use the tree View to expand down to where the AuthForwardServerList Multistring Values were added to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    5. Enter a Check into the Box next to the entries you made earlier, Click Finish, and close GPO manager

    6. All that’s left is to link it to the domain, site or URL and QA

    7. The GPO is completed http://bit.ly/d4ji0L and you can view The Value Data or the websites you were mentioning earlier…

    8. Using the Wizard to Create the GPO……http://bit.ly/bE8V62

     

     

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Tuesday, September 20, 2011 5:43 AM
  • Hi,

    This is a browser issue,you can use below mentioned trick as an alternative

    For Example: If your site url is http://servername/Shared%20Documents/AllItems.aspx

    Replace all // with \\ and / with \

    Also Remove the % or other extra characters with the Library Name and remove the page name.

    Now Open Windows Explorer and type -   \\servername\Shared Documents\ and press enter.

    Document Library will get opened in the Explorer View.

    Thanks!!

    • Proposed as answer by Tanvi Aggarwal Wednesday, June 06, 2012 7:10 AM
    Thursday, February 23, 2012 12:50 PM
  • I found online where the error would occur intermittently with 
    SharePoint 2010, however I think the SharePoint version is irrelevant. 
    They said the client would sometimes poll for a SharePoint root 
    site and the error would occur if there was none. We have not seen 
    the error since I created a root site even though we’re only using 
    WSS3. Our errors began when we changed clients to Windows 7. So 
    it sounds to me like the issue could be from root site polling due 
    to an IE8 security change in Windows 7.

    Thursday, May 24, 2012 6:33 PM
  • I solved this simply by opening Internet Explorer and going into Tools>Internet Options>Security>Local Intranet>Sites>Advanced and adding the site that I wanted to use explorer view with. After that the error stopped and I was good to go.

    This was cross domain access using a fresh install of Win 7 ultimate.

    Wednesday, April 10, 2013 1:58 AM