locked
HTTP Error 503. The service is unavailable.

    Question

  • I need some help troubleshooting this problem but I'm not sure what to try next. I came in the other day and was getting an 'Unable to connect to the content database' error when I pulled up my SharePoint site. I messed around in SharePoint and changed my forms-based authentication back to Windows authentication and then the error became: HTTP Error 503. The service is unavailable. This error remains whether or not I have it on FBA or Windows authentication.

    Two things had changed within 24 hours of this, although I think the site was still working after both of these events occurred:

    1) I changed my network password (trivial, maybe, but I have to mention it)
    2) We made one of the other sites on our SharePoint Server accessable from the outside internet. A security certificate was added to that other site in IIS.

    The other SharePoint site (running on the same server) is working just fine. I have tried rebooting the SharePoint server as well as the SQL server where the databases reside. I restarted the website in IIS and I restarted the SharePoint-related services in the services manager. I did an iisreset on both machines.

    I haven't found anything in the event log that mentions this 503 error. All the SharePoint-related errors go back further than the start of this problem. If it helps I will post those but I don't think they are related.


    • Edited by Mike Walsh FIN Wednesday, June 08, 2011 6:22 AM Help please... removed from title
    Friday, October 24, 2008 8:21 PM

Answers

  • Check the web site properties in IIS. Under home directory tab, check the application pool value.  and then open that application pool from the application pools (separate node in the IIS tree). Click the identity tab and see who is the pool assigned to. For the sake of testing, you can select "Predefined" and select local service from the drop down. Restart IIS and see if things work out for you. Http 503 error is generated by the IIS and it happens when web server sends data stream back to the web site.
    SSA
    • Marked as answer by David Zimmer Monday, October 27, 2008 6:03 PM
    Friday, October 24, 2008 10:14 PM

All replies

  • Check the web site properties in IIS. Under home directory tab, check the application pool value.  and then open that application pool from the application pools (separate node in the IIS tree). Click the identity tab and see who is the pool assigned to. For the sake of testing, you can select "Predefined" and select local service from the drop down. Restart IIS and see if things work out for you. Http 503 error is generated by the IIS and it happens when web server sends data stream back to the web site.
    SSA
    • Marked as answer by David Zimmer Monday, October 27, 2008 6:03 PM
    Friday, October 24, 2008 10:14 PM
  • Thank you so much. My application pool was actually stopped. When I restarted it and then restarted IIS it stopped itself. So I went into the Advanced Settings (this is on Server 2008) and Identity it had my username in there. To test out, I changed this to Local Service and tried to access the page. This gave me a "Cannot connect to configuration database" error.

    So I changed to Network Service and was able to reach the site from the SharePoint server but not from other machines. I got a different Server 500 error I believe. So finally I went back to identity, changed to my username/pass, restarted IIS and everything works.

    This makes me think that it WAS my username and password having changed that caused the site to stop working. This does not seem right to me though. Am I going to have to go back into IIS and update my user/pass in the Application Pool Identity everytime I change my network password?
    Monday, October 27, 2008 6:08 PM
  • Why not create a service account that has a password that never changes, for this?

    In our environment, we have 4 different service accounts that run different services.  None of their passwords expire and so far we've been ok.  I think it's Microsoft best practice, also, to run under service accounts rather than personal user accounts.

    Veronica
    Monday, October 27, 2008 6:54 PM
  • Good point. I just found out we have a spadmin login created just for this. Thanks!
    Monday, October 27, 2008 7:10 PM