none
Master page won't apply when a new site is created

    Question

  • Hi everybody,

    I am quite new with SharePoint branding and I have created new master page (just copy the v4.master, rename it and change SiteLogoImage). Then I selected this site as default for Site Master Page and System Master Page. Also in Site Actions -> Master pages and page layouts -> is my new master page Approved. Problem is that when I create a new Site (for example Team site) the old master page is applied. If I check "Reset all subsite to inherit this master page settings" the new master page is applied for all subsites, but the problem with new site still remain.

    I really don't know what I am doing wrong.

    Any help? Thanks a lot.

    Wednesday, April 18, 2012 8:34 AM

Answers

  • Hi David ,

    this is the SharePoint default functionality ( setting).If you want to apply custom master pages to subsite either you need to reapply with check box or create a feature and attch the master page using code.refer the link below

    Deploying a custom master page in SharePoint 2010


    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    • Marked as answer by David Row Wednesday, April 18, 2012 9:00 AM
    Wednesday, April 18, 2012 8:48 AM

All replies

  • Hi David ,

    this is the SharePoint default functionality ( setting).If you want to apply custom master pages to subsite either you need to reapply with check box or create a feature and attch the master page using code.refer the link below

    Deploying a custom master page in SharePoint 2010


    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    • Marked as answer by David Row Wednesday, April 18, 2012 9:00 AM
    Wednesday, April 18, 2012 8:48 AM
  • Thank you a lot for your answer.

    Then I really don't know why they write this in the Site Master Page Settings ->"Specify a master page to be used by this site and all sites that inherit from it:" if I understand properly it only sets the master page on the site but if I want to apply it to the subsite I have to check "Reset all subsites to inherit this site master page setting"

    Thanks again for your answer. I could be stuck here for a long time, keeping in mind that I do something wrong :) 


    • Edited by David Row Wednesday, April 18, 2012 9:01 AM
    Wednesday, April 18, 2012 9:00 AM