locked
How do I get the TS gateway webpart in to MOSS 2007?

    Question

  •  

    So I have installed Windows server 2008 with at Terminal service gateway, and I must say it work like a charm. I can hardly wait to remove my old Citrix server.

    But that a side, the document states that I can use the webpart from the TS web page in SharePoint.

    Does anyone know how to do that?

    All I can see in c:\windows\web\ts\bin a file called tsportalwebpart.dll, but I don’t know what to do with it.

    Does anyone have a suggestion?

    • Edited by Mike Walsh FIN Friday, January 16, 2009 8:32 AM Unnecessary ?s removed
    • Moved by Mike Walsh FIN Friday, June 11, 2010 6:49 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, January 30, 2008 8:58 PM

Answers

  • Please go to:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=518d870c-fa3e-4f6a-97f5-acaf31de6dce&DisplayLang=en

     

    You will find this document:

    Step_by_Step_Guide_to_Customizing_TS_Web_Access_by_Using_Windows_SharePoint

     

    It will tell you exactly how to get remoteApp Icons into WSS or MOSS.

     

    but,

     

    I followed every step in the document, in the last part you have the ability to add a new webpart containing the icons for the programs you have published via TS\RemoteApp. When I did that I was given an HTTP 403 error, this has to do with permissions. Most probarly I added a webpart for which I do not have the permission to see it. And if this webpart, in my case, is part of the sharepoint home page you do not see anything anymore. No more site settings, ... nothing.

     

    How am able to change webpart-permissions or remove the webpart without the possibility get into sharepoint? (Chicken and the egg)

     

    Greetz Freddy

    Wednesday, February 27, 2008 11:09 AM
  •  

    Boy howdy this was a tough one!

    I was having the same problem as Eric above and tried the fix that Daniel suggested without success but... it just so happened I tried adding the web part to a different site the second time and discovered the error path changed. From that point forward, no matter what site I tried to add the web part too, the error path remained the same (to the original failed site).

    The fix (at least for me): Delete TSPortalWebPart and reset IIS as Daniel stated. Re-add the TSPortalWebPart back to the web part gallery. Now here’s the trick and I’m sure it will be different depending on how your site setup. Add the TS Web Access web part to your top most site (for me it was the MOSS Server home page).  That’s it! After that you can remove the web part from the top site and add it to any site you want. 

    I’m guessing a default path is set the first time you add the web part and if it's not root then it won't work.

    James

    • Marked as answer by Mike Walsh FIN Tuesday, November 18, 2008 8:39 PM
    Tuesday, November 18, 2008 8:36 PM

All replies

  • Please go to:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=518d870c-fa3e-4f6a-97f5-acaf31de6dce&DisplayLang=en

     

    You will find this document:

    Step_by_Step_Guide_to_Customizing_TS_Web_Access_by_Using_Windows_SharePoint

     

    It will tell you exactly how to get remoteApp Icons into WSS or MOSS.

     

    but,

     

    I followed every step in the document, in the last part you have the ability to add a new webpart containing the icons for the programs you have published via TS\RemoteApp. When I did that I was given an HTTP 403 error, this has to do with permissions. Most probarly I added a webpart for which I do not have the permission to see it. And if this webpart, in my case, is part of the sharepoint home page you do not see anything anymore. No more site settings, ... nothing.

     

    How am able to change webpart-permissions or remove the webpart without the possibility get into sharepoint? (Chicken and the egg)

     

    Greetz Freddy

    Wednesday, February 27, 2008 11:09 AM
  •  

    Thanks... I will give it a try.
    Wednesday, February 27, 2008 3:54 PM
  • Please let me know if it worked at your site.

    Friday, February 29, 2008 8:29 PM
  • Finally I got time to set it up.

    It works like a charm, thanks again.

    Monday, April 28, 2008 9:47 AM
  •  

    I've installed the TS Web Access role on my MOSS server (running 2008 x64), but I get this error when I add the TS Portal Web Part to a page...

     

    The "TSPortalWebPart" Web Part appears to be causing a problem. Could not find a part of the path 'C:\inetpub\wwwroot\wss\VirtualDirectories\sharepoint80\services\_wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images\rapwait.gif'.

     

    I even went so far as to copy rapwait.gif from C:\Windows\Web\ts\images to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images directory and set permissions as needed.

     

    The thing that gets me is the "\services\" portion of the path in the error.  This directory does not exist in the file system or when I look at the virtual directory in IIS.

     

    Anyone have any input or suggestions?

     

     

    Sunday, May 18, 2008 4:48 AM
  • Hi,

     

    I was having exactly the same problem, but I've now fixed it and it's working fine.

     

    I deleted the web part and started again, with a few very minor tweaks.

     

    Delete the web part from any location(s) you may have placed it.  Go into site settings, galleries, web parts and delete the TSPortalWebPart.

     

    Do an IISReset to clear everything out.

     

    Run through the document as it says to do.  Create the images folder and set the permissions.

     

    After creating the images folder, copy all the images from the 'C:\Windows\web\ts\images' folder to the images folder you have just created.  I hadn't view this site.  You get a few extra images after you run it for the first time, but I guess by now you have been to this site several time?

     

    Then add the web part as per the documentation.

     

    I then found it worked straight away.

     

    I also had the problem that everytime I added a RemoteApp the webpart would complain because it couldn't find the app icon image.  I then found if I ran the TS Web Access web site and clicked on RemoteApp Programs it would generate an icon in the 'C:\Windows\web\ts\images' folder which I could then copy to the \wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images and it would work.

     

    I then thought, I run my MOSS web app as Microsoft tell me to, under a service account.  I re-ran the 'icacls images /grant NetworkService:F' command and replaced the 'NetworkService' with my web application pool service account. Deleted the image files I had manually copied, refreshed my SharePoint site and bingo, I saw the image files get created on the file system automatically and the web part displayed all the RemoteApps I had publish.

     

    Let me know if you have any further problems setting this up, it is very cool once it works and is even cooler when it runs through your SharePoint site.

     

    Friday, June 20, 2008 2:25 PM
  • After a successful test, I tried to move it over to the production system.

    There I get the exact same error as you Eric.

    I have tried Daniels solution but it didn’t seem to help in my case.

    Monday, June 23, 2008 7:31 AM
  • I'm experencing the same problem with the "Could not find part of the path" error. In our case, it seems to crash when we reboot the WSS server. Before the reboot no problems, after the reboot, the error comes up on every site which uses the webpart.

     

    Has anyone had any luck with it yet?

    • Proposed as answer by Jamests Tuesday, November 18, 2008 8:34 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, November 18, 2008 8:39 PM
    Wednesday, June 25, 2008 1:48 PM
  • I followed all of the instructions in the Microsoft guide.  However, when I go to create a new Web Part, "TSPortalwebPart" is not in the list.  I have went over my steps at least 6 or 7 times and exactly recopied the code that I was supposed to add to my web.config file.  I have full permission over the site. 

    Wednesday, June 25, 2008 5:18 PM
  • Hi Paul,

    Did you installl the TS Webaccess role on your sharepoint server?
    Friday, August 01, 2008 8:33 AM
  •  

    Boy howdy this was a tough one!

    I was having the same problem as Eric above and tried the fix that Daniel suggested without success but... it just so happened I tried adding the web part to a different site the second time and discovered the error path changed. From that point forward, no matter what site I tried to add the web part too, the error path remained the same (to the original failed site).

    The fix (at least for me): Delete TSPortalWebPart and reset IIS as Daniel stated. Re-add the TSPortalWebPart back to the web part gallery. Now here’s the trick and I’m sure it will be different depending on how your site setup. Add the TS Web Access web part to your top most site (for me it was the MOSS Server home page).  That’s it! After that you can remove the web part from the top site and add it to any site you want. 

    I’m guessing a default path is set the first time you add the web part and if it's not root then it won't work.

    James

    • Marked as answer by Mike Walsh FIN Tuesday, November 18, 2008 8:39 PM
    Tuesday, November 18, 2008 8:36 PM
  • I'm having the same issues as Paul. I have a windows 2008 terminal server, TS Web access installed and everything functioning. I'm trying to add the web part to our Windows 2003 Sharepoint server as per the documentation. I too cannot find the TSPortalWebPart, and I've gone over the steps a dozen times.
    Tuesday, November 25, 2008 6:49 PM
  • Hi James,

    I too had problems, but after following the advice of both Daniel and yourself, viola. However, I have a new problem. At some point during the night (during SQL Backup, Service reset, ???), something happens. When I first access the site each morning, I get the original "could not find path" error and have to go through the delete, service restart, reinstall process. Everything works fine for the rest of the day. Any ideas?

    Jay

    Friday, December 05, 2008 4:09 PM
  • Jay,

    I suspect it’s the same problem with the default path not being set properly when the system first starts up. For us I created a tab on our MOSS home page so the path is set the first time someone accesses the site.

    I have read MOSS does some kinda of reset at night which forces the just-in-time compiler to re-compile the site. This can cause up to a 45 second delay for the first person who logs in. I’ve downloaded a warm up script that’s supposed to “warm up” the site but haven’t tested it yet. You may be able to use a similar script to set the path.

    James 

    Monday, December 08, 2008 5:38 PM
  • Hi,

    I am experiencing this very same problem but with WSS 3.0. As others have said when the IIS resets on the WSS/TS Web server I get the error.  'C:\inetpub\wwwroot\wss\VirtualDirectories\80\demo1\_wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images\rapwait.gif'

    In my case demo1 is a subsite of the main WSS site. This root site has multiple subsites each with a TS webpart on them and demo1 is the first of these and even if I have a TS webpart on the root page I still get the same error.  I initially followed the instructions here to remove and add the webart to the site(s).  However I found out that this didn't resolve the issue because when IIS reset the problem would recoccur.  The quickest way to resolve it was to do an iisreset on the WSS/TS Web server.  This always fixes the problem even sometimes after 1 iisreset but sometimes it would take 2 or 3 attempts.

    It would appear that when IIS resets itself either through a restart or some other task the process that manages the web part does not initialize itself. This is a real problem for me because I now have to remove automatic security updates from this internet facing server.  My next step is to raise a critical support call with Microsoft to see if I can get this fixed as it is obvious there is a bug/glitch somewhere.

    Wednesday, December 10, 2008 7:30 PM
  • James,

    I'm pretty sure your correct. If I add the part to the main page (and only the main page), it works just fine without a problem. As soon as I add it to a subsite, it errors out on first access after startup with the subsite in the path. I will try your suggestion on the startup.
     
    This has to be a permissions thing, but it's got me stumped!

    Jay
    • Proposed as answer by JayD3 Friday, December 12, 2008 1:56 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, January 13, 2009 11:01 AM
    Thursday, December 11, 2008 11:14 AM
  • I'm getting soooo close.

    It's definitely the path issue, as James indicated. I don't have the answer as to why it has to be accessed from top site yet, but I have found a decent work around.

    First of all, reboots, iisresets and reinstalls are not necessary. Everything is tied to recycling the application pool. By default, IIS recycles the application pools every 1740 minutes (29 hours). Apparently, Sharepoint changes that setting to once a day at a specific time (2:12am in my case). This is when everything gets reset. The first time you access the site after the recycle, the default path for the web part will be set and in our case that needs to be at the top site.

    James mentioned a warm up script. That's the direction I went. However, I found a cool tool called the Application Pool Manager for Sharepoint Developers (www.harbar.net/articles/apm.aspx). You can configure the tool to automatically access a Warm up URL after an app pool recycle. From the top site, I created a new web part page and saved it to a top site document library. I added the TSPortal web part to that new page and then added its URL into the Warm Up URL field in the Application Pool Manager. From the App Pool Manager, you can force a recycle. It works!

    That's the good news. The bad news is that even though the pool manager was running, it didn't appear to fire off after the IIS forced recycle at 2:12am. The first thing I did this morning was to go directly to the subsite and I got the path error. However, all I did to fix it was to close my browser and force a recycle from the app pool manger. It took about 5 seconds. I then reopened the subsite and Bingo - No Error!

    This pool manager tool does have draw backs. It does not run as a service, so some account has to be logged on for it to work. And as I mentioned earlier, it didn't appear to seamlessly handle the nightly recycle event. But a 5 second routine to get it working again is a definite improvement. I'm going to continue working on this and will keep you posted.

    Jay

    Friday, December 12, 2008 2:36 PM
  • I've been wrestling with this for about two weeks or so; I need to get the TSWebPart webpart to work on multiple sites within our sharepoint farm as cleanly as possible.  I appreciate all the feedback I've seen on this thread, it has definitely been helpful.

    It works perfectly on the very first site I put it on, but something doesn't link up right for any other sites (even other top level sites) even though all of the settings are correct and IIS looks like it is mapping correctly.

    The work around that I'm using now is to create a shortcut to the appropriate images directory (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images) at the location specified in the Sharepoint error.  So far this is working flawlessly;  it has survived iisresets, server reboots, app pool bounces - all without me having to do any further tweaking. 

    Monday, December 22, 2008 10:45 PM
  • JessD said:

    I've been wrestling with this for about two weeks or so; I need to get the TSWebPart webpart to work on multiple sites within our sharepoint farm as cleanly as possible.  I appreciate all the feedback I've seen on this thread, it has definitely been helpful.

    It works perfectly on the very first site I put it on, but something doesn't link up right for any other sites (even other top level sites) even though all of the settings are correct and IIS looks like it is mapping correctly.

    The work around that I'm usiGWPng now is to create a shortcut to the appropriate images directory (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images) at the location specified in the Sharepoint error.  So far this is working flawlessly;  it has survived iisresets, server reboots, app pool bounces - all without me having to do any further tweaking. 



    Jess,

    When you say create a shortcut at the location specified in the SharePoint error. Did you have to manually create the folder structure below "C:\inetpub\wwwroot\wss\VirtualDirectories\80" for example the path in the error might be "C:\inetpub\wwwroot\wss\VirtualDirectories\80\mysite\_wpresources\TSPortalWebPart\6.0.0.0__31bf3856ad364e35\images\rapwait.gif" On my server the mysite folder mysite does not exist along with the subsequent folders.

    Cheers
    Paul
    Tuesday, January 13, 2009 8:28 AM
  • Well I think *fingers crossed* I may have fixed the problem. I raised a call with Microsoft support and a hotfix was suggested. I have applied the hotfix to my test environment and run 20 consecutive IISRESET's, recycled the application pool 20 times and restarted the server 3 times and have yet to see a reoccurrence of the issue.  The hotfix is http://support.microsoft.com/kb/957081/ and while it suggests you don't need a reboot I had to reboot the server before the problem disappeared.

    Hope this helps everyone else who has been driven mad with this issue.

    Cheers
    Paul
    Tuesday, January 13, 2009 10:22 PM
  • paulmo said:

    Well I think *fingers crossed* I may have fixed the problem. I raised a call with Microsoft support and a hotfix was suggested. I have applied the hotfix to my test environment and run 20 consecutive IISRESET's, recycled the application pool 20 times and restarted the server 3 times and have yet to see a reoccurrence of the issue.  The hotfix is http://support.microsoft.com/kb/957081/ and while it suggests you don't need a reboot I had to reboot the server before the problem disappeared.

    Hope this helps everyone else who has been driven mad with this issue.

    Cheers
    Paul



    Well it appears my initial optimism was unfounded. I Checked the server this morning as I have been doing for the last 3 months and the TSPortalWebPart was down. I had to do an IISRESET to get everything working. What I cannot understand is that the server survived reboots and resets 2 days ago. 

    Cheers
    Paul
    Friday, January 16, 2009 7:28 AM
  • I have implemented some changes and the TSPortalWebPart has been stable for nearly 6 days now. The following is the process that I have gone through. This example assumes I have 2 subsites to the root SITEA and SITEB.

    1. Identify the website experiencing the issue.

    2. Make a backup copy of your \system32\inetsrv\config\applicationHost.config file.

    3. Open the \system32\inetsrv\config\applicationHost.config file using Notepad or an XML editor.


    4. Locate the <sites> section.


    5. Locate your specific website’s subsection within <sites> (in my case it was <site name="SharePoint - 80" id="1412019433" serverAutoStart="true"> )

    6. Note there are several lines beginning “<virtualDirectory path=”


    7. After the first of these entries, add the following line:


    <virtualDirectory path="/SITEA/_wpresources" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources" />
    <virtualDirectory path="/SITEB/_wpresources" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources" />
     

    8. Save your changes to the file.


    9. From a Command Prompt, run IISRESET.

    Then all you need to do is is change this file each time you add a new subsite.

    Cheers
    Paul

    Wednesday, January 21, 2009 8:33 AM
  • Can this be implemented on a 2003 server running MOSS? I have  2008 server running the TS server.
    • Proposed as answer by Jeff-G Wednesday, August 26, 2009 3:38 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, March 10, 2011 11:13 AM
    Friday, March 20, 2009 8:15 PM
  • where should tsportalwebpart.dll go as it dose not say in the step by step guide ?
    Tuesday, September 22, 2009 9:06 PM
  • Hi Daniel,

     

    Wow, this Microsoft documentation is some of the worst I've tried to follow.  It just doesn't work.  It doesn't take into account RD 6.1 and Server 2008 R2 it seems like.

     

    My problem is, in IIS, I have the Default Site folder installed with the WSS folder, and the RD Web Services is configured.  When I install SharePoint it takes port 80, and then the Default Site stops.  So.. that breaks stuff because the WSS folder that you edit the web.config is located there right?

    Someone needs to revisit this documentation, and put some screen shots in.

    Some of the other people who posted on here are using the 6.0.0.0 instead of 6.1.0.0 for Server 2008 R2.  In the MS docs, you'll find it either or, and listed for either or 2008/2008 R2.

     

    Just need some simple steps forward to make this work if anyone can provide them.

     

    Thanks,

    Rob

    Thursday, June 10, 2010 9:58 PM
  • I got this working in R2 i change the line in the web.conf file the line is

    Web.config file, add the following line under the other SafeControl Assembly entries (as a single line):

    <SafeControl Assembly="TSPortalWebPart, Version=6.0.0.0, Culture=neutral

     

    change to

     

    Web.config file, add the following line under the other SafeControl Assembly entries (as a single line):

    <SafeControl Assembly="TSPortalWebPart, Version=6.1.0.0, Culture=neutral

     

    and it all work fine

     

     

    Thursday, June 17, 2010 8:59 PM
  • RobF- you need to add a host header to your sharepoint-80 site and then the default site for RDWeb can be restarted.  but, adding a hostheader will only work if you also add a dns entry of the same name to point to that server or IP address.


    MCITP:Enterprise Admin MCSA, MCSE, MCDBA

     

    Moderator Note: NEVER add SP 2010 questions (or comments) in Pre-2010 threads !

    • Edited by Mike Walsh FIN Thursday, March 10, 2011 11:15 AM Moderator Note added - text in this post removed and a later SP 2010 question deleted.
    Thursday, October 28, 2010 8:03 PM