none
Single sign on across different web applications

    Question

  • Hi All,

    I am using forms based authentication with a custom login, custom membership provider, and custom aspnetdb database.  Does anyone know the best way to do single sign on across multiple web applications, all using the custom forms login?

    Thank you,

    Nici

    Tuesday, March 06, 2012 6:36 PM

Answers

  • Does SharePoint have any cookies or session variables that it uses to form authentication that I could use to do SSO between the different web apps?

    Thank you,

    Nici

    • Marked as answer by KonaCoffee Tuesday, March 20, 2012 5:29 PM
    Friday, March 09, 2012 6:41 PM

All replies

  • That should be easy. You just need to Configure Secure Store Web Service to use SQL Membership Provider.

    Follow the steps as given below:

    3. Configure Secure Store Web Service to use SQL Membership Provider

    Everything we did for Central Admin site, we are going to do for theSecurityTokenServiceAppliaation which is in the SharePoint Web Services application.

    image

    Without redo’ing all the steps:

    • Create the connection string
    • Add the .NET role provider
    • Add the .NET users provider
      Verify connection by editing config.xml.


    Varun Malhotra
    =================
    If my post solves your problem could you mark the post as Answered or Vote As Helpful if my post has been helpful for you.

    Wednesday, March 07, 2012 1:54 AM
  • Hi Varun,

    Thank you for your post.  I already have the connection string and the membership provider in this webconfig but when I click on a link from one of my sites to a site in another web app, it is still prompting me to log in again.  All my sites are using forms authentication.  Is there something else that I can set that might let me go straight into the other site, bypassing the login page?  I have double checked all the permissions for both sites and I know the I have permissions. 

    This is from the securitytokenserviceapplication webconfig

     <connectionStrings>
          <clear />
           <add name="SQLProvider" connectionString="Server=serverName;Database=aspnetdb;User ID=sa;Password=password" providerName="System.Data.SqlClient" />
        </connectionStrings>
      <system.web>
        <membership defaultProvider="CustomMembershipProvider">
          <providers>
            <clear />
            <add name="CustomMembershipProvider" connectionStringName="SQLProvider" applicationName ="/" type="Custom.AspNet.Membership.CustomMembershipProvider, CustomMemberShipProvider, Version=1.0.0.0,  Culture=neutral, PublicKeyToken=c5ae7c5e0dc4c5fa" enablePasswordReset="false" enablePasswordRetrieval="false" passwordFormat="Clear" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" />
          </providers>
        </membership>
        <roleManager enabled="true" defaultProvider="CustomRoles">
          <providers>
            <clear />
            <add name="CustomRoles" connectionStringName="SQLProvider" applicationName="/" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
          </providers>
        </roleManager>
        </system.web>

    Thank you,

    Nici


    • Edited by KonaCoffee Wednesday, March 07, 2012 2:36 PM
    Wednesday, March 07, 2012 2:35 PM
  • Does SharePoint have any cookies or session variables that it uses to form authentication that I could use to do SSO between the different web apps?

    Thank you,

    Nici

    • Marked as answer by KonaCoffee Tuesday, March 20, 2012 5:29 PM
    Friday, March 09, 2012 6:41 PM
  • Hi All,

    Im still trying to implement sigle sign on and I am trying to follow http://msdn.microsoft.com/en-us/library/hh446525.aspx which has a codeplex project http://claimsid.codeplex.com/ 

    Has anyone be able to get this to work? 

    Thank you,

    Nici

    Tuesday, March 13, 2012 5:42 PM
  • Hi Nici,

    Were you able to find a way to implement sso across multiple web applications in SP 2010 using fba?

    Thanks, Diego

    Tuesday, July 10, 2012 6:32 PM