none
SharePoint 2010 Custom Events Calendar Add new Item hover not working

    Question

  • Hi,

    I am have created a custom events list based on the OOTB Calendar via Visual Studio 2010.

    I create my list def and package it up and deploy no issues.

    I then create a new list based on my custom list definition.

    All seems fine

    But when I want to add an item from the calendar view there's no mousehover functionality anymore, for the add new event when hovering over a day item in the calendar view.

    If I create a new events list based on the OOTB list definition I can get the add new event from the calendar view.

    As far as I can tell all the relevant .js files are included on the page when viewing the source.

    Is there a trick to get this working for a custom events list?

    Thanks in advance, Pete

    Thursday, February 10, 2011 5:01 PM

All replies

  • If anyone else runs into this issue changing the Type attribute to 106 fixes the problem. For example:

      <ListTemplate
        Name="ProjectEvents"
        Type="106"
        BaseType="0"
        OnQuickLaunch="TRUE"
        FolderCreation="FALSE"
        SecurityBits="11"
        Sequence="340"
        DisplayName="Project Events"
        Description=""
        Image="/_layouts/images/itevent.png"/>
    

    This matches the Type of the default Events lists. Note that the Type attribute needs to be unique within a feature.

    • Proposed as answer by sdfsda Friday, September 09, 2011 2:24 PM
    • Unproposed as answer by sdfsda Friday, September 09, 2011 2:25 PM
    • Proposed as answer by sdfsda Friday, September 09, 2011 2:59 PM
    • Unproposed as answer by Steven AndrewsEditor Friday, June 01, 2012 4:23 PM
    Tuesday, March 08, 2011 3:28 PM
  • Yes True,

    but everything worked fine, but I lost the custom column which I used in the definition.

    It looks like, if we use this default Type=106 ( which was earlier in my case 1004), rule out your custom column which you crated in definition.

    so still it seems the issue is there, when we try to have custom calendar list with out column..

    -tx  Labhesh


    Labhesh Shrimali
    Tuesday, June 14, 2011 5:10 PM
  • Can I expact some reply from MS community memeber?

    Is this bug or the solution is available for this issue? Current I need to provide this functionality to client, so request you to respond as soon as possiable.

    tx

    -L


    Labhesh Shrimali
    Monday, July 04, 2011 3:46 PM
  • Labhesh,

    Hey, thanks for your entry.  I had the same problem.  For me, it seems to work all the way.  I changed the Template Type to 106 for the List Definition and List Instance, however in the Schema file I do override the OOB Content Type "0x0102" with my own custom Content Type, and this shows all my custom columns as normal.  And it does fix the problem with Add button.

    Hope this helps, even if its late!

    Friday, September 09, 2011 2:59 PM
  • Hi Labhesh,

    Can you post your Content Type? Tanks

    Friday, June 01, 2012 12:35 PM
  • Hi arriba,

    In my Sharepoint visual web part i am using default sharepoint calendar view. But Mouse hover over the date to add a new item is not working. Please see this image below i need the same add new item functionality. 

    Thursday, October 18, 2012 5:18 AM