locked
How can I remove/hide built-in Title field in list definition

    Question

  • Now I'm customize a new Content and then new List Template, just like below definition;

     <ContentType ID="0x0100ed096ab35eeb4d2e98fb71b9842e9616" Name="Staff Member" Group="Berry Gardens Internet">
      <FieldRefs>
       <FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Name="Title" />
       <FieldRef ID="{F5E777EA-C083-4c2f-BC10-E4BF2B4D6372}" Name="Synopsis" />
       <FieldRef ID="{2307576C-A060-4c2d-BABC-34E5A9924667}" Name="Image" />
       <FieldRef ID="{051B830A-8105-4384-9AA1-103CEE43B760}" Name="Email Address" />
      </FieldRefs>
     </ContentType>

    It is inherit from Item parent type, and using built-in Title field({fa564e0f-0c70-4ab9-b863-0177e6ddd247}), but I found that it's diffcult to remove/hide it.

    When in the default list view, there are two Title fields.

    So what can I do in the list definition.

    Regards

    upzone

     

     

    • Moved by Mike Walsh FIN Thursday, April 01, 2010 7:48 AM customization rather than programming (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Thursday, April 01, 2010 7:30 AM

Answers

  • Hi,

    One possibility is to add between <FieldRefs> and </FieldRefs> following section:

    <FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Hidden="TRUE" Required="FALSE" DisplayName="_hidden" />

     

    other is to add:

    <RemoveFieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" />

     

    ID is default Title field ID, so you just need to copy it.

    • Marked as answer by upzone Thursday, April 22, 2010 12:50 PM
    Thursday, April 01, 2010 10:13 AM
  • Hi Upzone,

    To hide Title column please follow below steps.

    1) Go to List settings-->Click on Advanced Settings-->Select Allow Management of Content Types=Yes radio button

    2) Click on particular content type where title field exists--->click on Title column--->Select Hidden(Will not appear in forms) radio button ---> click on "OK" button

    3) Now go to your list and check (by click on new ---Title will not visible) and similarly you uncheck the Title column from Default view(It won't appear in View)


    Thanks & Regards, Neerubee
    • Marked as answer by upzone Thursday, April 22, 2010 12:50 PM
    Thursday, April 01, 2010 8:24 AM

All replies

  • Hi Upzone,

    To hide Title column please follow below steps.

    1) Go to List settings-->Click on Advanced Settings-->Select Allow Management of Content Types=Yes radio button

    2) Click on particular content type where title field exists--->click on Title column--->Select Hidden(Will not appear in forms) radio button ---> click on "OK" button

    3) Now go to your list and check (by click on new ---Title will not visible) and similarly you uncheck the Title column from Default view(It won't appear in View)


    Thanks & Regards, Neerubee
    • Marked as answer by upzone Thursday, April 22, 2010 12:50 PM
    Thursday, April 01, 2010 8:24 AM
  • Hi,

    One possibility is to add between <FieldRefs> and </FieldRefs> following section:

    <FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Hidden="TRUE" Required="FALSE" DisplayName="_hidden" />

     

    other is to add:

    <RemoveFieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" />

     

    ID is default Title field ID, so you just need to copy it.

    • Marked as answer by upzone Thursday, April 22, 2010 12:50 PM
    Thursday, April 01, 2010 10:13 AM
  • Thank You Borozna

    <RemoveFieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" />

    worked for me

    Tuesday, August 17, 2010 8:29 AM