none
Insert picture from sharepoint disabled in editor field

    Question

  • Hi,

    When I create an announcement list, the body is a" multiple lines of text" field with then enchanded rich text editor mode enabled.
    When I add a new item, I can open the tab insert and click on picture.

    There I get 3 options: from computer / from address / from sharepoint
    The option "from sharepoint" is disabled (grayed out).

    I looked on the forum here and google, and all I could find was that the SharePoint Server Publishing should be enabled, but that is already the case on my site, and still the option is disabled.

    I tried with a custom list, but it gives the same problem.
    When I add a content editor web part on one of my pages, the option to insert a picture from sharepoint is enabled. So it's only happening when trying this inside a listitem.

    How can I browse for a picture inside SharePoint from the editor inside a listitem ?

    Thursday, September 09, 2010 8:37 AM

Answers

  • These content types:

    • Enterprise Wiki
    • Publishing Page

    Allow "Insert from Sharepoint" because the content field is of type "Publishing HTML"

    These content types:

    • Wiki
    • Blog

    Don't have the "Insert from Sharepoint" action, because the content field is of type "Multiple lines of text"

    You can only use the Insert from SharePoint action when the field is a Publishing HTML type.

    • Proposed as answer by BobChauvin Tuesday, September 13, 2011 1:16 PM
    • Marked as answer by kurtvd Tuesday, September 13, 2011 1:38 PM
    Saturday, September 10, 2011 4:20 PM
  • Nice to know, but that's not something I can explain to my end users...

    To me this is still a bug that should be solved.
    End users don't care about content types. All they see is an editor where sometimes they can insert from sharepoint and sometimes they can't, and it doesn't make any sense to them.


    • Edited by kurtvd Monday, September 12, 2011 7:45 AM
    • Marked as answer by kurtvd Tuesday, September 13, 2011 1:38 PM
    Monday, September 12, 2011 7:45 AM
  • I found a solution that fixed this problem for me.

    Add the 'Page Image column to your list (remove it from the default view). The insert from SharePoint button shouldnt be greyed out anymore.

    Greetz.

    • Marked as answer by kurtvd Thursday, September 27, 2012 8:17 AM
    Thursday, September 27, 2012 8:06 AM

All replies

  • Is this something that is not supported in a listitem?
    If so, why is the option there in the first place ?

    I think it's highly user unfriendly when users are not able to browse inside sharepoint to select a picture :(

    Friday, September 10, 2010 9:42 AM
  • I am facing the same problem, are the moderators going to reply or do something about the post? Its been here since September last year!
    Monday, April 11, 2011 1:45 AM
  • SharePoint Publishing feature should usually fix this problem.  Can you please indicate the Build/Edition you are using, so that I will try to reproduce it at my end.
    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, April 11, 2011 2:38 AM
  • Hi Kamlesh,

    I am usig SharePoint 2010 server with december cumulative update applied.

    Configuration database version: 14.0.5130.5002

    Regards,

    Monday, April 11, 2011 3:18 AM
  • Activating the publishing features at the top level site collection resolved this issue for me.

     

    -Thanks,

    Pallavi


    Thanks, Pallavi
    Wednesday, June 15, 2011 2:23 PM
  • As indicated in the first post, it doesn't solve it for me.

    After 9 months, still no solution or good explanation as to why this is disabled.
    Way to go Microsoft.

    Wednesday, June 15, 2011 2:24 PM
  • Didn't work for me, either. :(

     

     Configuration database version: 14.0.5114.5000


    /bac
    • Edited by BobChauvin Thursday, August 18, 2011 5:07 PM added version
    Thursday, August 18, 2011 4:57 PM
  • Sorry to hear that this issue is still persisting in some of your environments.  I could not simulate this at my end.  By the way, did anyone try upgrading to Service Pack 1 and checking the behavior?
    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 19, 2011 3:15 AM
  • These content types:

    • Enterprise Wiki
    • Publishing Page

    Allow "Insert from Sharepoint" because the content field is of type "Publishing HTML"

    These content types:

    • Wiki
    • Blog

    Don't have the "Insert from Sharepoint" action, because the content field is of type "Multiple lines of text"

    You can only use the Insert from SharePoint action when the field is a Publishing HTML type.

    • Proposed as answer by BobChauvin Tuesday, September 13, 2011 1:16 PM
    • Marked as answer by kurtvd Tuesday, September 13, 2011 1:38 PM
    Saturday, September 10, 2011 4:20 PM
  • Nice to know, but that's not something I can explain to my end users...

    To me this is still a bug that should be solved.
    End users don't care about content types. All they see is an editor where sometimes they can insert from sharepoint and sometimes they can't, and it doesn't make any sense to them.


    • Edited by kurtvd Monday, September 12, 2011 7:45 AM
    • Marked as answer by kurtvd Tuesday, September 13, 2011 1:38 PM
    Monday, September 12, 2011 7:45 AM
  • @Bil Simser - Thanks.  Microsoft should bridge the gap.  As @kurtvd points out, this is not going to be a fun discussion with users.
    /bac
    Tuesday, September 13, 2011 1:18 PM
  • Hi, I'm experiencing the same issue. I already installed Service Pack 1 but the behavior persists. I've checked Publishing features (for the collection sites, for the top level site in the collection and for the site that cointains the list) and they are enable.  I can't use fields of type "Publishing HTML" because I need to personalize my list form with Infopath and those field types don't support personalization (they don't appear in the avalaible fields in infopath).

    Does anybody have another suggestion?

    Thanks a lot.

    Any help would be very valuable.


    • Edited by AnaCris_Aranda Wednesday, October 05, 2011 8:25 PM I found more issues
    Wednesday, October 05, 2011 4:03 PM
  • There is no solution. Microsoft simply wants you to explain your users that under the hood it's not really the same field as eg a publishing page, and Microsoft expects that your users will understand and live with it...
    Thursday, October 06, 2011 7:30 AM
  • Does anyone know if Microsoft have any plans to fix this in a future patch, or has it already been fixed?
    Thursday, March 22, 2012 12:02 AM
  • Is there a solution then to be able to add a link or a picture in an announcement, from SharePoint?

    Friday, June 01, 2012 9:25 AM
  • No solution from Microsoft yet.

    I haven't found any solution to work around this. I simply tell my users that it's a bug that Microsoft doesn't want to fix, and then show them how to find the URL of a picture in a second screen to use in the editor. They really dislike that approach, but they blame Microsoft, not me.

    Friday, June 01, 2012 10:40 AM
  • I have seen this happening when the page resides at site root such as default.aspx (even the publishing feature is activated.). Read the analysis here. The page should belong to some library.

    Tuesday, June 19, 2012 4:37 PM
  • I found a solution that fixed this problem for me.

    Add the 'Page Image column to your list (remove it from the default view). The insert from SharePoint button shouldnt be greyed out anymore.

    Greetz.

    • Marked as answer by kurtvd Thursday, September 27, 2012 8:17 AM
    Thursday, September 27, 2012 8:06 AM
  • The problem is not related to a page being at the root or in a library. We're talking about list items here, not pages.


    I've tested it with the Page Image column, and it does seem to work.

    But I still disagree that this is a normal solution to this.
    You shouldn't need to add some dummy column in order to get this working.
    But it is by far the easiest solution to get this solved. Thanks for posting it here.

    Thursday, September 27, 2012 8:16 AM
  • I agree, its a dirty fix. But it works and there is no need for the  SharePoint Server Publishing feature to be enabled by the way.

    This 'fix' works also when the Publishing feature is disabled.

    Thursday, September 27, 2012 8:24 AM
  • Nils, thanks for the suggestion, but this did not fix the issue for me. Do you have any other ideas?

    Dean


    Dean MCTS-SQL 2005 Business Intelligence, SharePoint 2010, Configuration

    Wednesday, January 16, 2013 1:32 PM
  • If you add an existing column to the list, you can add an the publishing field called Page Content to the list.  Once it is added, you can change the name if you want.  It will now allow you to insert images from SP.

    You don't have to add the content type to the list, just the column.

    Thursday, April 18, 2013 10:46 AM