none
Problems with Top Link Bar Navigation after disabling Publishing feature

    Question

  • Hi:

    I have some problems trying to edit/delete a Navigation Link in the Top Link Bar of my site. The problem was related to activate/deactivate the SharePoint Server Publishing Infrastructure feature in the Site Collection. The steps I followed were:

    1. Create a site collection with the My Sites Host template. By default, the SharePoint Server Publishing Infrastructure feature is not activated.

    2. I create two Navigation Links in the Top Link Bar on the Site Settings --> Look & Feel --> Top Link Bar option.

    3. I activate the SharePoint Server Publishing Infrastructure feature in my site collection. Now, I don't see the Top Link Bar option in the Site Settings, that is correct.

    4. I deactivate the SharePoint Server Publishing Infrastructure feature in my site collection. The Top Link Bar option appears again in the Look & Feel section of the Site Settings, but when I select it, it only shows the default options and my two new Navigation Links are missing from this section. Therefore, I don't have any option to edit or delete them.

    However, the links that I added are shown in the top level navigation all the time, and they are fully functional.

    Do you have any idea how to edit/remove those two links? Or how to make them appear again on the Top Link Bar option of the Site Settings?

    Regards,

    Gustavo

    ----------------------

    Some updates on this issue:

    1. I have reviewed the NavNodes table in my content database, and these two options don't appear there. However, they still appear to the users at the top of the pages.

    2. We restarted the IIS in the server, and now we are seeing these two options duplicated!! It seems that these options have been stored in some sort of cache and they are retrieved every time the Web application is recompiling.

    Regards,

    Gustavo

    Wednesday, April 13, 2011 11:27 PM

Answers

  • Hi Gustavo, there is another way to admin these top links. Just go to:

    Central Administration -> Manage Service Applications -> User Profile Service Application -> Configure Personalization Site

    In this section you can add/delete/edit Top Link bar items. These items are stored in SharedListSync table, under Profiles DB.

     

     

    Monday, May 16, 2011 5:15 PM

All replies

  • When you turn on "SharePoint Server Publishing Infrastructure" feature it turns off "Top Link Bar" but gives you a new link for "Navigation".  After publishing features are turned on you use this Navigation to change the top link bar.  If you click on the link on 'Navigation' you will see an area which is labled Globel navigation this is where you place the link for the area above your sites page.

    Here is a link which should help you understand what the sections of the Navigation area are.

    http://corylangner.wordpress.com/2010/02/15/customizing-global-navigation-in-sharepoint-2010/

    Good luck,
    Gary


    Gary Newman MCSE, MCT, CCNA MCDBA, MCAD, MCSA MCTS SharePoint 2007 Dev & Admin MCPD SharePoint 2010 Development
    Thursday, April 14, 2011 12:24 AM
  • Thanks Gary, that's the expected behavior when the Publishing feature is on. However, my problem is that I activated it and then deactivated it (because I don't need it) and now in the Top Link Bar I can't edit or delete the two custom links that I added before I activated the feature. Those links still appear in the navigation to the users, but as an administrator I have no longer control over those. What should I do to edit/remove those two links?

    Regards,

    Gustavo

    Thursday, April 14, 2011 3:44 AM
  • Did you try removing them with the Navigation link?

     

    Good luck,

    Gary


    Gary Newman MCSE, MCT, CCNA MCDBA, MCAD, MCSA MCTS SharePoint 2007 Dev & Admin MCPD SharePoint 2010 Development
    Thursday, April 14, 2011 4:01 AM
  • Yes, I tried that, but they don't appear there either. The only options that I see in Global Navigation are the defaults of the My Sites Host template: My Newsfeed, My Content and My Profile. I can't see the two custom links I created before I activate the Publishing feature.

    Regards,

    Gustavo

    Thursday, April 14, 2011 4:08 AM
  • Hi Gustavo,

    did you try remove them with publishing on and then switch off publishing and add them manually by Top Link Bar option?

    Rado


    Radoslav Sopon
    Thursday, April 14, 2011 7:43 AM
  • Yes Rado, I've tried with publishing off (through the Top Link Bar) and with publishing on (through Navigation) but in both cases I've only seen the original default links and not the new ones I added before.

    Regards,

    Gustavo

    Thursday, April 14, 2011 1:29 PM
  • What if you clear the SharePoint cache followed the reference below.
    http://support.microsoft.com/kb/939308

    Thanks & Regards.

    • Proposed as answer by geordie tom Wednesday, January 02, 2013 2:55 PM
    Thursday, April 21, 2011 1:38 AM
  • Thanks Lily. I've just tried it but it didn't solve the problem.

    Regards,

    Gustavo

    Sunday, April 24, 2011 1:47 AM
  • Hi Gustavo, there is another way to admin these top links. Just go to:

    Central Administration -> Manage Service Applications -> User Profile Service Application -> Configure Personalization Site

    In this section you can add/delete/edit Top Link bar items. These items are stored in SharedListSync table, under Profiles DB.

     

     

    Monday, May 16, 2011 5:15 PM
  • Excellent Víctor, I found my missing links in that option. Now I can edit them !!!!

    But, I don't know when or how those links get into that option and dissappeared from my Top Link Bar option. Anyone knows the objective of this option under User Profile Application?

    Monday, May 16, 2011 5:23 PM