none
SharePoint 2010 application pool run on .net framework 4.0

    Question

  • After I switch the SharePoint 2010 web application pool running on .NET Framework from v2.050727 to v4.030319,  the Sharepoint site stopped working. The error message says,

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Any one has idea about this issue?

    Thanks in advance,

    Peter 

       

    Tuesday, June 01, 2010 1:28 PM

Answers

  • After I switch the SharePoint 2010 web application pool running on .NET Framework from v2.050727 to v4.030319,  the Sharepoint site stopped working. The error message says,

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Any one has idea about this issue?

    Thanks in advance,

    Peter 

       


    SharePoint 2010 uses .NET Framework 3.5, not 4.0.   The SharePoint 2010 app pools should be configured as .NET Framework 2.0 using the Integrated Pipeline Mode.

    Regards,

    Tom Brownell


    Tom Brownell KnowledgeLake, Inc.
    • Marked as answer by peterxw Tuesday, June 01, 2010 7:40 PM
    Tuesday, June 01, 2010 2:28 PM