locked
Upgraded to IE8, now sharepoint giving errors, no lists, drop-downs working

    Question

  • Hi, several machines on our network(  xp and 7) have upgraded to IE8 and they're all getting the same errors.
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Timestamp: Wed, 18 Jan 2012 16:27:20 UTC


    Message: Object expected
    Line: 339
    Char: 47
    Code: 0
    URI: http://isteach/Pages/default.aspx


    Message: '_spBodyOnLoadFunctionNames' is undefined
    Line: 1705
    Char: 1
    Code: 0
    URI: http://isteach/Pages/default.aspx


    Message: 'WPSC' is undefined
    Line: 1740
    Char: 1
    Code: 0
    URI: http://isteach/Pages/default.aspx

    As a result no lists or drop-downs work, i.e  Employee Lookup,  Site actions etc.

     

     Has anyone experienced this in Sharepoint 2007? Unsually it works fine in IE9, but can't use this solution for XP machines!


    • Edited by Mike Walsh FIN Thursday, January 26, 2012 2:11 PM SP 2010 comment at best irrelevant and certainly off-topic
    Wednesday, January 18, 2012 4:33 PM

Answers

  • Eventually I found my solution!! In IIS my  _Layouts application folder was set to the wrong version of  ASP .net, instead of being 2  it was 1.1, no idea how that happened as all the other folders had the correct version...some update or something must of changed it. I was distracted by the fact that I wasn't getting the errors in IE7 and IE9 when in fact it was nothing to do with the browser. Anyway thank you for your contribution I hope this might be of help to someone else!
    • Marked as answer by Cacmd Thursday, January 26, 2012 12:23 PM
    Thursday, January 26, 2012 12:23 PM

All replies

  • Are you using a custom site template? I am curios if you have the same problem on a SharePoint OOB site, without customizations.


    MCITP|MCTS SharePoint| SharePoint Performance blog
    Wednesday, January 18, 2012 7:43 PM
  • Hi,

    Try removing debugging of scripts from your browser settings nad then observe the same.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Wednesday, January 18, 2012 8:14 PM
  • the javascript may be disabled in your IE8 browser. Add that sharepoint site in trusted site list. Then the script might work fine. Its my guess try it!
    Thanks, Saravanan PRS
    Thursday, January 19, 2012 9:14 AM
  • I've hada similar issue when upgrading to IE8. I haven't tracked down the exact cause but I believe it's something to do with a difference in the effect certain security settings have between the browser versions. I just don't know which settings.

    I have been able to resolve the issue for affected browsers by going to Tools->Internet Options->Advanced and resetting all of the settings to their default.

    Thursday, January 19, 2012 10:37 AM
  • You try running Microsoft Office Diagnostics tools and restart your machine. I have seen a similar post where it worked


    MCITP|MCTS SharePoint| SharePoint Performance blog
    Saturday, January 21, 2012 9:47 AM
  • Hi all, Thanks for your replies, I tried changing security settings, office dianostics, added as a trusted site, disabled debugging, but still no luck! It is a custom style-sheet which I'm reluctant to edit as it works perfect in other browers. It's really annoying because we use alot of Lists and users with this problem can't even open them, they just see the collapsed view.  I know an upgrade to IE 9 will work but obviously I can't upgrade xp machines to IE9!
    Tuesday, January 24, 2012 2:19 PM
  • Eventually I found my solution!! In IIS my  _Layouts application folder was set to the wrong version of  ASP .net, instead of being 2  it was 1.1, no idea how that happened as all the other folders had the correct version...some update or something must of changed it. I was distracted by the fact that I wasn't getting the errors in IE7 and IE9 when in fact it was nothing to do with the browser. Anyway thank you for your contribution I hope this might be of help to someone else!
    • Marked as answer by Cacmd Thursday, January 26, 2012 12:23 PM
    Thursday, January 26, 2012 12:23 PM