none
Connecting with Outlook fails with “Cannot start Outlook”

    Question

  • When i click the button 'Connect with Outlook' (in the action menu) in IE8 i get the following error:

    "Cannot start Microsoft Outlook"

    The regular security question of IE pops up, the one about opening a program on my PC, listing the stssync-url, which i accept. Then the error is displayed. Just that text, no error code.

    When I cut'n'paste the stssync-url out of the security question and paste it in start->run.. Outlooks starts fine and is able to connect to the list.

    This just started happing, i was able to connect to lists. I don't rememeber changing anything. I've seen this strange behaviour on multiple pc's now.

    What is preventing my outlook from starting from sharepoint?

    System: Vista & Office 2007 & IE8 & WSS3.0
    Already tried:

    • Disable and enable STSsync plugin in IE
    • Repair Office
    • Enabled Outlook logging (no hints)

     

     

    Friday, January 08, 2010 10:28 AM

Answers

  • I uninstalled IE8 (thus reverting back to IE7) and everything works fine again. Weird. Probably this is a IE/Outlook issue and not a SharePoint issue.
    Wednesday, January 13, 2010 10:58 AM

All replies

  • Hi,

     

    Start Outlook in Safe mode (Click Start > Run type: Outlook.exe /safe ), browse to the Calendar List and synchronized with Outlook and check the effect.

     

    Do you see the issue when you link to the WSS 3.0 Calendar from another machine that has never connected to the Calendar list before? Or delete current Outlook profile, recreate a new one, and check the effect.

     

    How to create and configure an e-mail profile in Outlook 2007 and Outlook 2003

    http://support.microsoft.com/kb/829918

     

    Are your Outlook working in cached mode? If so, change to online mode, and check the effect.

     

    Try to enable SharePoint synchronization logging by utilizing the following registry:

     

    Key: HKCU\Software\Microsoft\Office\12.0\Outlook\Options\Mail

    DWORD: EnableWSSSyncLogging

    Values: 1 = logging enabled.

     

    And then open the SharePoint site, navigate to the calendar, click Action-Connect to Outlook, you can find the SharePoint synchronization log files in the %Temp% folder and they have the following naming convention:

     

    #-wss-sync-log.htm

    {UID}-#-wss-response.xml

    {UID}-#-wss-syncitems.xml

    {UID}-#-wss-errors.xml

     

    Post the information in #-wss-sync-log.htm into the forum for further research.

     

    Also, you can refer to the following article:

     

    http://hosting.intermedia.net/support/kb/default.asp?id=1130

     

    http://blogs.technet.com/dblanch/archive/2009/10/13/using-sharepoint-with-your-outlook-client.aspx

     

    Hope this helps.

     

    Rock Wang


    Rock Wang– MSFT
    Monday, January 11, 2010 7:19 AM
  • Hi Thanks for the reply. I'll list the effects of each step:

    • Start Outlook in safe mode. No effect.
    • New Profile: No effect
    • I'm not aware of any 'chaced mode' in my Outlook (can't even find the setting)
    • I enabled WSSSynLogging. No error or what so ever shows up. Already connected list do sync fine. Creating a new connection isn't even shown in de log. Not in de WSS SyncLog, not in the Outlook Diagnostics Logging.
    • Both articles listed steps I already tried.
    Update:
    Hmm, the problem seems to be much worse: Outlook won't start either when clicking on mailto: links. This seems to berelated: http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/623ae39a-64ba-4616-bb00-d2e0e166818b

    Something in Outlook is wrong, when invoked from IE8. (Statring from shell/command prompt with mailto: and stssync: works fine)
    Wednesday, January 13, 2010 8:49 AM
  • I uninstalled IE8 (thus reverting back to IE7) and everything works fine again. Weird. Probably this is a IE/Outlook issue and not a SharePoint issue.
    Wednesday, January 13, 2010 10:58 AM