none
Event ID 3760

    Question

  • I am getting an error ID 3760 in my event logs that says "SQL Database 'Search_Service_Application_1_CrawlStoreDB_55a98f2fe04d4a0f87fed18d8d219b8a' on SQL Server instance xxxxxxxxx\xxxxxxxxx not found. Additional error information from SQL Server is included below.

    Cannot open database "Search_Service_Application_1_CrawlStoreDB_55a98f2fe04d4a0f87fed18d8d219b8a" requested by the login. The login failed.
    Login failed for user xxxxxxx"

     

    I originally created this search service application named Search Service application 1, but removed it along with the database. At a later time I created a new search service application with the same name, (which is working fine) for some reason it is still trying to access the old db.

     

    Can someone let me know how to stop sharepoint from trying to access this non exsistant db?

     

    thanks



    Thursday, July 28, 2011 4:28 PM

All replies

  • When you removed the search service application do you delete all of the search databases, before recreating it?
    Simon Rennocks | SharePoint 2010 MCITP & MCPD | Blog | LinkedIn
    Thursday, July 28, 2011 5:24 PM
  • Yes, I checked the box that said remove database, or something like that. I don't recall the exact wording, but it deleted the service and the database. I guess I don't know if there were other databases associated with it, but I just let SharePoint handle it. I didn’t' delete any db manually

    Thursday, July 28, 2011 5:36 PM
  • You will want to check that the other search databases were removed too, manually.
    Simon Rennocks | SharePoint 2010 MCITP & MCPD | Blog | LinkedIn
    Thursday, July 28, 2011 5:38 PM
  • do you know what they are? I see databases that refer to my search service, but how do I know they are refering to the old or new, being I used the same name?
    Thursday, July 28, 2011 5:57 PM
  • They should be named like:

     

    Search_Service_Application_CrawlStoreDB_[GUID]

    Search_Service_Application_DB_[GUID]

    Search_Service_Application_PropertyStoreDB_[GUID]


    Simon Rennocks | SharePoint 2010 MCITP & MCPD | Blog | LinkedIn
    Thursday, July 28, 2011 6:18 PM
  • what I have is:

    Search_Service_Application_1_CrawlStoreDB_d2285b7eef994d30ba07f56b394bf524

    Search_Service_Application_1_DB_cb1f5ea6c6d44b058d47be80ccf91b27

    Search_Service_Application_1_PropertyStoreDB_eae378145cbf4ce19db1b35a2ae1628

     

    Which I assume are for the working search service. The GUID listed in the error does not exist, but for some reason something is trying to access it, and  generating the error. When I deleted the original search service, some part of it must not have been removed.

    Friday, July 29, 2011 1:19 PM
  • Did you ever find a work arround for this? I deleted my search application, but not the DBs. Recently when I moved all my DBs to a new server, I did not bring the old ones. I can't imagine why sharepoint is looking for them.
    Willner001
    Monday, December 05, 2011 3:56 PM