none
SharePoint default page not loading (WSS3)

    Question

  • Hi all,

    I seem to have an annoying little problem after installing WSS 3.0. I find that I can't browse SharePoint 80 or SharePoint Central Administration v3 using the URL (http://webserver/) - webserver is the name of the server. Im trying to do this locally from the actual server WSS is running on. It gives a HTTP 404 'Webpage cannot be found' error in IE. If I want to view either of these I have to specifically type:

    http://webserver/default.aspx to view the SharePoint 80 site and..
    http://webserver:port/default.aspx to view central admin.

    It is the same when using localhost instead of webserver. I again will have to enter default.aspx to cring the pages up.

    Here are some things I've tried already but had no luck:

    * Added http://webserver and other relavant names in Alternate Access Mappings
    * Ensured Default.aspx is top of the list in 'Default Documents' in IIS7
    * Checked the hosts file
    * Set DisableloopbackCheck in registry and restarted.

    One thing to note is that this server is running 2 other web services also in IIS. I'm not sure if this would cause any issues.

    Has anyone seen this behaviour before and know how to fix it? Any help that can be given would be highly appreciated.

    Thanks.
    Mehds
    Wednesday, January 13, 2010 7:01 PM

Answers

  • If you're still interested, I just ran into almost the exact same issue as you're describing. Here's what I was working with:

    • WSS v3 Server: Windows Server 2008 R2. SQL Server 2008 SP1 Client Tools installed to create a SQL Alias
    • SQL 2008 SP1 Server: Windows Server 2008 R2. SQL Server 2008 SP1 instance to host databases

    I installed WSS v3 on the server and ran the Config Wizard. The config wizard did not report any errors and once it finished it attempted to open the Central Admin site in IE. I was shown a log in screen, and once I provided the credentials of the farm account, I received a 404 error. I tried adding the site to the Trusted Sites list, then the Intranet sites list, both resulting in errors. I tried logging into the CA site from the SQL host (to see if it was the LoopbackCheck error), and got the same error, even after adding it to the Trusted and Intranet sites lists.

    I tried creating a new SharePoint web application and site collection via STSADM, it also displayed a 404 error after authentication. I checked permissions in the file system (12 hive, Inetpub), as well as in SQL, everything was as it should be.

    I tried re-running the config wizard, no luck. I tried uninstalling WSS and re-installing it, no luck. I tried uninistalling WSS, removing the Web Server (IIS) role from the server, adding it back and re-installing, no luck.

    I tried a lot of stuff that didn't work, but I finally got it to work. The problem was the fact that I had manually added the Web Server (IIS) role to the server, and had apparently either selected some options that conflict with SharePoint or left them out. I fixed this but once again uninstalling WSS and removing the Web Server role from the server, then running the WSS installer without manually adding the Web Server role. Once the config wizard finished, the Central Administration site prompted me for authentication and once I logged in it opened w/o error.

    All in all, very frustrating, in that there were no errors in the server event logs or in the SharePoint error logs, even with Verbose logging enabled. The IIS logs showed a 401 error that led to the prompt for authentication, followed by a 404 error because the page could not be found, but gave no further indication of the issue. I enabled Failed Request Tracing in IIS (which is pretty cool, btw), but it didn't show anything beyond the 404 file not found error. I even checked the source of the 404 error page and saw an HTTPException in System.Web.Util.FileUtil.CheckSuspiciousPhysicalPath, but that was of little help.

    The lesson I'm taking from this is: if you're installing SharePoint 2007 on a fresh Windows Server 2008 or 2008 R2 build, let the installer configure the server roles it needs for you. If you're putting it on a server with the roles already enabled, very carefully review everything enabled on it to ensure that you don't have any conflicts with what SharePoint does and does not need enabled!

    John


    MCTS: WSS v3, MOSS 2007, and SCOM 2007

    Now Available on Amazon - The SharePoint 2007 Disaster Recovery Guide.
    • Marked as answer by msib7 Tuesday, March 30, 2010 10:02 AM
    Monday, March 08, 2010 6:57 PM

All replies

  • Have you tried running the configuration wizard again?   I wonder if something is wrong with SharePoint's ISAPI filter.   Do you have anything specified in the http redirect section for your site in IIS 7?  Was this a restored site?

    I would back up your content db's and recreate the farm, then restore the content.  Hopefully this is a brand new environment.

    Wednesday, January 13, 2010 7:46 PM
  • Hi Andrew, thanks for your reply and ideas. I will try running the configuration wizard again but I don't think it'll make a difference as I've done a fresh install twice with the same result. Also, it's not a restored site......yet. It has this behaviour soon as I install WSS 3.0. Even when I do restore a site (successfully) the behaviour continues. I will have a look at the ISAPI filter and redirect section of IIS and then get back here.
    Wednesday, January 13, 2010 9:54 PM
  • >I can't browse SharePoint 80 or SharePoint Central Administration v3 using the URL (http://webserver/)

    Windows Firewall settings on the server ?

    To see if that's it, temporarily turn off the service. If you can then access your site you can turn the service back on and fine tune.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Thursday, January 14, 2010 4:36 AM
  • Hi Mike, thanks for your suggestion. I tried switching it off but the problem remains.
    Thursday, January 14, 2010 9:30 AM
  • Thanks Ivan for the link. I tried the registry setting for the loopback problem before but it didnt help unfortunately.
    Thursday, January 14, 2010 9:31 AM
  • ok, you probably need to add Default.aspx to the "Default documents" list in IIS. In IIS6 it is in WebSite properties->Documents
    sometimes it's not updated automatically
    Thursday, January 14, 2010 10:37 AM
  • Thanks Ivan, I've tried that too but it still won't load the page automatically. It keeps giving the 404 not found error. Any more thoughts?
    Thursday, January 14, 2010 10:47 AM
  • Hi, I've had a look at the ISAPI filters. I have 2 entries:

    * ASP.Net_2.0.50727.0
    * ASP.Net_2.0.50727-64

    I've not really delved into ISAP filters before so not sure how these would be causing the problem. Also, I dont have the http redirect role installed on the server. Should it be installed?



    Thursday, January 14, 2010 11:03 AM
  • Ok, I've tried removing and re-applying the ISAPI filters also but the problem remains. In addition, I've tried accessing the site from a remote computer but the default.aspx still doesn't load automatically.

    Anyone have any other ideas? Any thoughts are welcome.
    Friday, January 15, 2010 2:28 PM
  • Could you please look into IIS logs to find how it is processing your requests?
    Friday, January 15, 2010 3:11 PM
  • Hi again,

    Okay I have the IIS logs. They are below. I seem to be getting 401 2 and 404 4 errors which mean that 'Access is denied due to server configuration favoring an alternate authentication method.' and 'No handler was found to serve the request.' respectively.

    Error codes are here if anyone needs them:
    http://www.iisworkstation.com/2008/06/troubleshooting-iis-6-status-and.html

    Has anyone resloved these types of error before?

    ===================================================================================================================

    Logging on to admin site as domain user (http://webserver:16945):
    2010-01-18 09:20:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 401 2 5 1
    2010-01-18 09:20:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 NT+AUTHORITY\LOCAL+SERVICE 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 200 0 0 35
    2010-01-18 09:20:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 NT+AUTHORITY\LOCAL+SERVICE 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 200 0 0 3
    2010-01-18 09:21:12 127.0.0.1 GET / - 16945 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 401 2 5 434
    2010-01-18 09:21:23 127.0.0.1 GET / - 16945 DOMAIN\myusername 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 404 4 2 63

    Logging on to admin site as local admin user (http://webserver:16945):
    2010-01-18 09:25:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 401 2 5 0
    2010-01-18 09:25:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 NT+AUTHORITY\LOCAL+SERVICE 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 200 0 0 34
    2010-01-18 09:25:24 127.0.0.1 POST /_vti_bin/sitedata.asmx - 16945 NT+AUTHORITY\LOCAL+SERVICE 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4200) 200 0 0 4
    2010-01-18 09:27:22 ::1 GET / - 16945 - ::1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 401 2 5 36
    2010-01-18 09:27:22 ::1 GET / - 16945 WEBSERVER\Administrator ::1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 404 4 2 0

    Logging on to admin site as local admin user (http://localhost:16945):
    2010-01-18 09:27:33 ::1 GET / - 16945 - ::1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 401 2 5 2
    2010-01-18 09:27:33 ::1 GET / - 16945 WEBSERVER\Administrator ::1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 404 4 2 0
    2010-01-18 09:27:47 127.0.0.1 GET / - 16945 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 401 2 5 0
    2010-01-18 09:28:06 127.0.0.1 GET / - 16945 webserver\administrator 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.21022;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 404 4 2 14

    ===================================================================================================================
    Monday, January 18, 2010 10:07 AM
  • Hi misib7,

     

    From the HTTP status codes, we know the following information:

     

    404 - Not found. 404.0 - (None) – File or directory not found.

     

    404.4 - No Handler (IIS 7)

     

    It seems that some WSS server files are corrupted. You can try to perform the following steps to fix the issue:

     

    1.       Back up the database before repairing the WSS.

     

    2.       Repair WSS server, then run configuration wizard, check the effect.

     

    If the steps above can’t resolve your issue, back up the database, uninstall the WSS v3 and IIS, then install IIS, next install WSS V3, after that run Configuration wizard, restore the database, finally check the effect.

     

    For more information about how to repair WSS server, please refer to the following articles:

     

    To repair the Windows SharePoint Services installation

    http://technet.microsoft.com/en-us/library/cc560963.aspx

     

    Setup.exe command-line reference (Windows SharePoint Services)

    http://technet.microsoft.com/en-us/library/cc288033.aspx

     

    For more information about how to restore database, please refer to the following article:

    Restore: Stsadm operation (Windows SharePoint Services)

    http://technet.microsoft.com/en-us/library/cc288929.aspx

     

    Hope this helps.

     

    Rock Wang


    Rock Wang– MSFT
    • Marked as answer by Rock Wang– MSFT Friday, January 22, 2010 9:23 AM
    • Unmarked as answer by msib7 Friday, January 22, 2010 9:41 AM
    Friday, January 22, 2010 3:45 AM
  • Check this blog

    http://prequest01.wordpress.com/2008/11/27/unable-to-open-sharepoint-sites-without-defaultaspx/

    Do you have coldfusion installed on th server?
    Friday, January 22, 2010 5:02 AM
  • Hi Rock,

    Thanks for the details and links. I've already tried multiple times a complete uninstall and fresh install of WSS3 including detaching and removing any remaining databases and deleting any remnants of WSS3 (even including the Microsoft Internal Database). I'm pretty sure this is an IIS configuration problem when there are exisiting sites on the server prior to installing WSS. If I install it on a server with no other sites, the default.aspx page loads itself fine. I've just tried to repair the installation as suggested but unfortuantely no luck with it. 

    I guess I will have to try an uninstall and reinstall of IIS but prefer to leave it as a last resort as the other sites are using it currently. I'll see what I can do about it.
    Friday, January 22, 2010 9:55 AM
  • Hi Hema,

    Thanks for this link. I've actually already come accross it. Took me while to associate it's aspects with IIS7, but in the end it didn't resolve the problem.

    There is no coldfusion running on this particular server. Any more ideas?
    Friday, January 22, 2010 9:59 AM
  • If you're still interested, I just ran into almost the exact same issue as you're describing. Here's what I was working with:

    • WSS v3 Server: Windows Server 2008 R2. SQL Server 2008 SP1 Client Tools installed to create a SQL Alias
    • SQL 2008 SP1 Server: Windows Server 2008 R2. SQL Server 2008 SP1 instance to host databases

    I installed WSS v3 on the server and ran the Config Wizard. The config wizard did not report any errors and once it finished it attempted to open the Central Admin site in IE. I was shown a log in screen, and once I provided the credentials of the farm account, I received a 404 error. I tried adding the site to the Trusted Sites list, then the Intranet sites list, both resulting in errors. I tried logging into the CA site from the SQL host (to see if it was the LoopbackCheck error), and got the same error, even after adding it to the Trusted and Intranet sites lists.

    I tried creating a new SharePoint web application and site collection via STSADM, it also displayed a 404 error after authentication. I checked permissions in the file system (12 hive, Inetpub), as well as in SQL, everything was as it should be.

    I tried re-running the config wizard, no luck. I tried uninstalling WSS and re-installing it, no luck. I tried uninistalling WSS, removing the Web Server (IIS) role from the server, adding it back and re-installing, no luck.

    I tried a lot of stuff that didn't work, but I finally got it to work. The problem was the fact that I had manually added the Web Server (IIS) role to the server, and had apparently either selected some options that conflict with SharePoint or left them out. I fixed this but once again uninstalling WSS and removing the Web Server role from the server, then running the WSS installer without manually adding the Web Server role. Once the config wizard finished, the Central Administration site prompted me for authentication and once I logged in it opened w/o error.

    All in all, very frustrating, in that there were no errors in the server event logs or in the SharePoint error logs, even with Verbose logging enabled. The IIS logs showed a 401 error that led to the prompt for authentication, followed by a 404 error because the page could not be found, but gave no further indication of the issue. I enabled Failed Request Tracing in IIS (which is pretty cool, btw), but it didn't show anything beyond the 404 file not found error. I even checked the source of the 404 error page and saw an HTTPException in System.Web.Util.FileUtil.CheckSuspiciousPhysicalPath, but that was of little help.

    The lesson I'm taking from this is: if you're installing SharePoint 2007 on a fresh Windows Server 2008 or 2008 R2 build, let the installer configure the server roles it needs for you. If you're putting it on a server with the roles already enabled, very carefully review everything enabled on it to ensure that you don't have any conflicts with what SharePoint does and does not need enabled!

    John


    MCTS: WSS v3, MOSS 2007, and SCOM 2007

    Now Available on Amazon - The SharePoint 2007 Disaster Recovery Guide.
    • Marked as answer by msib7 Tuesday, March 30, 2010 10:02 AM
    Monday, March 08, 2010 6:57 PM
  • Hi John, many thanks for providing this insight for me. Yes definately still interested. It could be the resolution I've been looking for :) Microsoft have been working on it (and still are) since the end of January. We've tried all sorts. At the moment we have another live site on the server we have sharepoint installed so I'll have to organise some downtime before trying it out. I'll certainly post back here with the results as soon as I've prepared everything and tried it.

    Many thanks again!

    Mehds
    • Proposed as answer by armibewob Wednesday, March 24, 2010 8:30 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, March 24, 2010 9:04 AM
    Thursday, March 11, 2010 4:00 PM
  • Hi,

    I recently had the same problem. I think it started because I was messing around with the Sharepoint website in IIS directly which Sharepoint doesn't seem to like.

    I managed to fix this by removing the website from IIS using 'Remove SharePoint from IIS Web site' in Central Administration then recreating it using 'Create or extend Web application'. After i had done this I could browse directly to the site without specifying default.aspx.

    Hope this helps.

     

    • Proposed as answer by armibewob Wednesday, March 24, 2010 8:35 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, March 24, 2010 9:05 AM
    Wednesday, March 24, 2010 8:35 AM
  • armibewob:

    Please don't propose your own posts as answers. It isn't helpful.

    propose the good answers of other people but wait until someone else proposes your post.

    (Moderator)

    (The post from msib7 you also proposed as an answer, certainly was not an answer)

     


    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Wednesday, March 24, 2010 9:06 AM
  • Mike,

    RE: proposed answer, sorry, I must have mis-clicked.

    Tuesday, March 30, 2010 10:05 AM
  • Hi John,

    I think your were right about this. MS support came back to me and it turned out there was
    an issue with IIS. Somehow the handler mapping for 'wildcard' broke. The
    easiest fix was to add my own 'Wildcard Script Map' with the details:

    Path: *
    Executable: <path to aspnet_isapi.dll>
    Name: any name you want

    Proper fix would be to reinstall IIS but wasnt possible for me as I had live
    sites on this server.

    Thanks all.

    Mehds

    Tuesday, March 30, 2010 10:10 AM
  • Mehds,

     I need your help desesperatly!! :(

     I'm facing the same problem that you described above, but I don't know how to proceed with this 'new' "Wildcard Script Map". Can you help me??

     My WSS pages doesn't work with http://server_name! Only with http://server_IP/default.aspx!! :(

    Tuesday, June 01, 2010 6:38 PM
  • Hi,

     

    Ok try the following:

     

    1) Open IIS7 and on the left pane, expand your 'SERVERNAME' connection. Under that, expand 'Sites'

    2) Click on the site that is having the issue (for me it was 'SharePoint - 80' and 'SharePoint Central Administration v3')

    3) In the Features View for the site you just clicked on, double click on 'Handler Mappings'

    4) Right-click under the list of existing mappings and in the menu that appears select 'Add Wildcard Script Map'

    5) In 'Request Path' put *

    6) In 'Executable' put the path and filename of your isapi dll. For me it was this: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll

    7) In 'Name' put whatever you want to call it e.g. ASP Wildcard Map

     

    *Remember you have to add this mapping to each site your having problems with. So for me it was 'SharePoint - 80' and 'SharePoint Central Administration v3'.

     

    Then give it another go. Hopefully all will be well. If not, try reset IIS then try it again.

    Hope that helps.

    Wednesday, June 02, 2010 8:06 AM