none
Item level permissions in SharePoint list

    Question

  • Hello,

     

    I have created a SharePoint list and granted “contribute” access to it also I have done the below setting under List advance settings -> Item level permissions and enabled the below

     

    Read access:   ALL

    Edit access:   only their item

     

    With the above settings the users are able to edit all items which is not the expected as per my understanding,

     

    Please help…


    Manish

    • Moved by Mike Walsh FIN Friday, July 01, 2011 9:42 AM admin q not customization (From:SharePoint - Design and Customization (pre-SharePoint 2010))
    • Edited by M.Sharma Monday, July 04, 2011 2:05 PM
    Friday, July 01, 2011 8:44 AM

Answers

  • Thanks Prasath,

    Item level permissions works fine as set, the "Edit item" option made me confused which is always visible to edit any item (looks like a bug in SP). Though you can see the edit option with items created by others but still you are not allowed to edit them as you don’t have access.  User can find exact result when they try to save the item.

    Contribute access given at site level and list level works same.

    Thanks,

     


    Manish
    • Marked as answer by M.Sharma Monday, July 04, 2011 1:41 PM
    Monday, July 04, 2011 1:41 PM

All replies

  • Is the user given contribute permission at site level, this may override the permission in the list, try changing that to read only at site level and contribute at list level and try again.
    --Cheers
    Saturday, July 02, 2011 11:15 AM
  • Thanks Prasath,

    Item level permissions works fine as set, the "Edit item" option made me confused which is always visible to edit any item (looks like a bug in SP). Though you can see the edit option with items created by others but still you are not allowed to edit them as you don’t have access.  User can find exact result when they try to save the item.

    Contribute access given at site level and list level works same.

    Thanks,

     


    Manish
    • Marked as answer by M.Sharma Monday, July 04, 2011 1:41 PM
    Monday, July 04, 2011 1:41 PM