none
"Connect to Outlook" Disabled

    Question

  • Hi,

    I am not able to connect any SharePoint 2013 list or calendar to Outlook 2013.  When I select a SharePoint List Ribbon the "Connect to Outlook" button is always greyed out.  I am running Windows 8, IE 10, Outlook 2013 and SharePoint 2013 (Foundation).  IE and Outlook are 32-bit versions.  I am the site administrator and have full access to all the lists.

    Any suggestions would be appreciated.

    Thanks,

    Greg

    Wednesday, March 13, 2013 8:31 PM

Answers

  • The reason why the "Connect to Outlook" is greyed out, is because there is a feature called "Minimal Download Strategy". The feature redirect you to an application page start.aspx, do some validation, and loads start.js script. This add the "_layouts/15/start.aspx" in the URL wich seems to break the Connect To Outlook functionnality.

    To go arround this, you have 2 choice;

    1-Open you Calendar, Click the Calendar button in the top navigation bar, and go to "List Settings". (4 buttons right from the connecto to outlook)

    From there, copy the "Web Adress", and paste it in the adress bar of your browser.

    Then go to the Connect to Outlook, it shouldn't be greyed out anymore. It work for me on IE9 32bit with outlook 32 bits.

    2- Go to the site settings of your collection, then to Manage Site Features, and deactivate the Minimal Download Strategy" feature.

    The Minimal Download Strategy is actually a very good feature that you migh want to keep though as it makes most of the apps load faster.

    I still don't know why this breaks it, but I'll do more research on it.

    Let me know if this works for you as well.


    • Proposed as answer by JohnyLuky Friday, March 15, 2013 5:53 PM
    • Edited by JohnyLuky Friday, March 15, 2013 8:02 PM Updated with more relevant information
    • Marked as answer by gsshea Monday, March 18, 2013 5:35 PM
    Friday, March 15, 2013 5:52 PM
  • If the Connect to Outlook is not greyed out, then you could be getting an error. Is there any sort of error in the event log? if you get a change launch FireFox and do the same thing and see if you get a response. because sometimes what I have noticed is IE hides a lot errors and would be difficult to debug.


    Philip

    • Marked as answer by gsshea Thursday, March 14, 2013 9:42 PM
    Thursday, March 14, 2013 8:19 PM

All replies

  • You might want to check if the service is running


    Philip

    Wednesday, March 13, 2013 11:35 PM
  • Hi Philip,

    Thank you for your response.  Can you please confirm what service you are referring to and how I might check this status?

    Thanks again,

    Greg

    Wednesday, March 13, 2013 11:39 PM
  • One quick question, is the list custom list or a default task list. Custom list may have a problem.

    The services are located on your admin console "Manage Services on Server" will check out the exact server and let you know


    Philip

    Thursday, March 14, 2013 6:31 AM
  • On the default task list, "Connect to Outlook" is not greyed out but nothing happens when I click the button.  The "Connect to Outlook" is greyed out on all other lists and calendars (including contact lists).

    The following are the SharePoint Services on the server and the current status:

    • SharePoint Administration - Not Started - Manual
    • SharePoint Search Host Controller - Started - Automatic
    • SharePoint Server Search 15 - Started - Manual
    • SharePoint Timer Service - Started - Automatic
    • SharePoint Tracing Service - Started - Automatic
    • SharePoint User Code Host - Started - Automatic
    • SharePoint VSS Writer - Not started - Manual

    Greg

    Thursday, March 14, 2013 4:08 PM
  • If the Connect to Outlook is not greyed out, then you could be getting an error. Is there any sort of error in the event log? if you get a change launch FireFox and do the same thing and see if you get a response. because sometimes what I have noticed is IE hides a lot errors and would be difficult to debug.


    Philip

    • Marked as answer by gsshea Thursday, March 14, 2013 9:42 PM
    Thursday, March 14, 2013 8:19 PM
  • Hi, I have the exact same problem as gsshea, "Connect to Outlook, This control is currently disabled". My environement is a bit different; Windows 7 x64, Outlook 2013 32 bit, IE 9 32bit, SharePoint Enterprise 2013. Brand new install. I'm a Farm Administrator, Site Collection Administrator. Verified all the following:

    - Enable Client Integration in the Authentication Providers of the Web Application
    - Activated Offline Synchronization for External Lists in the Collection Site Features
    - All services are started
    - No errors or warning in the event logs

    I've been reserching this issue for a while and I'm running out of idea on what to verify next. Any suggestion is appreciated.

    Thursday, March 14, 2013 8:44 PM
  • I installed Firefox and restarted my computer.  I am now able to connect the default Task List to Outlook (awesome).  I'm not sure why other lists such as calendar and contacts cannot be connected (the "Connect to Outlook" is still greyed out).

    But progress has been made and thank you for your advice.  We now know that the connection can be made - unfortunately the system won't allow connections on most lists - not sure why?

    Any thoughts regarding the other lists?

    Thursday, March 14, 2013 9:41 PM
  • The reason why the "Connect to Outlook" is greyed out, is because there is a feature called "Minimal Download Strategy". The feature redirect you to an application page start.aspx, do some validation, and loads start.js script. This add the "_layouts/15/start.aspx" in the URL wich seems to break the Connect To Outlook functionnality.

    To go arround this, you have 2 choice;

    1-Open you Calendar, Click the Calendar button in the top navigation bar, and go to "List Settings". (4 buttons right from the connecto to outlook)

    From there, copy the "Web Adress", and paste it in the adress bar of your browser.

    Then go to the Connect to Outlook, it shouldn't be greyed out anymore. It work for me on IE9 32bit with outlook 32 bits.

    2- Go to the site settings of your collection, then to Manage Site Features, and deactivate the Minimal Download Strategy" feature.

    The Minimal Download Strategy is actually a very good feature that you migh want to keep though as it makes most of the apps load faster.

    I still don't know why this breaks it, but I'll do more research on it.

    Let me know if this works for you as well.


    • Proposed as answer by JohnyLuky Friday, March 15, 2013 5:53 PM
    • Edited by JohnyLuky Friday, March 15, 2013 8:02 PM Updated with more relevant information
    • Marked as answer by gsshea Monday, March 18, 2013 5:35 PM
    Friday, March 15, 2013 5:52 PM
  • Yes, this did work for me.  Thank you for the help.

    Greg

    Monday, March 18, 2013 5:35 PM
  • There is a third choice: If you refresh your screen that does the trick (at least for me): How to: Enable the “Connect to Outlook” grayed out/disabled button on SharePoint 2013 to synchronize your content


    Juan Carlos

    Sunday, March 31, 2013 9:52 PM
  • This solution also works for me, and its a lot better than disabling the minimal download strategy.

    Monday, April 01, 2013 11:26 AM
  • Thanks, worked for me
    Tuesday, April 30, 2013 8:59 AM
  • 1 worked for me.  Curious that on the my main publishing site there is no issue.

     
    Wednesday, January 22, 2014 1:12 PM
  • Same issue, solved it by:

    1. Adding the site to "Safe sites" zone in IE settings -> Security tab
    2. Maximizing the permissions for the "Safe sites" zone at the same tab.

    Suppose the security settings didn't allow the IE to interconnect with Outlook.

    • Edited by Firenzi Wednesday, April 30, 2014 7:56 AM
    Wednesday, April 30, 2014 7:55 AM
  • Hello, I know this post is over a year old but I just came across this issue in my environment and this post below totally solved it by copy/pasting the web address etc.!  Problem solved!  Thank you!  I did not disable the Minimal Download Strategy though as we will be migrating to SP365 next month and will deal with it then, but this helped me out now and to close a ticket!  Thank you!

    Joan

    Thursday, May 22, 2014 1:30 PM
  • Didn't work for me.  Turned off the feature but still could not connect calendar to outlook.  Turned the feature back on didn't make any difference.  The firefox browser method did work however.  Thanks Philip.
    Friday, May 23, 2014 7:03 PM