none
Error The tool was unable to install Application Server Role, Web Server IIS Role Last return code 0X41D=1053

    Question

  • I was trying upgrade SharePoint 2007 enterprise to SharePoint 2010 enterprise but during the install of the prerequisites I received an error SharePoint 2010 setup Application Server Role, Web Server (IIS) Role: configuration error. After the error the installation fails and I am able to look through an PrerequisiteInstaller.2011.03.17-20.01.57.log for details. I posted this log below.

     

    My System is Windows 2008 R2 64bit Enterprise and meet all hardware requirements.

     

    The  Application Server Role, Web Server IIS roles were already installed on the server because of SharePoint 2007.

     

    The user I am installing the software is a domain Admin and has full rights.

     

    I researched this error online for about 3 hours and got nowhere. Please let me know if you need any more details.

     

    2011-03-17 20:01:57 - Processor architecture is (9)

    2011-03-17 20:01:57 - Reading the following string value/name...

    2011-03-17 20:01:57 - Common Startup

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

    2011-03-17 20:01:57 - The value is...

    2011-03-17 20:01:57 - C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

    2011-03-17 20:01:57 - Trying to remove the startup task if there is any.

    2011-03-17 20:01:57 - C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\SharePointServerPreparationToolStartup_0FF1CE14-0000-0000-0000-000000000000.cmd

    2011-03-17 20:01:57 - Error: Startup task doesn't exist. This is not a continuation after a restart.

    2011-03-17 20:01:57 - Locating the following command line arguments file:

    2011-03-17 20:01:57 - D:\PrerequisiteInstaller.Arguments.txt

    2011-03-17 20:01:57 - Error: This file does not exist

    2011-03-17 20:01:57 - Details of the current operating system:

    2011-03-17 20:01:57 - Major version number of the operating system:  (6)

    2011-03-17 20:01:57 - Minor version number of the operating system:  (1)

    2011-03-17 20:01:57 - Build number of the operating system:  (0X1DB0=7600)

    2011-03-17 20:01:57 - Major version number of the latest Service Pack:  (0)

    2011-03-17 20:01:57 - Minor version number of the latest Service Pack:  (0)

    2011-03-17 20:01:57 - Platform ID of the operating system:  (2)

    2011-03-17 20:01:57 - Product suites available on the operating system:  (0X112=274)

    2011-03-17 20:01:57 - Product type of the operating system: VER_NT_DOMAIN_CONROLLER

    2011-03-17 20:01:57 - Product type:  (10)

    2011-03-17 20:01:57 - Configuring the application's property sheet...

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Hotfix for Microsoft Windows (KB976462)

    2011-03-17 20:01:57 - Reading version of the following file...

    2011-03-17 20:01:57 - C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\System.IdentityModel.dll

    2011-03-17 20:01:57 - The version is...

    2011-03-17 20:01:57 - 3.0.4506.4926

    2011-03-17 20:01:57 - Reading version of the following file...

    2011-03-17 20:01:57 - C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\System.ServiceModel.dll

    2011-03-17 20:01:57 - The version is...

    2011-03-17 20:01:57 - 3.0.4506.4926

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Windows Identity Foundation (KB974405)

    2011-03-17 20:01:57 - Reading the following string value/name...

    2011-03-17 20:01:57 -

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Windows Identity Foundation\Setup\v3.5

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft Sync Framework Runtime v1.0 (x64)

    2011-03-17 20:01:57 - Reading version of the following file...

    2011-03-17 20:01:57 - C:\Windows\assembly\GAC_MSIL\Microsoft.Synchronization\1.0.0.0__89845dcd8080cc91\Microsoft.Synchronization.dll

    2011-03-17 20:01:57 - GetFileVersionInfoSize failed (-2147024894)

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft Chart Controls for Microsoft .NET Framework 3.5

    2011-03-17 20:01:57 - Reading the following DWORD value/name...

    2011-03-17 20:01:57 - Install

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Wow6432Node\Microsoft\NET Framework Chart Setup\NDP\v3.5

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft Filter Pack 2.0

    2011-03-17 20:01:57 - Check for a subkey matching the following pattern...

    2011-03-17 20:01:57 - {*5140000-2000-****-1000-*000000FF1CE}

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft SQL Server 2008 Native Client

    2011-03-17 20:01:57 - Reading the following string value/name...

    2011-03-17 20:01:57 - Version

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI10\CurrentVersion

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft SQL Server 2008 Analysis Services ADOMD.NET

    2011-03-17 20:01:57 - Reading the following string value/name...

    2011-03-17 20:01:57 - DisplayVersion

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{68442820-C846-4E8A-8D53-EDEDD1511CDE}

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft Server Speech Platform Runtime (x64)

    2011-03-17 20:01:57 - Reading the following registry location...

    2011-03-17 20:01:57 - TypeLib\{D3C4A7F2-7D27-4332-B41F-593D71E16DB1}\A.0\0\win64

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - Microsoft Server Speech Recognition Language - TELE(en-US)

    2011-03-17 20:01:57 - Reading the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Speech Server\v10.0\Recognizers\Tokens\SR_MS_en-US_TELE_10.0

    2011-03-17 20:01:57 - Check whether the following prerequisite is installed:

    2011-03-17 20:01:57 - SQL 2008 R2 Reporting Services SharePoint 2010 Add-in

    2011-03-17 20:01:57 - Reading the following string value/name...

    2011-03-17 20:01:57 - Version

    2011-03-17 20:01:57 - from the following registry location...

    2011-03-17 20:01:57 - SOFTWARE\Microsoft\Microsoft SQL Server\Report Server SharePoint Addin\CurrentVersion

    2011-03-17 20:02:02 - Beginning download/installation

    2011-03-17 20:02:02 - Created thread for installer

    2011-03-17 20:02:02 - "C:\Windows\system32\ServerManagerCmd.exe" -inputpath "C:\Users\admin\AppData\Local\Temp\PreF392.tmp.XML"

    2011-03-17 20:02:03 - Install process returned (0X3EB=1003)

    2011-03-17 20:02:03 - [In HRESULT format] (0X800703EB=-2147023893)

    2011-03-17 20:02:03 - "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe" -i

    2011-03-17 20:02:03 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:03 - Install process returned (0)

    2011-03-17 20:02:03 - [In HRESULT format] (0)

    2011-03-17 20:02:03 - "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v2.0.50727"

    2011-03-17 20:02:04 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:05 - Install process returned (0)

    2011-03-17 20:02:05 - [In HRESULT format] (0)

    2011-03-17 20:02:05 - "C:\Windows\system32\iisreset.exe" /noforce

    2011-03-17 20:02:05 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:06 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:07 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:09 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:10 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:11 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:12 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:13 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:14 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:15 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:16 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:17 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:18 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:19 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:20 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:21 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:22 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:23 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:24 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:25 - Request for install time of Application Server Role, Web Server (IIS) Role

    2011-03-17 20:02:25 - Install process returned (0X41D=1053)

    2011-03-17 20:02:25 - [In HRESULT format] (0X8007041D=-2147023843)

    2011-03-17 20:02:25 - Last return code (0X41D=1053)

    2011-03-17 20:02:25 - Error: The tool was unable to install Application Server Role, Web Server (IIS) Role.

    2011-03-17 20:02:25 - Last return code (0X41D=1053)

    2011-03-17 20:02:25 - Options for further diagnostics: 1. Look up the return code value 2. Download the prerequisite manually and verify size downloaded by the prerequisite installer. 3. Install the prerequisite manually from the given location without any command line options.

    2011-03-17 20:02:25 - Cannot retry

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Hotfix for Microsoft Windows (KB976462)

    2011-03-17 20:02:25 - Reading version of the following file...

    2011-03-17 20:02:25 - C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\System.IdentityModel.dll

    2011-03-17 20:02:25 - The version is...

    2011-03-17 20:02:25 - 3.0.4506.4926

    2011-03-17 20:02:25 - Reading version of the following file...

    2011-03-17 20:02:25 - C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\System.ServiceModel.dll

    2011-03-17 20:02:25 - The version is...

    2011-03-17 20:02:25 - 3.0.4506.4926

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Windows Identity Foundation (KB974405)

    2011-03-17 20:02:25 - Reading the following string value/name...

    2011-03-17 20:02:25 -

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Windows Identity Foundation\Setup\v3.5

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft Sync Framework Runtime v1.0 (x64)

    2011-03-17 20:02:25 - Reading version of the following file...

    2011-03-17 20:02:25 - C:\Windows\assembly\GAC_MSIL\Microsoft.Synchronization\1.0.0.0__89845dcd8080cc91\Microsoft.Synchronization.dll

    2011-03-17 20:02:25 - GetFileVersionInfoSize failed (-2147024894)

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft Chart Controls for Microsoft .NET Framework 3.5

    2011-03-17 20:02:25 - Reading the following DWORD value/name...

    2011-03-17 20:02:25 - Install

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Wow6432Node\Microsoft\NET Framework Chart Setup\NDP\v3.5

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft Filter Pack 2.0

    2011-03-17 20:02:25 - Check for a subkey matching the following pattern...

    2011-03-17 20:02:25 - {*5140000-2000-****-1000-*000000FF1CE}

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft SQL Server 2008 Native Client

    2011-03-17 20:02:25 - Reading the following string value/name...

    2011-03-17 20:02:25 - Version

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI10\CurrentVersion

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft SQL Server 2008 Analysis Services ADOMD.NET

    2011-03-17 20:02:25 - Reading the following string value/name...

    2011-03-17 20:02:25 - DisplayVersion

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{68442820-C846-4E8A-8D53-EDEDD1511CDE}

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft Server Speech Platform Runtime (x64)

    2011-03-17 20:02:25 - Reading the following registry location...

    2011-03-17 20:02:25 - TypeLib\{D3C4A7F2-7D27-4332-B41F-593D71E16DB1}\A.0\0\win64

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - Microsoft Server Speech Recognition Language - TELE(en-US)

    2011-03-17 20:02:25 - Reading the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Speech Server\v10.0\Recognizers\Tokens\SR_MS_en-US_TELE_10.0

    2011-03-17 20:02:25 - Check whether the following prerequisite is installed:

    2011-03-17 20:02:25 - SQL 2008 R2 Reporting Services SharePoint 2010 Add-in

    2011-03-17 20:02:25 - Reading the following string value/name...

    2011-03-17 20:02:25 - Version

    2011-03-17 20:02:25 - from the following registry location...

    2011-03-17 20:02:25 - SOFTWARE\Microsoft\Microsoft SQL Server\Report Server SharePoint Addin\CurrentVersion

    2011-03-17 20:02:43 - Opening log file

    2011-03-17 20:02:43 - Opened action for user

    2011-03-17 20:02:43 - C:\Users\admin\AppData\Local\Temp\PrerequisiteInstaller.2011.03.17-20.01.57.log


    Friday, March 18, 2011 2:34 PM

Answers

  • Briteskies – Launch Server Manager, click on Roles (in the left pane) and check to see if the Web Server (IIS) role has already been installed.  In the right pane, if it shows as already installed and has a red icon to the left of Web Server (IIS), there may be an issue with one of the related services.  Under Roles listed on the right side, click on the Web Server (IIS) link to open the management Summary of that role, then scroll down to the System Services section and review the related services shown.  The IISAdmin and World Wide Web Publishing services may be stopped.  Ensure that all services with a Startup Type of Auto are started, or start them.

    -Ken

     

    • Marked as answer by KeFang Chen Friday, March 25, 2011 1:35 AM
    Thursday, March 24, 2011 5:42 AM

All replies

  • Briteskies – Launch Server Manager, click on Roles (in the left pane) and check to see if the Web Server (IIS) role has already been installed.  In the right pane, if it shows as already installed and has a red icon to the left of Web Server (IIS), there may be an issue with one of the related services.  Under Roles listed on the right side, click on the Web Server (IIS) link to open the management Summary of that role, then scroll down to the System Services section and review the related services shown.  The IISAdmin and World Wide Web Publishing services may be stopped.  Ensure that all services with a Startup Type of Auto are started, or start them.

    -Ken

     

    • Marked as answer by KeFang Chen Friday, March 25, 2011 1:35 AM
    Thursday, March 24, 2011 5:42 AM
  • Thank you. after looking in the manager I found that I was getting an error with Event ID 10016 from DistributedCOM. after fixing this error I was able to move forward with the installation.

     

    using this post help me fix the DCOM error

     

    http://www.windows2008forums.co.uk/event-id-10016-from-distributedcom-p132.html

    Monday, March 28, 2011 1:25 PM
  • I had exactly the same issue with Winows Server 2008 R2 in WMWare + Sharepoint 2010.

     

    The reason is, that iisreset was unable to stop services in time (20s). More precisely, all services were stopped except for one:

    Net.Tcp Port Sharing Service

    I killed this service  (and ev`ery other service related to IIS just to be sure) manually and suddenly the installer was able to proceed.

    • Proposed as answer by Skoel Friday, October 19, 2012 9:44 AM
    Wednesday, May 18, 2011 12:37 PM
  • The reason is, that iisreset was unable to stop services in time (20s). More precisely, all services were stopped except for one:

    Net.Tcp Port Sharing Service

    I killed this service  (and ev`ery other service related to IIS just to be sure) manually and suddenly the installer was able to proceed.

    This worked for me!
    • Edited by skeltonr Friday, October 14, 2011 4:46 PM
    Friday, October 14, 2011 4:46 PM
  • I got the same problem, while running the prerequisites tool on a SBS2008. I figured out, that the tool does an iisreset /noforce, which did not work. So I did a "iisreset" to force the process manually. After this, the tool worked fine.
    • Proposed as answer by Milo1250 Saturday, November 16, 2013 8:33 PM
    Wednesday, December 14, 2011 12:48 PM
  • I had exactly the same error message.

    However the cause was different

    It was caused by MSMQ Corruption.

    See this article for details of how to solve it

    http://code-journey.com/2009/the-iis-admin-service-or-the-world-wide-web-publishing-service-or-a-service-dependent-on-them-failed-to-start-0xc00e03f1/

     

    • Proposed as answer by pawksawd Tuesday, January 24, 2012 12:37 PM
    Tuesday, January 24, 2012 12:37 PM
  • WebDAV Publishing wasn't installed.  Installing it fixed this error for me. 

    FYI - after running PrerequisiteInstaller, Setup finished with "Microsoft SharePoint Server 2010 encountered an error during setup.  One or more required Office components failed to complete successfully."  I could not tell from the setup log what the exact problem was.  I ran run the SharePoint 2010 Products Configuration Wizard, which completed successfully.  I setup my site normally.  My point is, if you get this error, you may be able to continue without a showstopper problem.

     

    Monday, July 09, 2012 3:56 AM
  • server 2012 and SP2013. was online windows update enabled but kept failing. tried removing from domain as someone suggested but no luck. Manual install worked thanks to this article.

    http://social.technet.microsoft.com/wiki/contents/articles/14582.install-sharepoint-2013-prerequisites-offline-or-manually-on-windows-server-2012-a-comprehensive-guide.aspx

    • Proposed as answer by xyee Wednesday, December 05, 2012 12:03 AM
    Wednesday, December 05, 2012 12:03 AM
  • After searching for solutions and trying all kinds of avenues, I realized that my Active Directory account was not in the local machines Administrators group.   Adding my active directory account to the local Administrators group on the machine solved this issue.


    Greg

    Tuesday, February 19, 2013 9:50 PM
  • I had exactly the same issue with Winows Server 2008 R2 in WMWare + Sharepoint 2010.

     

    The reason is, that iisreset was unable to stop services in time (20s). More precisely, all services were stopped except for one:

    Net.Tcp Port Sharing Service

    I killed this service  (and ev`ery other service related to IIS just to be sure) manually and suddenly the installer was able to proceed.

     Thank a lot. This worked for me, too.
    Wednesday, September 25, 2013 6:04 AM